Recommendation - Disable Mouse Scroll Wheel Inputs for Drop Down Selection Buttons


#1

I have a small recommendation that would go some way to protecting me from myself.

I use a mouse with a scroll wheel, which I find very useful when scrolling up / down documents and for easy image zooming operations. However, the wheel is ‘diabolical’ when either the SGP Sequencer or Control Panel is displayed. It only takes an inadvertent touch of the scroll wheel while the mouse is hovering over any of the drop down selection buttons to make accidental changes. You do not need to click, just hover over, the buttons. It can also occur with a simple accidental knock of the mouse. Although I caught this early, I noticed an accidental change of a ‘Light’ frame selection to a ‘Dark’ frame, and a change of an intended ‘720 second’ exposure to ‘1 second’. I would prefer any changes to settings within the Sequencer and Control Panel to be much more deliberate - i.e. remove the ability of SGP to respond to mouse wheel inputs when hovering over drop-down selection buttons.

Just a suggestion. Otherwise I will need to tape my fingers away from the wheel …

Regards
Dean


#2

This is normal Windows behavior. I would prefer to stay inside of that is normal vs changing things to be abnormal when it comes to UI elements that way things are similar across multiple applications. Otherwise transitioning between different applications feels weird as things don’t behave as normal.

I believe most mouses can be set to turn down the sensitivity of the scroll wheel.

Thanks,
Jared


www.mainsequencesoftware.com