Remove warning message when starting sequence?


#1

Hi there,

is it possible by any configuration to remove this warning message when starting the sequence ?
“Do you want to start your telescope when the sequence begins ?”

image

we launch the sequence from an external application and this message is bugging us.
Thanks.


#2

I agree that there should be an option to remove this kind of messages, there’s also the message about camera temperature if camera is still cooling, there should be an option to automatically wait for correct temperature without having to get the message.


#3

I sometimes get this message even though the scope is not parked. Using v3.0.3.140 and EQMOD v2 on two different setups and it happens on each. Possibly, it has only started happening after upgrading to v3.0.3.140. It doesn’t happen all the time and each time the mount has been parked while SGP is open but I’ve unparked it in EQMOD before running or resuming the sequence. It’s as if SGP has not received the “unpark” notification (if there is one from EQMOD?) or has not checked the mount’s status.


#4

bugs me as well


#5

The warning message is there to warn the user of something that will stop the sequence running. Removing the warning message means that the sequence still won’t run but the user doesn’t get any feedback.


#6

SGP only needs to unpark the telescope at the beginning of a sequence w/o asking. There could be a setting for that.

Kind regards,
Horia


#7

The messages are there to let you know that a discrepancy between connected equipment and your settings exists. This could mean that you have some options to slew selected and no telescope connected. Or options to move the focuser and no focuser connected. The alternative would be to have a “ok, I know what I’m doing, continue” option but that very well lead to another post titled “SGP didn’t slew my telescope”.

Thanks,
Jared


#8

Hi Jared,

If this should happen, then sure, the sequence cannot start and user interaction is needed.

The message I am seeing – and the message shown at the beginning of this thread – reads:

StartScope

i.e. SGP just asks for an OK to unpark the telescope. I would normally klick OK, SGP would normally unpark and continue. This is not an unconnected equipment issue and, for those of us willing to do so, there should be an option in SGP like “Auto unpark scope at the start of a sequence”.

As I am mostly using SGP as an automation tool, I would even push this a step further and would ask for the option to run a sequence from the command line, like this:

“…\Sequence Generator.exe mySequence.sgf /run /y”

/run would mean:

  • connect all the equipment (like the “Tools” – “Connect All Equipment” option)
  • reset sequence but preserve progress (like the “Sequence” – “Reset Sequence (Preserve Progress)” option)
  • open the roof/activate the dome, if necessary unpark the telescope
  • set the filter wheel to the filter selected for centering (there is no corresponding function in the actual version)
  • wait for the camera to cool down
  • run the sequence

/y would mean:

  • answer with an “yes, continue” all questions reasonably asking for a confirmation.
  • do not continue and actually bring the system to a safe state (that would be the normal End of Sequence state) if the issue is “There is no water in the pool. Do you really want to jump?” or equivalent.

Kind Regards,
Hora


#9

Absolutely, no warning message and this simple way of launching SGP via command line would be great for those of us running SGP in a remote observatory with a big time difference (we would like fully automated start to avoid waking up at night to launch the sequence. We run our observatory in Chili remote controlled from France).

Thanks, Jared, for considering the request.


www.mainsequencesoftware.com