Routine crashes of SGP


#1

I am virtually unable to run SGP on my ‘observatory’ laptop because it crashes whenever it decides that it has lost contact with the main camera. Sadly there have been no responses to my queries.

The following error appears at every connection:

[03/09/2016 09:27:01] [DEBUG] [Main Thread] Error loading notification settings! Could not find file ‘C:\Users\Lawrence\AppData\Local\SequenceGenerator\Sequence Generator Pro\notifications.sgd’.

Is this a real error? It repeats many times and is at the start of the log files.

If this cannot be solved/explained then I cannot go on…

Lawrence


#2

That’s not really an “error” as such. Similar log notes like that appear in every one of my logs as well.

If you are having an issue with communicating with your camera make sure that your usb cables and any hubs are working properly. How is the camera connected to the computer? Through a hub? If something is causing a loss of communication with the camera that’s probably not a SGP problem.

Can you post the full log via dropbox or something like that?


#3

Thanks Joel - you are the first person to actually respond to a major problem… I’ll try to post.

sg_logfile_20160903092657.txt (23.0 KB)

again Thanks.

Lawrence


#4

There appears to be a problem with the ASCOM connection to the camera. At
this point I won’t be much help because I don’t have the technical
knowledge. It may be worthwhile to uninstall the SX main drivers and the SX
ASCOM driver, restart the computer, and re-install both drivers again.

One thing I did notice in the log that may not have anything to do with the
problem…the SPG log says that it is trying to connec to “Starlight Xpress
Main Camera #2”. Do you have more than one main imaging camera? In the
SGP camera chooser, do you have more than one SX main camera listed?


#5

Hello Joel
Firstly - I am really grateful for your help.
I am using a Lodestar#1 (the original Lodestar camera) as my guide camera. I am using an Ultrastar (also SX) as the main camera (for this configuration). I am using PHD2 to guide, and as I ascend the knowledge curve I have been using PHD2 to guide the telescope and then start the imaging exposures via the Ultrastar on the main scope (AT6RC). That’s what these logs are all about.

My later problem will be to try to configure my main scope (RCX400 12") to also run with SGP/PHD2/AI. First things first.

So this configuration uses Lodestar#1 as guide and Ultrastar as main camera (2).

Does this answer the questions?

Lawrence


#6

Can you help with this as well?

Some weeks back SGP crashed like never before. This is all I can get when I run it. I cannot restore the proper display.

Lawrence


#7

What do you mean by “proper display”? The Histograms and Frame and Focus
modules are undocked. If you drag one of them to either side a little
square will appear and you can dock the module to the side. You can also
dock another module under or over any other module that is there, or
combine modules so they are tabbed together. If you go to View/Docking
Modules you can choose which modules you want to display on the desktop.


#8

On my other laptop, the two modules hold nicely within the left side and
with a menu for image adjustment. These two modules do not dock. They
do offer the small square but that square is not accessible. Maybe I
have not used the right technique?

Lawrence :-[


#9

Can I note that the smiley was not the one I selected! Please ignore…!

Yet another crash stopped me from re-trying your suggestion. I copied the crash message in case it helps?

Lawrence


#10

At this point Jared or Ken will have to weight in as I am at the end of my
technical knowledge. However, it seems like there are so many things going
on that I would probably completely start over with the computer. How old
is the computer and what are the basic specs? I would perhaps uninstall
SGP and all related equipment drivers, including the ASCOM 6.2 platform and
reinstall everything. But wait until Jared or Ken have a say…


#11

@Lawrence

Had some time to read through this… Unfortunately I don’t think I can be of much help. The logs you provided don’t show any suspicious activity. As for the constant crashing, please make sure that all your native and ASCOM drivers are up to date. Other than that, I am not sure. We no widespread reports of crashing behavior. SGPro is dependent on .NET 4. It is pretty hard to corrupt the .NET interpreter, but we have seen it before (just a couple days ago actually).

The position of docked windows does not save until you close SGPro (something we’ve been meaning to change).

Ken


www.mainsequencesoftware.com