Safe to go back to Windows 10 Pro?


#1

When the Win 10 updates blew up in the first week of Jan, I was in the middle of a sequence and decided to re-install Win7 Pro x64. I do miss the multiple monitor support on remote desktop and wondered if it is safe to go back to Win10.

Does anyone know of any remaining Win10 issues arising from the Jan 3 update that were not subsequently fixed by the subsequent MS updates?


#2

That was resolved quite awhile ago.


#3

My W10 Pro (64bit) obsy PC with all current updates works absolutely fine.


#4

Hello
For me too, SGPro 3.0.1.0 works well under Windows 10 x64 Pro up to date.
Clear Skies
Claude


#5

thanks - I was really thinking more about all the peripheral drivers out there - I’m confident that my TSX/SGP/PHD2/OPTEC applications will work. I was just wondering if there are still legacy issues out there with other cameras, focusers, filter wheels etc.


#6

Hi Buzz,

have on Win10 QSI690, Alnitak FlatPanel, Mircotouch Focuser, Stickstation, Unihedron SQR meter running without any issues. Main change: use the beta version of bugfix SW from ascom-standards.org.

Michel


#7

Thanks Michel - this highlights the dilemma - I understood that the ASCOM DCOM utility was not required with the latest MS update in late Jan.

My goal is to go back to Win 10 only if it is a workaround-free system, not only for my own hardware at this time but also for the various simulators, hubs and popular peripherals.


#8

Buzz,

got it. It did not take the effort of a clean new installation. So for that I can’t help right now. Still have some issues with the latest big win10 updates, which do not install on some of my equipment. :frowning:

Michel


#9

Here is what the ASCOM standards site now shows on it’s front page:

ALERT: Windows 8.1 and 10 January 2018 Security Updates
UPDATE: Windows 10 v1709 KB4058258 Appears to Correct Previous Problem

On Windows 8 and 10, the January 2018 Cumulative Security Rollup KB4056898 (W8.1) and KB4056892 (W10 1709) caused connectivity issues between ASCOM components. Inbound connections to EXE drivers or API interfaces are affected. DLL based drivers are not affected. This was caused by a change in security that affected an obscure feature that was introduced for an astronomy product many years ago. As of 31-Jan, it appears that Microsoft has reversed out the security change in KB4073291 (w10 1709), which may be included in the 31-Jan KB4058258 (W10 1709). We believe that those of you who changed the authentication level will still be OK, and those who used the ASCOM provided tool can run it again and revert the security level back to its original. Be sure you have the brand new KB update for your OS/version before doing this. No changes to any drivers will be needed going forward.


#10

Thanks Chris - that is a clear message on ASCOM-related issues - I hadn’t realised they had updated the .org site. If none of the mainstream applications (planetarium, automation, processing and acquisition) remain affected, it looks like I’ll spend some snowy evenings upgrading back to W10.


#11

Fix here that I used

Dave

http://forums.dc3.com/showthread.php?11182-ALERT-Windows-10-Update-KB4056892-Reported-Problems&p=67734#post67734


#12

Davy - thanks, but if you scroll up, you will see that this is no longer required.


#13

that seemed to be limited to specific ascom situations, notably theSkyX

i didn’t have any connectivity or ascom related issues with SGPro on windows 10 pro all through that debacle.

Brian


#14

My Win-10 laptop (with all self-updating updates :unamused:) continues to randomly re-start itself. If this happens during a run it would be a real problem. I’ve so far not been brave enough to chance it.

Lawrence Harris


#15

Well, I just updated to W10 and had the same. I disabled fast start and it seems to behave itself. The one problem remains, how to stop it restarting in the middle of the night and leaving my obsy exposed.


#16

Hi Buzz,

still I discovered not this topic on my win10 installation, but I searched for this topic in the past:

This should disable reboot mechanism. But still with your favor it’s not a built-in solution, but a hack again.

Michel


#17

If you suffer badly with this you can upgrade to W10 Pro and prevent the updates using the Group Policy Editor. It is a simple task and I did a YouTube video showing how to do this, link below.


#18

There’s an active hours option in Windows Update which allows you to specify the time when you do NOT want Windows to automatically restart. It’s normally set from 0800 to 1700. If you set it so the active time is overnight it may help. Try something like 1700 to 0900. The maximum is 18 hours.


#19

Thanks Ray

I’ll consider this as an option.

Lawrence


#20

Thanks Chris

Most odd - for the last few years I have run all my applications with administrator privileges.
I just updated to Win 10 and I can only connect to TSX if all the applications do not have admin setting. I didn’t do this before when I had a clean install, or in Win 7. Go figure !


www.mainsequencesoftware.com