Sequence fails, SGP hangs trying to change filters - 2.4.2.5


#1

I’ve been working on getting my new ATIK 383L+ and EFW2 filter wheel working. Last night I had a test sequence of the Ring Nebula running with 20 images in each LRGB filter. The sequence started normally, plate solved, focused and completed the luminance frames. It then stopped saying it could not change the filter. SGP was frozen and non-functional at that point and I had to use the task manager to close the program. I restarted the laptop and restarted the sequence. The camera cooled and the filter wheel changed to red as it was supposed to and completed the 20 red frames. The same problems occurred when attempting to change to the green filter. I had to forcibly close SGP again. No warning dialog boxes were on the screen such as a crashed driver. Any ideas? Log attached.

Chris

SGP log


#2

Something seems wrong with your filter wheel. In some conditions, it is never reporting that it is done moving and SGPro times out.

[8/13/2015 3:31:17 AM] [DEBUG] [Sequence Thread] Moving filter wheel, isMoving, check 1…
[8/13/2015 3:31:48 AM] [DEBUG] [Sequence Thread] The filter wheel is taking a long time to change filters. Aborting…
[8/13/2015 3:32:50 AM] [DEBUG] [Sequence Thread] Error setting filter position! Cannot continue sequence!


#3

Sorry, I know this won’t help, but I also had an Atik EFW2. It acted up exactly in the fashion you report.
I tried many things to get it to work with SGP, but it was unreliable.
I also operated it with the native software Artemis, better but still not reliable.
I don’t think this is caused by anything in SGP. I returned the EFW2.
I’m currently using a Starlight Xpress filter wheel and it’s totally stable with any software I use to run it.


#4

I’ve been using an Atik efw2 with Sequence Generator before SGP was SG"Pro" and never had a problem with it.

Sent from my Android phone and typed with fat thumbs.


#5

Some follow up:

Last night I powered everything on and ran a set of flats. The filter wheel ran normally and changed when it was supposed to. The sequence completed successfully.

I then restarted everything, just to make sure everything was fresh. I started my sequence, which was to start with filter 2 (red) and it failed right off the bat with the same error. I moved the USB cable to a different hub, restarted the laptop and equipment again. Same result, failure saying it could not set filter position. I did notice that the filter module in SGP was always saying the wheel was moving when it was not.

So, pretty frustrated at this point. I was looking around at the settings in SGP and decided to put a 10 second filter change delay. The sequence then started and ran without problems, changing filters as needed. I put in a second target while the first was running with four more filter changes and it completed them as well.

I have only tested this out once but it seemed to work so far. We’ll see if it continues…

This now makes two pieces of equipment I have to add delays for because ASCOM polling (correct term?) doesn’t seem to work. The other is my CEM60 mount. I have to put in a 60 second settling time or it fails to meridian flip. The flip actually happens but SGP thinks it is done while still slewing and fails because it has not yet changed pier side and the driver is not correctly reporting a slew in progress. Unfortunately there seems to be variation in the interpretation of the ASCOM standards throughout the industry. I’m not trying to blame anyone in particular, just noting the problem.

Chris


#6

I had the same issue during the last couple of nights (using EFW2 icw ATIK383L+), used filter delay of 5 secs. I’m using SGP version 2.5.0.23.

It is strange that it happened in the middle of sequence of shooting 10 red frames (so why did it try to change the filter???)

What is most annoying: it does not abort the filter change attempt and to start the recover mode… it just hangs and wastes another scarce Dutch clear night…

I’ve now increased the delay time to 10 sec. and will try again tonight…


Atik EFW2 Fails to report move complete + SGP failed to notify
#7

Over the last couple of months I’ve been experiencing the same thing that the OP described with my Atik EFW2: SGP calls for a filter change and the FW reports it is “moving” even though the filter wheel has stopped on the correct filter. After a few minutes SGP will immediately abort the sequence. I should note that this EFW2 is about 5 years old and it has worked with SGP without issue that whole time.

This happened the first time I attempted a sequence last night right off the bat. Here is that log file. Without cutting power to the FW or any other equipment, I closed SGP and restarted SGP. When I connected the filter wheel it reported the correct filter and the sequence ran fine all night long (2 different imaging filters but changing to LUM for autofocus and meridian flip functions).

I’ve been trying to track this down for a couple of months now. The problem has occurred with different USB hubs and cables, so I doubt it’s a communication problem. I’ve talked with Atik about this and they seem fairly convinced that I just need a new elastic band that goes around the internal filter disk. I don’t know why that would make any difference, but Atik is sending me a replacement band. We’ll see.

In the mean time I will also add a delay to see if that helps, but again I’ve had no problems with the FW and SGP for years until the last couple of months.


www.mainsequencesoftware.com