Sequence fails to start looking for focuser


#1

Last night for the first time, using new version 3.0.3.169, my sequence with new user profile refused to start with message no focuser.

This new setup does not have a focuser at all. Nothing I did could make this work. Looking at the log file for the test session I have now with a completely new profile with no focuser listed anywhere has this message:
[03/17/19 19:46:59.680][DEBUG] [Main Thread] New focuser object (NiteCrawler Focuser) dispatched…

I have a different telescope with the Nitecrawler I did setup in a sequence. Some configuration file somewhere is telling SGP a Nitecrawler focuser is involved. This cost me over a 1/2 hour trying to clear this up.

Finally I just changed the sequence from no focuser to simulated focuser and connected that. Then a sequence could run. I need help correcting this.

thanks for any help


#2

Is the setup with your nitecrawer focuser in your default profile?

Thanks,
Jared


#3

Thanks for responding.

Yes, my default profile included the nitecrawler. Why should that matter if I switched to another profile with no focuser?

The only thing that worked so far was to delete all of the x.confg files in the app_data/sequence_generator dir.

Then starting new SGP session, there was not a default profile any longer. I was able to recover the profiles I had and started with a new one for my telescope with manual focuser. I made up a sequence to take some darks and bias frames last night and this time it worked. There was not a halt due to lack of a focuser.

Is this some type of a bug possibly? It seems we should not be bound by what’s in the default profile should we, especially when we can make separate equipment profiles?

SGP has performed wonderfully for me and allowed me to automate capturing data so well. I have not run into this issue before as I have been using only one telescope with the nightcrawler for a couple years now.

-Steve


#4

It shouldn’t…but it’s a current bug in SGP that needs to be addressed.

Thanks,
Jared


#5

Thank you for the heads up! So far, once I cleaned out all of those old config files, I was able to setup a new profile without the focuser. Now I’ll have to make another new profile with the Nitecrawler for my other telescope. By the way, the auto focus does work very well for me with the Nitecrawler.

thanks for all the good work,

-Steve


www.mainsequencesoftware.com