Sequence Generator Pro Beta cannot dismiss registration splash

Hi, I’ve used SGP 2.x for a couple of years now, and have previously used a trial of 3.x.

I recently tried to install Sequence Generator Pro Beta, following uninstallation of a previous 3.x and the splash screen says trial expired.

Clicking on dismiss, it throws an exception - meaning I cannot play with any 3.x beta on that particular pc (windows 10 x64). I’ve tried uninstalling and reinstalling without luck.

Reinstalling Sequence Generator Pro, this works fine in ‘lite’ mode, so the betas aren’t working for me.

Is there a way around this?

Can you provide the details of the exception by clicking the show details button?

Sure (after reinstallaing over previous 3.x ‘lite’)…

I’ve updated .net 4…?

Assembly Version:
Win32 Version: 4.8.3752.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll

Assembly Version:
Win32 Version: 4.8.3825.0 built by: NET48REL1LAST_B
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll

Assembly Version:
Win32 Version: 4.8.3752.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll

Assembly Version:
Win32 Version: 4.8.3752.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

Assembly Version:
Win32 Version: 4.8.3752.0 built by: NET48REL1
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

Assembly Version:
Win32 Version:
CodeBase: file:///C:/Program%20Files%20(x86)/Sequence%20Generator/RestSharp.DLL

Anonymously Hosted DynamicMethods Assembly
Assembly Version:
Win32 Version: 4.8.4042.0 built by: NET48REL1LAST_C
CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_32/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the section.
The application must also be compiled with debugging

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

There was not any information about the actual exception encountered?

Here’s a screenshot:



Please give the beta a try. This should be resolved.

Ok I’ll give it a try.

Is it wise to uninstall the previous version first or is upgrading over the top advised?

No need to uninstall anything

Ok, that has worked and SGPro beta is now running in lite mode (with trial expired message etc. popup).

Although having said that, I’ve noticed the ‘no update available’ message and about screens do not tally with the versions:

This is because you are using a beta. Messaging is a little confusing, but anything above the stable release version will qualify as the most recent version. If you want SGPro to check for new betas instead, you can turn that on in Tools -> Options