Sesto senso won’t connect


#1

Hello,

Please help.

Windows 10

The Sesto Senso software connects just fine.

When using SGPro i get the error message
'Retrieving the COM class factory component with CLSID {2B05B806-4F74-4920-8908-077AEBC28B89} failed due to the following error: 8007000b. An attempt was made to load aprogramwith an oncorrect format> (ExceptionfromHRESULT:0x8007000B)

Any ideas please

Thanks

Ian


#2

Usually that kind or error indicates an installation problem. Is there an ASCOM driver for this device? If so, have you installed it?


#3

That exception is usually thrown if you mix 32bit and 64bit versions of software. For example if SGP runs in 32bit but you have installed the 64bit version of the driver or vice versa.


#4

Hi,

Thanks for your recommendations.

I updated the firmware at now it works.

Thanks again

Ian


#5

Hey Misterp,

I am having the exact same problem that you had with your Sesto Senso not connecting to SGPro.

Which firmware did you update? Was it the Sesto Senso Firmware?

Also could you tell me which ASCOM driver did you install? Was it the Sesto Senso ACSOM driver?

Thanks,

Liam


#6

Hi Liam,

I updated the firmware on the focuser, if you go tonPrimalucelab.com there are instructions there.

I also used the latest Ascom driver,

Hope that helps

Kind regards

Ian


#7

I just tried to upgrade the firmware of the Sesto Senso - my problem seems to be that the COM port that the Sesto Senso is using (COM 6) isn’t appearing on the dropdown list in the Sesto Senso Firmware upgrade application. Only “COM 1” appears. So I don’t seem to be able to upgrade the firmware… Hmmmm

Not sure where to go from here - seems to be a bug in the firmware updating application


#8

I retried the steps a few times and eventually the correct COM port appeared in the dropdown menu in the firmware updating application. However after selecting the firmware .bin file I get a message in the TERMINAL window saying the COM port is already in use… Nothing else is running except the Eagle software. Any ideas? I have attached screen grabs.

Regards,

Liam


#9

On Primalucelabs’ website there is a chat option, you could try that

Ian


#10

Thanks for the help Ian.

I managed to complete the firmware upgrade. The answer was in my last message where I said “Nothing else is running except the Eagle software.”. As soon as I closed the Eagle manager software the COM port was detected by the firmware updater application… So the Eagle manager software was holding on to the connection to COM 6 and not letting the Sesto Senso use it for the firmware upgrading…

Unfortunately I still have the same problem in SGP…


#11

Not sure that is the correct software.

You might be looking for the Eagle unit not the focuser


#12

I installed the latest ASCOM platform V6.4 and then installed the Sesto Senso ASCOM driver.

I’m also running SGP v3.

Do you think one of these is wrong? Or is there a setting I’m missing maybe?


#13

When I did this I initially got a different error message so I gave up for a while.

Then when I tried again averything worked ok.

Could you try connecting the camera and filter wheel first.

Good luck

Ian


#14

Ended up being a hardware issue with the USB board… Sending it off for repair now.

Thanks for the help,

L


#15

I am having to same issue. Was it the Sesto Senso USB board that was faulty and did they repair it or replace it?

Mine works just fine with the Primaluce Lab software, but SGP doesnt seem to like the ASCOM driver.


#16

Hello,

After a few attempts mine just connected, no new hardware required

Ian


#17

I solved the problem I was having. In the supplied software from Primaluce Labs I noted the COM port and I noticed that SGP was defaulting to a different COM port. After I got the unable to connect error in SGP the SESTO SENSO ASCOM setup dialog was displayed. I clicked on the Communication tab and set the Port to the right one and after clicking OK I was able to use the Focus Control.

Now that I am over this hurdle I am really happy with this device, works a treat!


www.mainsequencesoftware.com