Setting Backlash in Autofocus


I’m trying to set backlash compensation on 2 of my scopes. As the temperature drops the focus moves IN so I think I would set the direction for backlash compensation to OUT. On the other hand I think SGP always focuses from high numbers to low numbers. On one scope the numbers go from low to high as the focus goes out. On the other scope the numbers are reversed - they go from high to low as the focus goes out. So, what should the settings be for each focuser. I’m assuming backlash will be taken up only when the scope changes direction.

Also, I’m assuming that I don’t need to get the exact number of backlash steps correctly - as long as I put a number larger than the actual amount of back focus I should be ok. Is this correct? Thanks for any help.


It’s hard to describe with all the in’s and outs - but the main thing you do not want to happen is for backlash to be invoked at every step of the autofocus curve. You would be able to tell when that happens.

Some scopes, like sct’s, have a preferred direction of focus - but others may not matter as much.

If you are using realtime temp. based focusing then yes you would also not want to have backlash compensation due to temperature change.

If there is a conflict then see if somehow you can change the direction of the numbers so it all goes from high to low.

Yes - it should be ok to go too big on backlash compensation. As long as the backlash is removed and everything is repeatable it should be ok.



Thanks Frank. However, I’m missing the most basic thing. If my focuser is at 0 when all the way in and the numbers rise as the focuser comes out - do I set backlash compensation for IN? Then, if the numbers are reversed ( ie focuser at 0 when fully extended ) I set it at OUT.

I’m having trouble working out if this is correct or if I’ve got it backwords.


The direction, IN/OUT, is the direction of the final move of the focuser. More info in our docs:

In most cases you want to use “IN” as this will pull the draw tube “IN” which is against gravity (in the non reversed case). For a reversed focuser you’d want to use OUT to have the last move done against gravity. However reversed focusers and backlash don’t play nice with autofocus as you’d be invoking backlash compensation quite a bit. If possible I would recommend reversing the direction of the focuser in the ASCOM driver if they have that capability.



Thanks Jared - that makes sense. There was an option to reverse the direction of the focuser in an earlier ASCOM driver but its not in the latest version. I’m contacting the company to see if they can put the option back. If not, I’ll have to use “OUT” . I guess it should still work.


I think it’s problematic for the focuser to change the direction of its numbering - either in its own numbering or via ascom - because you would really want to change the current position number also.

If the range of the focuser is 0-10000 and you are at 1000 - and you suddenly say the focuser is numbered the other way - then the new range would be -8000 to 2000.

Alternatively when you changed the numbering you could cause the current position to change also - so the range is still 0-10000 but instead of being at 1000 you would suddenly be at 9000.

My FocusMax system does not allow changing the numbering system - but it does change what “in” and “out” mean. Many levels involved with the focuser do that also - sgp, the ascom driver, and the hardware itself will do this. But the numbering of the focus positions and the range never changes.

That’s why going from high to low during the focus curve could lead to a conflict that can only be resolved by changing the motor wiring or something - which is what I did.

But if high to low happens to match the way your system should take the focus curve - it is all fine once you get the in/out and backlash set right.



You can always mount the motor on the other side of the focuser. I just mounted my worm the other way round.

If in doubt, set the backlash figure to 100 or so and you will see the focuser move back on itself.


Thanks for the information.

Frank - It wasn’t just changing the numbers. The original ASCOM change allowed the focus motor to switch between clockwise and counterclockwise, so I figured that would fix the problem. Of course thats been dropped in the latest driver so I’ve contacted the vendor.

Buzz - The documentation says to attach the motor to the fast side (1:1 side) of the focuser. So, thats why I didn’t switch it.

Assuming I can’t change anything is there a problem just setting the backlash to “OUT”. I know it will then apply backlash to every focus change but I should still end up in focus - right? Thanks for helping me through this.


Technically “yes”, but in practice “maybe”. Really depends on how your backlash behaves. I would give it a shot and see what happens.



Jared, could you explain how the backlash is used? It seems to me that if the algorithm always approached the focus from the same direction that backlash compensation might not be needed. As I recall, the current code offsets the focuser by an amount equal to half the number of steps times the step size and then proceeds to move in one direction to generate the V curve. After determining the focus point, if the algorithm were to go the starting offset and then moved to the focus point wouldn’t that negate any backlash?


I just heard from the vendor, so I thought I would post here in case anyone else has the same motor/controller. I use a usb_focus system and they no longer have this type of control in the ASCOM driver. Instead they have a telescope control program that allows you so set the motor to clockwise or counterclockwise. So, you just connect, select, save and disconnect. You can then close the program as this setting is now kept in the controller. :slight_smile:


I was thinking more radically - mounting the entire worm block around the other way. The fixings tend to be symmetrical and I cannot think of a reason why it wouldn’t work but I’m sure someone will tell me!