SG Pro and MyT mount


#1

I am trying to connect my Paramount MyT mount through the Ascom driver on SG Pro, however I get the following message when connecting - “The SkyX was selected but it does not appear to be installed or configured for scripting.”

I believe I have the correct Ascom driver dowloaded from the Software Bisque site, so not sure where to go from here.

Thanks,
Khushrow


#2

I’ll reply here too -

Is TheSkyX running and connected to the mount? Paramounts must have it running for the ASCOM driver to connect even if you aren’t using TheSkyX for anything else. Here’s how my driver is configured:

Image44

Chris


#3

Hi Chris,
Thanks for the response. I get the same error message when trying to connect to the MyT through the Ascom driver in TheSkyX. I have been using TheSkyX to control the MyT, but would like to make the move to SG Pro.
Thanks,
Khushrow


#4

I get this message if any of my programs have different admin levels. I run all my programs (TSX, PHD2, SGP) as admin and the problem goes away. If you right-click the program icons, you will find a tab that says ‘run as admin’. I enable that and everything is cool.


#5

Thanks for the suggestion, I ran it as admin as you suggested and now I do not get the previous error message. However, the mount still does not connect, instead get a spinning wheel as if it is trying to connect but just hangs. A question, I checked in control panel and I see the MKS5000 connected to COM5, or if I move to different USB ports to, it moves to other COM settings, so the laptop sees the mount. Is there a COM port selection once ASCOM mount is selected, to change the COM port that gets assigned?

Thanks,
Khushrow


#6

Khushrow - I would do it in stages. It should all use the same COM port. First, get TSX to connect to the mount. If it can do that, ASCOM should too. You do not need to change the telescope settings in TSX. When you first use the ASCOM driver for TSX, you need to set it up. You click on the properties and tell it what you have. You need to select the right version of TSX, tell it you are doing PulseGuide etc. There are instructions on the settings by clicking the help tab. If you are still confused, I’ll fire mine up tomorrow and put up a screen grab.


#7

Thanks for the suggestion to look at the help menu. I think I have it working now. I connected to the MyT directly as I normally did with TSX, and then connected SG Pro to the Telescope using the Ascom driver. My mistake was trying to connect TSX also using the Ascom driver, which I now believe is incorrect.

Khushrow


#8

Khushrow - you should be able to connect via the ASCOM driver too. When you connect via ASCOM, if TSX is not running, it opens it and connects automatically. I wrote a small application for my observatory and I fire up TSX this way from my application.


#9

I will try your suggestion and let you know. With my focuser I notice this is exactly what happens, when I connect through SG Pro, the Focuslynx commander opens up. Thanks for all your help. Appreciate it.

Khushrow


#10

Sorry for hijacking the thread with a slightly different question, but I noticed on your posted ASCOM settings image that you have selected Direct guide as the guiding option. Do you guide your mount using a third party auto guiding software like PHD2? I am hoping you say PHD2 :slight_smile: Does direct guide work with PHD2?


#11

Yes, if I connect to my mount in SGP and TSX is not already running, the ASCOM driver will start it up.

But there is no way for TSX to connect to the mount through the ASCOM driver. TSX connects directly to the Paramounts.

Chris


#12

Yes, I use Direct Guide with PHD2, but you have to have a Paramount. You can use Pulse Guide as well. They both work. SGP cannot interface with TSX in any way to control guiding so PHD2 must be used.

Chris


#13

Thank you for your response Chris. Yes I own a Paramount Myt and been
having problems with guiding lately. I have a T Point model created and
enabled Protrack. I have not done PEC yet.

Would protrack interfere with phd2 guiding ?

Swaroop


#14

This really should be on the SB forum but to answer your question, I run ProTrack and PHD2. It gives a slight improvement on the guider RMS error, but more importantly, if PHD2 loses a star, or when you disable guiding during download to SGP, or during focusing in SGP, it keeps a better track. Last night, my RMS error was 0.25" with 8-second exposures. If I was not using ProTrack, I would probably have 2-4 second exposures to keep up with any drift - but with the risk of chasing seeing.


#15

Hi Chris,

I am now able to connect SGPro and PHD2 guide and TSX and have them work together. However I cannot get direct guide to work through PHD2. I can get direct guide working through TSX and its autoguiding tab. When I look at the telescope tab in SG I can see the mount RA and Dec positions and they update as I move the mount through TSX. The mount movement controls are greyed out in SG Pro and I cannot use these to move the mount through SG Pro. Also, when I try to calibrate PHD2 with direct guide enabled in SG Pro the star does not move. I can calibrate if I use the “On Camera” setting. Is there something else I need to enable to be able to control the mount through SG Pro and also to get it to calibrate using direct guide?

Thanks,
Khushrow


#16

The mount movement buttons in SGPro don’t work with TSX, if I recall correctly, they are not supported by the ASCOM Driver / API. It doesn’t matter, the ones in TSX work very well indeed.
For DirectGuide, there are two likely explanations; either you are bitten by the Windows 10 update just after Xmas or you have the TSX ASCOM adaptor settings incorrect. In PHD2, for the Mount, choose ASCOM Telescope Driver for TheSky.
If you fully update Windows 10, that problem will now go away. In the case of the ASCOM settings, these are mine:


#17

I am still on Widows 7, do you know of this issue exists with Windows 7? My settings are exactly as you show.

Thanks,
Khushrow


#18

I’m using Windows 7 Pro at the moment. I have not yet switched back to Win10


#19

Are there any settings in PHD2 that need to be set for direct guide other than selecting the Ascom driver for The SkyX in the mount selection? Is there a way to force mount movement through PHD2 to see if guide commands are getting through to the mount? I just do not see any star movement during cal. To confirm, I do not need to have the ST4 cable plugged in to try direct guide?

In PHD2 if I use “On Camera” as the mount selection and Ascom driver for the SkyX in the Aux selection then the cal works with the ST4 cable plugged in to the mount.

Thanks,
Khushrow


#20

You can guide three ways. ST4, PulseGuide or DirectGuide with a Paramount. In each case, you have to calibrate PHD2 using the same technique as guiding. Disconnect the ST4 cable, set up the ASCOM driver as in my earlier email and set up ‘ASCOM Telescope Driver for TheSky’. No need for an Aux connection. In PHD2, under the tools menu I think, you will find manual guide. You can move the mount, with guider commands. Set it to 5 seconds and you should see the mount location icon in TSX move. In fact, I would try this first, to prove that PHD2 is moving the mount, before trying to use SGP.


www.mainsequencesoftware.com