SGP 2.5.1.15 Hangs on Install


#1

Well my computer is equipment so in the Equipment Compatibility Forum

Retail user and 2.5.1.14 runs flawlessly until clouds show up. About an hour ago I upgraded to 2.5.1.15 and after the install it hangs and the splash screen never appears. I bounced back and forth a few times between .14 and .15 with uninstall, reboots, re downloads, and always the same with no go on 2.5.1.15.

I’m back at 2.5.1.14 and all looks good.

Windows 10 laptop.

No logs because no start


#2

What does the bottom left of the splash screen say when it hangs? About how long is it hanging for?

Thanks,
Jared


#3

I don’t get far enough to even see the splash screen.

I just see a little windows wheel go round and round. Nothing shows up
in task manager either.

I gave up after 5 minutes.


#4

Ah, gotcha.

Are you using a default sequence? If so can you attach it? We might have missed some compatibility settings between existing sequences.

Thanks,
Jared


#5

I should mention that my “main” laptop is down and I’m trying to get
this running on a backup. As I said 2.5.1.14 starts with no problem but
.15 gets nowhere.

Thanks


#6

I just installed and started SGP 2.5.1.15 and starts just fine. It also displayed the correct 2.5.1.15 version on splash screen. Also using Windows 10.

Peter


#7

Ya, probably something up with Steve’s default profile that is not in yours. Or maybe something is busted on clean installs? Although not much has changed from .14 to .15. Just some filter settings and handling memory better.

Anyways, just waiting for a reply on the default profile question.

Jared


#8

FWIW - I have been running a sequence in 2.5.1.14 in Win 10 and upgraded to.15 before continuing the session last night. SGP fired up with a default sequence last night and then I loaded the sequence I was progressing through. It did its stuff whilst I was asleep and have another 3 hours of data without any apparent issue.


#9

I also just updated to 2.5.1.15 last night and it ran perfectly on Windows 10.


#10

Jared did you get the attachment to look at?


#11

Steve,
I don’t see an attachment. If you replied via email that tends to remove the attachment.

Thanks
Jared


#12

Yep, I replied by email. Let’s do DropBox:

Sorry for the confusion and thanks.


#13

I should also mention that after what looks like a successful install of .15 (no Windows 10 error messages) and trying to run it leaves no trace in the SGP logs. Also the icon for “C:\Program Files (x86)\Sequence Generator\Sequence Generator.exe” is blank and not the pretty icon expected. The size of the .15 is 29,650KB


#14

Hm, something seems off with the install process. Do you have an antivirus? Maybe it’s messing with something even though our EXE is signed (which should make antivirus applications happy).

Have you tried uninstalling and reinstalling?

I’ll look into the SGF later this evening.

Thanks,
Jared


#15

Bingo! I disabled Avast, downloaded a fresh copy of 2.5.1.15, and
installed. With Avast off .15 runs. With Avast on…nada.

thanks for the help!


#16

That’s odd. If there is something in Avast that you can send us that shows
that it’s not allowing SGP to run that would be great to see if we can
track it down or get an exception with them.

Thanks,

Jared Wellman
Co-Founder and Developer

www.mainsequencesoftware.com


#17

I did a fresh install today on SGP. I see seventeen different named log
files have been written to today in the Avast folder.

I may have missed something but I see frequent references in the
autosandbox.log, probably one for each time I tried to start SGP with
Avast on.

6/13/2016 9:47:47 AM Autosandbox candidate: C:\Program Files
(x86)\Sequence Generator\Sequence Generator.exe
[Source: ]
[Opened by: C:\Program Files (x86)\Sequence Generator\Sequence
Generator.exe]
[Reason: 0x00020000]
–> Result: Sandboxing (NG component is not installed)
–> Instrumentation: Instrumentation inside sandbox requested

In GrimeFighter.log two of these on 6/10
[2016-06-10 01:10:10.031] [info ] [gf2client ] [ 1540: 4564] no rule
for uninstalled application {E3AFE4C0-18BD-4153-BF60-AD8B5B29A1A4}
(Sequence Generator Pro)
[2016-06-10 01:10:10.062] [info ] [gf2client ] [ 1540: 4564] not
enough data to create generic rule for uninstalled application
{E3AFE4C0-18BD-4153-BF60-AD8B5B29A1A4} (Sequence


#18

I have Avast running as my anti-virus and have had no issue installing or running 2.5.1.15 (or versions before this for the last 5 months or so I have been using Avast). This is on a W7 Home laptop. Neither do I recall setting anything specific in Avast to allow SGP installs.

Sorry if this throws a spanner in the works :slight_smile: .

Any logging I can do to help?


#19

After I understood that Avast was the culprit, I was able to tell it to
ignore the SGP directory for everything. SGP now runs like a champ.


www.mainsequencesoftware.com