SGP and Losmandy Gemini 2


#1

I have my G811 mount working perfectly with SGP through the Gemini ASCOM Driver. Except-

The park does not work properly. In fact when I ask it to park it tries to go under the mount!

The ASCOM Driver works perfectly and parks the scope as it should. I have set the arrow buttons in SGP so they match the directions in the Gemini Ascom. I park the mount in the CWD position, then ask SGP to SET this as the park. If I then slew with the arrows in SGP that works fine, but when I ask it to park it goes past the stop and keeps going way past the horizontal. How far it would go I don’t know because I stop it to prevent damage.

Other users of SGP with Losmandy mounts tell me theirs do the same.


#2

Not all mounts implement the Park command on ASCOM (i.e. SkyWatcher). My Paramount does, however, and once I set up the park position in TSX, SGP reliably parks it to that position. It is using ASCOM (I also have my own observatory application that also uses the ASCOM park command.)
Two things come to mind - SGP does not use the ASCOM park command with Gemini driver (easy to check in the ASCOM log file for the mount)
or
the Park setting you mention is not working as it should


#3

Thank you I will check the log file.


#4

Here is the log file, it doesn’t really mean much to me.

Also the profile for the Gemini ASCOM Driver, this does park the scope properly.


#5

Using the Gemini ASCOM Driver control panel (in the ASCOM driver, NOT SGP) verify that park does what you expect it to. I’m guessing you’ll need to either 1) set the correct park position in the driver or 2) select one of the other park positions (for instance Counter Weight Down (CWD)).

Thanks,
Jared


#6

I do set the park in the Gemini driver and it is set to CWD, ie the standard polar home position. The park works perfectly in the Gemini driver. It just goes haywire in SGP. If used it would cause some serious damage to kit! For now I am using the Gemini Ascom controller to park at the end of the session. It does mean though SGP can’t be left unattended to park at the end of a sequence. It would be safer if the park command was disabled in SGP rather than having it slewing between the tripod legs. I have spoken to other uses and they report the same issue.


#7

All SGP does is call the ASCOM Park command, the interpretation of that is up to the driver. What happens if you click the Park button from the Control Panel?

You can disable the park in the Telescope tab of the control panel.

Thanks,
Jared


#8

If I click the park command in SGP it sends the mount south!! If I click the CWD command in The Ascom Gemini driver it parks the mount as it should.

Again I have asked on FB groups if others have noticed the same. They have.

I just park it using the Ascom Gemini controller.

For someone who does not realize there is a problem then it could be very costly. That is why I am bringing it to your attention. It would be safer to disable it permanently in SGP rather than damage someone’s equipment.


#9


#10

Hi Jean,

SGP just tells the Mount, through the Ascom driver, “PARK”. It does not matter if this is a Gemini, Skywatcher, Astrophysics or whatever mount and driver. It is always just “PARK”. The user of that command - in this case SGP - expects that the Ascom driver knows how to interpret this and translate the command in something that the mount will understand and execute properly.

You may want to check if you have the latest Ascom driver. You may also try to contact the Gemini developer and ask if they have seen the issue already.

Kind regards,

Horia


#11

Hi All,
Just to confirm…I have a G11 / Gemini 2 and the park function does not work. I have tried everything under the sun :smile: it just does not work. I can also confirm that Prism software has the same exact issue. This was one of the main reasons I migrated to SGP. I was told on the Prism forum that this was brought up by other Gemini users before, and the issue is within the Gemini driver. Ther said the contacted Losmandy with no results. But I’m not a programmer so I can’t really confirm one way or the other. I just wish someone would figure it out.
Thanks
DMD


#12

Thank you for confirming this issue. I don’t have any other software to try it on, so all I can say is that the Gemini Ascom screen works as it should. SGP works for slewing and GOTO, just not parking.


#13

Sounds like it’s an issue with how the park command is implemented in the Gemini 2 Ascom driver if it’s happening with multiple applications. This is fundamentally different than clicking the “Park” button in the Gemini ASCOM Driver as that goes directly to the hardware and the Park call doesn’t get interpreted from ASCOM. Although they should have identical functionality.

The Gemini Group would probably be the right folks to talk to rather than Losmandy.

Thanks,
Jared


#14

Hello,
As a user of a Losmandy titan with gemini 2 level 5 I would like to say that I suffer the same issue with the Park command but I find that until this is resolved I can still leave the telescope unattended by using the Stop tracking command, for some reason it seems to work fine. Unfortunately I will never to be able to realize my goal of a fully automated observatory until this Park issue is resolved.


#15

Unfortunately we have no control over how the Gemini ASCOM driver implements park. All we can do is call the “Park” functionality and it is between the ASCOM driver and the hardware to do the right thing. Please contact the maintainer of the Gemini2 Ascom driver. There is probably a link in the driver itself. There is literally nothing we can do to resolve it.

Thank you,
Jared


#16

I have had this same problem and I think I have the solution. It’s not a bug, but rather a setting in the Gemini.net configuration.

Solution:

  1. Start up the Gemini software Hand Controller on your main Windows screen and click on the “Park” link.
  2. In the pop-up window click on the “Configure Park Position…” link at the bottom.
  3. Change the radio button selection to “Slew to CWD before Parking” .

That should change the Park behavior when you issue that command in your SGPro sequence.

I discovered that in my default Gemini.net configuration that radio button was set to “Slew to Alt/Az coordinates before Parking” which apparently causes the mount to slew to the Altitude & Azimuth coordinates right below the radio buttons in the pop-up window.

I have tested this indoors tonight with the radio button set to those two different selections and the SGPro generic Park command behaves differently for both selections… a slew off to La-La Land or… a Park to the CWD position.

I guess this feature was implemented to allow a slew to a Flat Box position?? for a Flats sequence at the end of the night???

Hope that solves your problem…

Joe


#17

Thanks very much Joe, this does seem to have solved the issue with parking.

I have also found when using the nudge keys ocassionally they can lock on and the mounts keeps slewing. There doesn’t seem to be any stop button in SGP. I have to stop it in the Gemini ASCOM driver. I was pushing all the buttons quite a few times to test it. Perhaps if pushed in a certain way it is designed to stay on (it has a solid white box appear around it) , if so how do I stop it? Pushing it again didn’t stop it. I can’t find any information about this on the help files.


#18

I have been using the Gemini.net ASCOM interface or the physical hand controller to nudge the mount because both of them have STOP buttons. I’ve noticed it’s a necessity.

I have experienced 3 other types of wild slews with my G11. One I can tie to the behavior of PHD2. For instance if I have been imaging a target in SGP and guiding with PHD when I pause the sequence to do a manual focus on a nearby star, I frequently experience a wild slew or mount stutter if PHD is still guiding when I issue the manual slew the star I want focus on. I think that PHD is fighting me in that case and doesn’t know that I have issued a manual “over ride” slew.

I experienced two other wild slews last night. One occurred when SGP had finished with one imaging target in the sequence and started slewing to the next target. The scope just kept slewing until it ran into a limit that I had set in the mount configuration. I have not experienced this type of slew very often.

On another occasion last night when SGP was centering on a target in the sequence the mount started slewing wildly until it ran into a limit. This type of wild slew happens more often than any other that I have encountered. It’s concerning because it means that I really can’t leave the mount unattended and I have had to set the limits tighter than recommended to ensure that equipment and cameras are not damaged by these occasional problems.

I checked the Gemini.net ASCOM object target log and it appears that the RA and Dec coordinates the driver received were OK and not corrupted. This would seem to implicate either the ASCOM driver, the Gemini 2 Losmandy onboard computer/software or perhaps the stepper motor drive circuitry/cables, but not a SGP problem. Not sure how to further debug this.

Anyway, just wanted to apprise you of other potential wild slews you might encounter and I am trying to document them more publically so that we might eventually figure out the root cause and correct them.

On the other hand I experienced the best steady guiding I’ve ever had on my G11 last night, .7 arcsec PE RMS.

Clear skies,

Joe


#19

Thank you for the warning. At the moment I am not leaving the mount unattended because I have experienced similar slews.

Glad to hear you have some good guiding, at the moment mine is awful!

Jean


www.mainsequencesoftware.com