SGP Crash with Nikon D850


#1

Couldn’t see the same problem on forum, hence this post. Cannot connect Nikon D850 to SGP, immediate program crash when camera connect icon clicked. Numerous attempts with no success. No problems with D810A using same setup (tethered to imaging laptop through a USB 3 hub running on Windows 10 64 bit). Imaging cards removed from camera. Device manager recognizes camera and states that device (D850) is running normally.

Link to Log file is https://www.dropbox.com/preview/sg_logfile_20180521145340.txt?role=personal

For this log file, all I was trying to do was connect camera (no mount, no autoguider, etc.). Tried everything last evening and couldn’t get anywhere as the program crashed every time I tried to connect the camera.

If there is any other information that would be of assistance, please let me know.


#2

Hi Jim,

I’m unable to view your log file, but see this thread. It may apply to you. The fix basically involves installing different c++ redistributables from Microsoft.


#3

Thanks for the information. Will try to install the c++ redistributables as soon as I get a chance.

Jim


#4

Installed 2017 and 2013 c++ redistributables (wouldn’t let me install 2015) and, alas, same problem, immediate program crash - "Sequence Generator has stopped working… A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.” Arrr. You’d think that if my D810A connects, the D850 should also.


#5

After trying to connect D850 several times after updating redistributables, tried connecting my D810A which has never been a problem. Now my principle camera will not connect, same problem - hit the connect camera icon and SGP crashes with same error message as for the D850.


#6

Odd that you can’t connect your 810A now. Did you try to install both the 32-bit and 64-bit versions of the redistributables?


#7

Thanks for the followup. Tried the 64 bit version, using 64 bit version of windows so didn’t know if the 32 bit version was applicable. Regardless, imaging laptop only used for astroimaging so reset windows (i.e. wiped off all apps and data) and reloaded and reconfigured all my astroimaging related software. Can connect D810A again but a little reluctant to reattempt the D850. Only thing that now does not seem to connect is the OpenWeather option under environmental options. Can live without that for the moment though. Not doing much imaging for the next few weeks as no true darkness at 53 degrees north.


#8

I definitely understand the reluctancy, however, since you won’t be imaging for a few weeks, now might be the perfect time to try to get the D850 to work.

I also run 64-bit windows, but since SGP is a 32-bit application, I needed to install the 32-bit redistributables in order to get my nikon to connect.


www.mainsequencesoftware.com