SGP Failed to Capture Calibration Frames after Error


#1

Greetings!

Under “Tools -> Options -> Sequence Settings” I have checked the box for “Capture calibration frames even if the sequence failed to complete.” During my sequence PHD2 lost the guide star after an auto-focus procedure, probably due to clouds rolling in. Following attempts to recover, SGP went through the shutdown procedure. However, at the end of the sequence I had a dark frame capture event set, but SGP ignored this.

Unless I had some conflicting settings, which I don’t see, I believe SGP should have parked the scope, told PHD2 to stop trying and sit still, but it should have kept the camera cooling and started taking the dark frames. Instead, checking the log file, it appears that SGP continued interrogating PHD2 the rest of the time until I intervened, cooled the camera and starting capturing the dark frames.

How do I make sure calibration frames will be taken even if the sequence can’t recover during the night?

I will upload the log file for your inspection.

The guide star was initially lost at [4/2/2016 03:57:13], but the sequence recovered.
There was an auto focus procedure, but it reported lousy results at [4/2/2016 04:07:48].
Guide star lost again at [4/2/2016 04:08:09]. This time no recovery (likely clouds).

Following this it appears to be in a loop checking PHD2 status until I woke up, cooled the camera and starting taking the dark frames at [4/2/2016 05:51:15].

I hope this is all sufficient information to help me figure out the problem.

Thank you!

Best Regards,
Ben

sg_logfile_20160401180136.zip (77.3 KB)Uploading…


#2

I forgot to mention that I am using the latest SGP version, and I was using PHD2 version 2.6.1dev5.


#3

This is because SGPro though the option was off:

[4/1/2016 20:44:56] [DEBUG] [Sequence Thread] bCaptureCalFramesIfSequenceFails: False

There was a small bug that caused this when the option was turned on from the options dialog instead of using the button under the target window. The bug has been fixed, but until it has been released, just use that button.


#4

Thank you very much! And thank you for fixing the bug so quickly. Next time I’ll make sure the button is checked as you say.

Ben


www.mainsequencesoftware.com