SGP Failing every night since last week


#1

I don’t know what happened to my setup, but it has been working nice all the summer, but last days I have used the SGP, it fails always.

I haven’t touch anything on my setup to make this problem appear. So I have no idea whats going on. I think that the main problem is that SGP loses communication with PHD2, and as soon at it fails it’s unable to work again.

After a week of getting problems with this I decided to reinstall the PHD2, but the problem is still there.

Here is my log:

https://onedrive.live.com/?v=TextFileEditor&id=A0A7875AB57A95A!3009&cid=0A0A7875AB57A95A&parId=A0A7875AB57A95A!1671


#2

When you start the sequence, is PHD2 already running or connected? I have seen a few instances when I had PHD2 already guiding, started a SGP sequence and it got hung up, waiting for PHD2 - when in fact PHD2 was already guiding nicely.

There are definitely some crossed wires if PHD2 is activated separately before SGP tries to interact. If I allow SGP to fire up PHD2 and connect, it works fine. So, if I am playing about with PHD2, I disconnect and close it before firing up the SGP sequence.

After I finish my current target, I will set up some deliberate instances and send the log files over. I’m guessing there is a simple assumption that is incorrect, say something like SGP is asking PHD2 to start up, when in fact it already is guiding.


#3

Actually, your PHD2 connection seems fine, this sequence was halted by a failure of your mount to return control to SGPro after asking it to slew:

[07/09/2016 1:35:45] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 18,8668305555556 (18h52m00,59s) Dec: 33,637725 (33°38’15,81")

Currently, SGPro has no slew “watchdog” to ensure that the mount actually does what it is supposed to do… it just waits to get control back from the driver and continue. In this case, that never happened. The mount logs will likely have more information in them.


#4

I guess that could be the problem, the night before the problems started, the telescope didn’t return to the park position after finishing the sequence, and also has failed to park some nights again… I’ll check the cable as it will probably be damaged.

Anyway, yesterday I installed a PHD2 beta version optimised for the QHY cameras, and the SGP opened the PHD2 on sequence start, but it couldt get control of the program when it tryed to calibrate the PHD2, it sended the command but the PHD2 dind’t connect the camera/mount and start the calibration procedure… I guess this is normal as the PHD2 version I was using is a beta, right?

Thank you so much for your time.


#5

Try PHD2 first with its connect all. I am always using snapshot builds. If that works, I would assume SGP will work too to connect all the gear. Did you set up the PHD2 profile in PHD2 and also select it in SGP for your sequence?


#6

I have checked all the cables of my equipment, and them look OK.

Last night I had the same problem again, when the PHD2 looses the guiding star, is unable to start guiding again.

What I have seen is that the SGP-PHD communication fails always, when my sequence starts it opens the PHD perfectly, but as soon as the SGP ask the PHD to calibrate, the PHD doesn’t do the “Connect all” step. If I go to SGP guiding setup and Choose my PHD profile and click on “Connect All” it works, but it seems that when the sequence starts the connect command doest work at all.

Thee SGP goes to recovery mode, and if I manually do “Connect all” on phd2, and then click on try again on SGP, then the PHD calibration process starts and the sequence goes well until the guiding start gets lost, and then SGP is unable to continue or communicate with PHD2 again.

Here is my last night log:

https://onedrive.live.com/?cid=0a0a7875ab57a95a&id=A0A7875AB57A95A!3351


#7

Right… that’s fair, unfortunately the same exact thing happened again and, as I mentioned in my original reply, without looking at mount logs to correlate the issue you are seeing we can’t be of much help.


#8

I’m looking for the eqmod logs, but I don’t know where are them… As soon as I found them I’ll post it.

Tonight I have been doing some test again, and the EQMOD get totally freezed… I tryed to unplug and plug again the eqdir cable, kill the eqmod process on windows, but nothing worked, as soon as I run eqmod again it freeze again.The only thing has worked to fix it has been shuting down my eq6 totally and poweron it again. This happened at midginth aprox and since then has worked perfectly until 6:00 am. when it failed again.

But this failure is not the same one I guess, because the SGP has been able to park the mount again, so it still have control of the eq6…

Anyway I must have something worng on my setup that makes the SGP unable to do the “connect all” procedure when the sequence starts.

As I said before, I’ll try to find the phd2 and eqmod logs.

Thank you so much for your time!


#9

Have you followed the EQMOD / SGPro guide?

http://mainsequencesoftware.com/Content/SGPHelp/UsingEQMODwithSGPro.html


#10

Are you using an EQDIR module?


#11

That’s right, I’m using a eqdir cable, and no, I haven’t done the steps you posted Ken, I didn’t know that steps must be configured, it has worked properly without them for many nights, but configuring the meridian flip was on my “to do list someday”, so I have my mount configured without auto meridian flips or limits.

I’ll do that and the other steps today and try to find the logs.


#12

In that case you have to follow
The steps in the manual. If you search around you’ll find some guidance on what versions work well with SGP.


www.mainsequencesoftware.com