SGP Hangs if Disconnecting Camera while in Frame and Focus


I was running a test and at the end I warmed my camera (ZWO ASI1600) and shut down other applications. I returned to SGP and tried to disconnect all equipment (Crtl-Sh-D) while in Frame and Focus mode (I forgot to Stop it). SGP hung and would not respond, so I had to kill SGP from the Task Manager. SGP eventually did try to put up the exit dialog for saving the sequence, but the dialog did not complete its rendering and was unresponsive.

Link to Logs

Useful Info

OS: Microsoft Windows 10 Pro
.NET: 4.8

For what it’s worth just an observation by a complete SGP neophyte since the situation described resembles one I ran into last night also during testing.

SGP (the client app) presumably blocks during synchronous remote procedure calls, so that if the remote procedure runs into trouble for one reason or another (or as it turned out in my case, simply opens a dialog window hidden under the main window and waits for input) SGP can appear to hang.

Edited to add: the upshot of this is, if an RPC service is the problem it might be spotted in Task Manager, and if so then killing it (rather than SGP) should result in an RPC error and control returned to SGP; otherwise as mentioned the service might simply be waiting for the user to acknowledge some sort of condition before closing…

I think it is an SGP problem. The dialog to quit was hidden under the main window, but did not appear for at least 30 seconds. The dialog was not fully drawn and did not respond to mouse clicks. On user actions, however stupid as disconnecting equipment while Frame and Focus was active, SGP should know what functions are active and then safely stop or put up a dialog that asks to stop imaging and disconnect or ignore the user request. That is, there is some idiot proofing to be done to help idiots like me.


I think I have this resolved. It will be in

Closing due to inactivity. If this is still an issue, please send the requested information and “uncheck” this thread as solved.