SGP Issues Detecting Moravian G2-8300


#1

Hi Guys,
Getting this error when choosing Gx USB Imager (64bit):

Error connecting to Gx USB Imager (64bit)! Retrieving the COM class factory component with CLSID
{31608A9D-A5E6-47B3-BB17-1B624E03B975} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

I have downloaded the lasted ASCOM 6.2 drivers
Latest Moravian drivers
Windows 7

Thanks for ur help


#2

You may want to attache the SGP log as well, but it looks like the ASCOM driver is unable to find the system driver. Did you also install the system driver (maybe these? http://www.gxccd.com/cat?id=158&lang=409)

I’m not completely familiar with Moravian cameras. Maybe one of our users that is currently using one can chime in.

Thanks,
Jared


#3

I notice this camera’s ASCOM driver uses 64 bits!!! Is there a 32 bit version ASCOM driver for this camera? Is it possible that 32 bit driver may be more compatible than 64 bits? 64 bits seem to be an overkill.

Have you tried non-64 bit application driver?:

http://www.gxccd.com/cat?id=154&lang=409

Click on the first link for USB or second link for Ethernet.

I understand that 64 bit driver is for 64 bit operating system but give the first two links a try.

Peter


#4

That did the trick Jared and Peter.

Installed the Moravian Gx 32bit drivers and it worked fine for both the camera and the internal filter wheel. Then chose Gx USB Imager (32bit) for the camera in the pull down menu.

The camera cooling options are also fully represented in SGP.

Thank u all.


#5

Very glad to hear this. Thanks for responding.

Peter


#6

I had this problem with my new Moravian G2-8300 MKII that arrived on Friday, I am one of the first to receive it.

I figured out that it didn’t like the 64bit drivers, which surprised me, is there any plans for SGP to support the 64Bit drivers, especially that the original post was two years ago?

Thanks for your replies.

Edit: - Windows 10 Ultimate SGP 3.02.91, Ascom 6.3


#7

Same question for me…Is there suport planned for 64bit driver?


#8

What’s wrong with using the 32bit driver?


#9

Nothing Joel! I actually installed the 32bit version last night as I’m in trial with SGPro.

I was using Nebulosity with the ASCOM 64bit driver so uninstalled it last night.

So now I have 64bit OS drivers and 32bit app drivers for the Moravian Ethernet device, autoguider and G3 camera.

Regards
YB


#10

FYI, the 64 bit drivers work only with the camera control application available from Moravian. SGP uses the 32 bit drivers only


www.mainsequencesoftware.com