SGP not communicating with Rigel Systems nStep motorized focuser not talking


#1

I’m still working on this, investigating and testing but in the mean time I also wanted to reach out and see if anyone else is having or had similar problem. SGP says its connected to the nStep focuser but isn’t controlling it. Does nothing. I can however control the focuser using the GCUSB-nStep ascom program which I have to launch manully and connect the focuser. SGP is showing green connected but not controlling the focuser is happening when the focuser is connected to a USB hub (Dlink in this case). If I plug the focuser directly to the laptop, and connect SGP to the focuser, SGP then can control the focuser but it also automatically launches and connects the focuser in the GCUSB-nStep program at the same time. Seems to be hub issue but I’m uncertain. I’ve checked ports and only the focuser is using com4. The hub is powered as well. I’m going to keep trying to figure it out but if anyone has a suggestion I’d appreciate the input.

Thanks,
Shawn


#2

I had a hard time too . Go to Rigel website, I had to dig around to get mine working, I will try and find the link for you.
Did you check the com port by clicking on focus in the Control Panel , then settings (in SGP) to make sure it is the correct port number ?? I think it has to be between 1 and 9 ( not sure about that but there is a limit)


#3

I have not had a problem with mine, but the GCUSB-nstep controller does open when I connect and I find I have to wait for that to open then minimize that window (don’t “X” close it) and everything works. If I close that window, SGP cannot control the focuser.


#4

Hi guys - thanks for the input. I have verified the port. I spent some time last night working all that out. So I know exactly what port every device is using.

I hooked the focuser directly to the laptop this afternoon to do further testing but this time the GCUSP-nStep controller didn’t open. Not sure why it did yesterday.

I have the scope setup again now. Have all night to troubleshoot. If I make any progress I will report back here. And if there is further input/suggestions by all means let me know! Willing to give it a try.

Thanks
Shawn


#5

I rebooted the laptop and now when enabling the focuser in SGP (green) it launches the GCUSB-nStep controller and connects via com port 4. BUT… I only got SGP to do an autofocus one time. Now SGP has lost contact with the GCUSB-nStep is seems. SGP doesn’t show any details for focuser position and when I click to run the autofocus SGP reports the focuser position needs to move in 280 steps. GCUSB-nStep reports it’s at 280 steps already. Basically SGP has decided again to not communicate it seems. ugh

Shawn


#6

I can get auto focus to run once but then I get this error message from SGP…

I also notice that SGP loses the focuser position when it goes into negative numbers.


#7

I figured it out! Negative numbers. SGP didn’t like negative numbers. This is my first motorized focuser on my home equipment. I didn’t really know how to initially set it up. So I had began with the focuser about half way out, focused, and ended up with negative numbers when running auto focus. This caused SGP to lose the position and then always give errors like the one above. I realized the connection between the negative numbers and SGP not communicating with the focuser. I ran the focuser in all the way, reset the position, and ran it out to focus (manually with a bahtinov mask). Then ran the SGP auto focus and it worked. I then ran it again and it worked. No negative numbers to deal with. I’ve been testing auto focus many times tonight and with different filters. Working good now! Hope this helps others that may have problems similar.

Cheers
Shawn


#8

@Shawn:

Most computerized focusers have software (or the ASCOM driver) which support a “homimg” function. When a focuser is homed, it normally runs to the fully “in” position and then calls that position “0”. This establishes the focuser range, since the max step position is typically published. You should not be in a position of trying to guess where the focuser position is.

Charlie


#9

Hi Charlie - Thanks. I’ll have to look and see if there is a homing function in the GCUSB-nStep controlller. I can’t say I saw an option for that but I will have another look. At least what I did helped. As soon as the negative position numbers were gone, SGP didn’t have issue communicating with the Rigel focuser.


www.mainsequencesoftware.com