SGP not connecting to Pegasus Focuser

Hi all,

I’m running a Pegasus focus controller motor through a Pegasus Ultimate Powerbox V2 using a direct RJ45 cable. The focuser connects and operates properly through the Pegasus’s own control software, but refusues to connect in SGP. I’m using the latest ASCOM Pegasus UPB Focuser driver V1.5.

Any suggestions would be apprciated.

Thanks,
Neil

I was having some problems between SGP and the Pegasus focus controller which seems to have disappeared with the Focus controller setup issued in March 20.

Thanks sterec, I’m using the latest driver. It was working fine under Win7, but I’ve upgraded to Win 10 and it no longer works. May be unrelated though.

It won’t work under APT or NINA either, so it seems like a driver issue rather than an SGP problem.

Neil

I’ve “solved” it, I’m embarrassed to say. I’d completely forgotten that you’re supposed to have he Powerbox standalone software running and connected even though you’re using SGP !

Doh!

Neil.

I am hoping you might be able to help me. I have a motor directly connected to my Ultimate Powerbox V2. When I use the Ultimate Powerbox app to try and move the focuser, I can feel the motor chatter, but it does not rotate. The motor is a Feathertouch HSM 30, so it has a clutch I can use to allow me to rotate the focuser by hand to verity that nothing is binding. I have verified that is the case. Also, SGP connects to the ASCOM driver just fine, and it also does not move the motor.
Is there a setting somewhere in the Ultimate Power Box app that needs to be set? I have played with the speed settings, but could not find anything else.

  • Tom

Sounds like a timing issue. I believe there is a setting for Steps/Second or something like that. Try lowering that value.

Also may be worth checking the cable to make sure it’s wired properly. I believe there are instructions with the UPB2.

Jared

Thanks for the quick response! I did adjust the motor speed down and up and it did not seem to make a difference. I also took the motor of the telescope and it had the same behavior, so I don’t think it is load related. I will check the cable next. I also sent a note to Pegasus support.
It is always something in this hobby…

  • Tom