SGP Program Fails to Start


#1

Greetings!

All of a sudden this morning, after a night of imaging, SGP crashed and now the program won’t even start. Here are my particulars:

OS: Windows 8.1
SGP: 2.5.0.23

I get the following error and traceback reported by Windows:

SequenceGenerator has stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: Sequence Generator.exe
Problem Signature 02: 2.5.0.23
Problem Signature 03: 56f89032
Problem Signature 04: System.Xml
Problem Signature 05: 4.0.30319.34281
Problem Signature 06: 565e85f1
Problem Signature 07: 985
Problem Signature 08: 27
Problem Signature 09: IOIBMURHYNRXKW0ZXKYRVFN0BOYYUFOW
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 1033
Additional Information 1: 5861
Additional Information 2: 5861822e1919d7c014bbb064c64908b2
Additional Information 3: 1318
Additional Information 4: 13181ae637ac2592fac0ca2dd662cdcc

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
C:\windows\system32\en-US\erofflps.txt

Here are some steps I have already taken, all of which have failed (not in any particular order):

  1. Reboot the computer
  2. Repair SGP using the install program
  3. Remove SGP using the install program, then re-install
  4. Remove SGP using Windows Control Panel, then re-install, rebooting all the way along.
  5. Remove the SGP folder completely from my AppData\Local directory (I did back all this up).
  6. Also ran Sequence Generator.exe /restart from the command line prompt

I have no log file to show for this because SGP doesn’t start to the point where it writes to a log file.

Can anybody help me with this problem? I’m stuck. Thanks.

Best Regards,
Ben


#2

Oh, and I turned off my virus software as well - didn’t fix it.


#3

Yikes. While SGPro has been known to crash from time to time under unexpected conditions, I have never seen this behavior. Looks like your settings may be corrupted.

Open a command prompt, navigate (with the “cd” command) to where you installed SGPro. Usually

“Program Files (x86)\Sequence Generator”

After changing directories, at the command line, type this:

"Sequence Generator.exe" /reset

If the problem persists, it is likely that one or more of your profiles was corrupted… We’ll cross that bridge if you need it.


#4

Ken:

Please note my Step 6 in the original post. I already tried that one after doing some searches on folks having similar issues. Did not help!

I’ve already uninstalled, erased, re-installed a couple of times. What do you suggest I do now?

Ben


#5

BenKolt,
Just a thought…

Go into Windows update and install anything related to .NET Frameworks (new versions and updates), not
saying it will answer your prayers but this Error is common to .NET Frameworks issues.
Its also quite common for Windows to throw this error if some part of .NET is older on YOUR system than
the version(s) on Ken and Jared’s systems when they compile SGP releases.

Give it a go !

Good Luck


#6

Well, I installed the latest .NET framework, but that didn’t help. Still the same error. Sequence Generator Pro is simply not starting on this computer anymore. I have installed SGP on other computers and they work fine. I’m now thinking at this point that I may need to do a complete reinstall of Windows itself as something has become corrupted.

Does anybody have some solutions I can try before going to that extreme?

Ben


#7

Did you try the SGPro reset I outlined above? I have several other ideas before you would have to do anything extreme.


#8

Hi Ben, Just FWIW,
I ran into similar behavior some time back. Several versions ago. SGPro would always start at least once after its initial installation. Then nada.
I found that installing a newer version would always fix the problem, at least until the next bad behavior cropped up. Eventually, several versions later, the problem ceased.
If you haven’t tried it, a newer version might do the trick.
Good luck,
Mark


#9

Ken:

Yes, I tried the reset several times.

Did you not see that I mentioned that I tried the reset in my original post, and I later responded to you that I tried it several times?

Please read the original post and you’ll see that I now have a completely new installation of SGP on the computer. All previous files including profiles have been deleted, so it ought to be a fresh new installation. It still won’t start.

My suspicion now is that SGP is itself fine but Windows 8.1 may have some corruption.

Can you give me any guidance in perhaps removing SGP again and this time cleaning it from the WIndows register?

Best Regards,
Ben


#10

Mark:

Thanks for your suggestions.

As I’ve told Ken, I went through a lot of steps (please see the original post) including de-installing and then installing the latest version, trying the reset command line option, removing all the profiles, etc.

My last thing to try would be completely cleaning the register of any instance of SGP and then doing yet another fresh installation, but I am now suspicious Windows 8.1 may itself have some corruption that is causing an issue.

Best Regards,
Ben


#11

Well, I thought it was worth mentioning.
You have my sympathy on this.
Mark


#12

Looks like I missed it… Sometimes I only read pieces and parts of posts (just to keep up)

Did you have a special storage place fro your equipment profiles or did you just use the default location?

We have a couple things to try before you try anything like re-installing the OS.


#13

Ken:

I understand. There’s a lot of messages to go through. I have the same challenge in my work.

I only used the default location for my profiles. During all my attempts to get SGP working again I completely eliminated my user directory where the profiles were stored. (By the way, I mentioned this in Step 5 in my original post :slight_smile:.) I did back everything up.

After uninstalling and reinstalling, erasing that directory and trying the other suggestions, facing north and twirling around clockwise while whistling, nothing is working. SGP fails to start so it doesn’t even create that AppData\Local directory again.

If you have another suggestion to try, I’ll be happy to give it a go, but I must say that I now suspect my Windows 8.1 has become corrupted on this computer. All my other applications are working, which is strange, but I wonder if there is some Windows file unique to SGP on my system that is failing. This file is not being affected by uninstalling and reinstalling.

Over the weekend I exercised a much more expensive solution. I purchased a new laptop that has Windows 10. Prior to this issue I was already contemplating getting a new one that had more RAM, more disk space and higher resolution. This issue accelerated my upgrade. I now have the new laptop configured and just went through my first night of imaging with it. Things went well and smoothly with the exception of having difficulty finding a Lodestar camera driver that worked on Windows 10. I think I got that now, but that’s not pertinent here. SGP installed smoothly, it works, and I just about have it configured as before - in fact better.

If you have another suggestions for me to try, I’d like to see if I can get the older laptop working again with SGP so that it can remain a backup, but the plan now is to decommission it and let the kids use it for their school work.

Thanks for your help.

Best Regards,
Ben


#14

I just had a failure to start after installing 2.5.1.11

log file is here: http://adgsoftware.com/misc/sg_logfile_20160511012717.txt

I saw this:

then this:

After clicking “Close the program” I tried starting it again and got the same result.

I have left everything as-is in case there is anything you need to look at to diagnose it. If not, let me know and I’ll try “/reset”.

Andy


#15

Andy:

Can’t say for sure that this was my error as well, but the result is the same when trying to start SGP. I’ll look at my last log file to see if it matches yours, but it seemed to me I didn’t get a log file when my error started. Sorry you’ve run into a similar issue.

Best Regards,
Ben


#16

Well… I did, but it seems that you beat me to it as they all involved manual removal of AppData\Local folder created by SGPro. If you have done this already and you are still stuck, I don’t really have any other ideas. SGPro does not use the Windows registry. I can’t think of anything that SGPro would attempt to do before reading in the settings files (which you have removed so it should re-create).


www.mainsequencesoftware.com