SGP restarts guiding during Auto Focus run


#1

I am using SGP 3.0.2.94 with PHD2 2.6.5… I am using an Off-axis guider, so during the Auto Focus process, I need the guiding paused, because when the focus is racked way out - PHD2 cannot guide. I therefore have checked the “Pause guiding during auto focus” option in the equipment profile for my configuration.

When SGP initiates an AF run, I see it say it is pausing PHD2, and then I see PHD2 go into a paused state (watching the PHD2 User interface). Then I see PHD2 come out of being paused - and go back to guiding . This causes terrible problems for the AF routine, because PHD2 has a terrible time guiding on the now badly out-of-focus guide star seen through the OAG.

Looking at the SGP log, I can see:

1). SGP initiates an AF run, and it sends a message to PHD2 to pause guiding.
2). SGP waits to receive a “paused” status from PHD2 - which it does.
3). SGP then begins the AF run - positioning the focuser to the 1st point of the run.
4). SGP checks PHD2 status again - gets “paused”
5). SGP checks focuser position - verifies that it is at the desired location
6). SGP log says “Resuming auto guiding (settling)
7). SGP then waits for PHD2 to report having settled, which takes forever (sometimes not at all) - because the guide star is out of focus.

As a result, the AF process takes a very long time compared to what it should take, and sometimes does not successfully complete.

I have tried manually stopping PHD2 at this point, but then SGP gets hung up because it is waiting for PHD2 to settle, and it will not because it is not guiding.

Sometimes at this point I have to kill everything and start over because SGP has gotten into such a messed up state.

This appears to me to be a bug in SGP - that it is telling PHD2 to resume in the middle of an AF run. This is a very serious problem from the automation perspective, and I really need some help with it.


#2

I may have found the issue… there are 2 options in Auto Guiding:

 Pause guiding during auto focus
 Settle auto guider before auto focus frames

I intended to have the 1st checked - I didn’t even realize the 2nd existed, and would not have checked it - but somehow it was checked. this would explain what I experienced.

It seems to me that you should not be able to check both of these options - they are mutually exclusive!!

Now I have made sure that the “Settle auto guider before auto focus frames” is NOT checked in any of my profiles… will double check next time I’m out - and make sure it isn’t somehow getting automagically set.


#3

Yes, it seems those two should be mutually exclusive. I guess they technically don’t have to be…but for this reason it probably makes sense for them to be mutually exclusive.

Thanks,
Jared


www.mainsequencesoftware.com