SGP stops with Nikon D5500 dslr!


#1

Hi Guys
First try of SGPro. Installed latest version and just ran it with my Nikon D5500 dslr, created a test directory, created a test user profile no other equipment connected, set the Nikon for a run of 1- 1x1 1second second shot and prog crashed each time I ran it. Pc is Windows 10 64 bit.

Anything else I could try please?.
thanks
Steve


#2

Try adding a 10 or 20 second delay. If it still crashes, try 30 second exposures. SGP will often crash with very short exposures. This usually happens when taking bias or flat frames and generally works fine with a delay added. Does not happen when taking lights because they have a longer exposure.


#3

Hi
Tried 10,20 and 30 sec delays still crashes at the point of taking the shot. Camera connects fine and all seems ok until taking the shot??. Not quite sure what to try next?. I have the dslr set to manual which I assume is what SGP wants it set at? I do take short exposures sometimes when needed maybe SGP not quite right yet for my model? Didn`t like 30 sec exposures either!
regards
Steve


#4

The Nikon D5500 is supported by SGP. When you choose the camera type select Nikon. There is a box to the right of Nikon that says Settings. Click on it and select your model. You will see the D5500 there as a choice.

Also I think on the camera you select Manual and then set Bulb - at least I do that with my D5100… It should work ok - if you’ve tried this and you still have an issue let us know.


#5

Hi Tim
Nope, D5500 selected ok, connects fine. I didnt have Bulb selected before but just tried it and still crashes at the same point just as the shutter opens and the exposure begins. Ive been using BYN (Back Yard Nikon) for tethering before and it works perfectly. I tend to use my Atik 314 mainly for imaging but it would have been useful to use my Nikon too.
If I then click on Debug I get this screen -

I have Visual Studio 2015 Community installed and I wonder if there is some conflict with this or .Net with SGPro?.
Steve
Ps And I`m not sure why this font changes with the apostrophe ? weird!!


#6

Can you please check/post the firmware version of your D5500? I have a newer D5300 and had a similar issue but was not able to connect and I was able to solve it but I need to see your Firmware version first before I offer my solution. Thanks.


#7

Also is autofocus off? (Ie if you were testing with just a lens on it)


#8

You can try with these newer files for the 5500. Replace the files located here:
C:\Program Files (x86)\Sequence Generator\NikonLibs\Type0016
with the files in the zip.

Please let me know if that works.

5500.zip (229.7 KB)

Thanks,
Jared


#9

Hi guys
Many thanks for the helpful replies, my firmware version is C 1.00 L 2.009 (whichever one of those applies?)
It turned out to be the SD card I left in the camera, no doubt its written down somewhere that it should be removed before connecting to SGPro ;-{ sorry. I gather that I should be able to use the Liveview with the camera will have to suss that out.
I was going to update the camera`s firmware recently but apparently the newer Nikon firmware was incompatible with BYN so I didnt do it. BYN have now done an update to fix this but I havent bothered, if it aint broke… Would you still like me to try those files Jared?
I can now start exploring SGPro properly now!.
thanks again guys.
Steve


#10

No need unless you want to. Just back up the old ones first.

SGP should be detecting the SD card and prompting you to remove it. I’ll have to double check that.

Thanks
Jared


www.mainsequencesoftware.com