SGP won't start


#1

After a couple weeks of flawless running sgp now will not boot. This began after sgp was left running and windows crashed during that time. I haven’t tried reinstalling yet thought I would ask here first so i don’t have to re-do my profiles or can I save the profiles file and add them back in after i reinstall or maybe these another option?

charles


#2

update i removed the user config file and then reinstalled and now the program has started, saved my profiles and put them back and they are working to, just need to get the platesolving all set up again and i should be ok. i can sent the bad user confiq file if you all want it for debuging


#3

I would uninstall and reinstall. Sounds like something got corrupted somewhere.


#4

Hi Charles,

What config file did you remove to get SGPro working again?


#5

it was the user.config

ive attached the one i removed


#6

@Charles_Lillo

Thanks for the response. Did you forget to attach the file? Trying to figure out what it is… I don’t recall ever writing or using that particular file. We have one called sg_ui_config.xml, but I can’t place anything called user.config.


#7

Ken the file was located in this directory…
C:\Users\clillo\AppData\Local\Main_Sequence_Software
Sequence_Generator.exe_Url_uyjbpyzhvz35hcxshcxrldxcqwux0btg\2.5.1.17

file should be attached i saved it as a txt just in case my email server
won’t send the xml

user.config.txt (7.51 KB)


#8

I actually had this same problem Saturday. Almost the same circumstances, my computer locked up and I did a hard reset and .17 would not start. Tried uninstalling and reinstalling but no luck. I downgraded to .14 and it worked but I had to install and then install again to get it to show up. I am going to try the fix you found to see if it works for me.


#9

Ah, thx. Yes, this is a Windows generated file so SGPro does not create it explicitly. Seems that these windows settings can be corrupted pretty easily. I will look into this and see if we can add this into our current “reset” functionality.


#10

I reinstalled .17 but it wouldn’t start so I deleted the user config file and .17 started right back up after the file was deleted. Thanks Charles!


#11

awesome Ken!


#12

Dumb luck on my part finding that file but glad to help, and looks like it is a
bug that they can fix too.


#13

@Charles_Lillo

Thanks for the report. We have not fully identified all conditions that can possibly corrupt the SGPro settings file, but the new recovery process should be much smarter about resetting to a good state and also not losing all of your settings while doing so (some might get lost).


www.mainsequencesoftware.com