SGPro 3.0.0.X Issue Thread


#21

I’ve uninstalled and re-installed and updated the user and equipment profiles and it is working now.


#22

My dome slave problem persists.

I have been in touch with the Pulsar Dome software developer today, who has installed all the latest dome software on my system. There is communication between SGP and dome, but when I click slave, nothing happens. If I then nudge the dome a few degrees from within SGP, the dome moves and then moves to slave with the mount. Is anyone else using SGP and a Pulsar Dome suffering from this problem? The SGP log file is here:

Ken & Jared, I look forward to hearing what you think about this issue.

Thanks,

Gav.


#23

@Ken
I’m also having issues with slave commands. I have now had two cases with an aborted sequence due to unsafe conditions, where the mount parked but the roof did not close. I could still close the roof with another application using ASCOM. That application checks the mount condition too before closing.
It appears around 00:48, the mount park command is set but an exception is reported.

I have had dozens of sessions where the slave sequence has worked fine, but not with the 3.0x betas. I cannot rule out that this is the Paramount API throwing an exception through the TheSkyX ASCOM driver. I do wonder if something has changed in the 3.0x Betas that may affect operation. I have the SGP log file but unfortunately do not have the ASCOM driver one. (I will next time though).

sg_logfile_20171014202731.txt (915.4 KB)

[update] I have played about with older and most versions of TSX with the 3.01 beta and could not repeat the failure. It may have been just one of those things. This is the season for heavy dew and it may have been a simple hardware anomaly. I’m better prepared for next time and will have full log coverage.


#24

Another (minor) one. In the past, if you ran a timed start up sequence and were waiting for it to start, if you subsequently altered the time it did not affect the outcome. The new beta does take notice of the new time… but the banner at the bottom does not update - it shows the time when you hit ‘run sequence’.
regards


#25

I am not sure if this is related to the Beta release (3.0.0.2), but I think that it might be…

The equipment profile that was associated with the sequence doesn’t stick with it for me. That is, when I open a sequence, the header indicates no profile is associated with it. There was one associated with it when last closed, and I almost always create a sequence from a profile (can’t swear I did in this case, if it matters).

So I apply a profile to the sequence and it shows up in the header. Then save the sequence. However, next time I load the sequence, there will not be a profile associated with the sequence. Equipment appears to all still be correctly associated, but I think the profile stayed in the header, too, previously?

Not a big deal, just FWIW.

Thanks and regards
Craig

PS, hope you guys have a nice visit to El Dorado.


#26

Howdy- I have been looking at the planning tools, and one thing that would really help me is a way to map out what part of my sky is visible (I have many trees restricting me to a small portion of the sky).

The other thing that I am not sure if I can do, is manage the start/end times of all of the members of the sequence. Let’s say I have three objects, and I want to image them one by one through the night as they become visible. I’d like to be able to edit when the objects were going to be imaged and see how that playss out on a graph or animation.

Is there a way we can now edit the start/end times of all of the items (or active items) in a sequence at the same time, like in some sort of table view, so we could easily set up long sequences of objects? I currently image between 5 and 10 objects a night, but coordinating them is clunky.

Thanks-

Lightpath.


#27

SBIG Error Message: BAD_CAMERA_COMMAND.

I haven’t used my ST-8300M in a while and hooked it up, using the latest V 3 Beta, to build a fresh dark library and consistently got the above error message. The camera did function and download an image. I did a check on the SBIG drivers and finally reverted back to SGP V 2.6.0.23 which functioned without any error message. V 3 Beta Log with error and V 2 Release Log without error attached.

https://www.dropbox.com/s/jn61w0qfc7rfrdb/sg_logfile_20171023151948.txt?dl=0
https://www.dropbox.com/s/6yb7gwo8ra1zhn7/sg_logfile_20171023152409.txt?dl=0


#28

Here is a link to an issue I am having with SGP 3.0.0.2 hanging trying to download my 6D images. It used to take just 10 seconds. SGP 3.0.0.2 hangs on image download
Dean


#29

Found a bug running 3.0.0.1
When I run a “flats only sequence” and use the disconnect equipment option at end of sequence, the flip flat box is left lit. I have to reconnect it and set the slider to 0 to turn it off. Probably a quick fix. Thought I would you guys know.


#30

I am finding that my Pulsar Dome gets ‘stuck’ at around 180° while slaving. I have mentioned the issues I am having with slaving generally and I’m sure this must be related. When it stops moving, if I nudge the dome a degree from within SGP, it ‘wakes up’ again and catches up to slave with the mount properly again. I notice that it seems to happen just before reaching 180°.

I am looking forward to the next Beta release, which I guess Ken & Jared must be busily preparing as their presence here seems to be far less frequent at the moment!


#31

In the beta timed sequence visual display control I have a nitpick bug.
As the clocks went back last night, I noticed that my ongoing sequence now has start and stop times that are one hour out.
It would be useful if they could save internally as UST and then adjust the displayed time accordingly?


#32

Where do you live? I believe the clocks don’t go back until Nov. 5th for most of North America that are on DST.


#33

In the UK. They went back Sat night. There is a C# .net property that gives the PC status, so it would be possible to automate it.


#34

The planning display doesn’t show anything. Black. ?


#35

Just saw the update to 3.0.0.3 - applied it. Same problem. This is new screenshot. Also if I uncheck as example, hide/rise, SGP crashes. Screenshot as well. ?


#36

There is another gremlin in the recent 3.x betas (though it may also be in earlier versions too). I have a Paramount and I set the telescope sync setting in SGP to ‘target offset’. I’m mid imaging an object and I notice that when I load a partially complete sequence with a new beta - it changes that setting back to ‘sync’. If I change it back again and save the sequence, the setting persists and runs OK on subsequent nights.

[update] - in addition I notice that if I go into my equipment profile manager, all my profiles have flipped to sync mode from target offset in the telescope tab.


#37

Hi Ken and Jared,

I have an observatory with Home Dome, AP 1200 GTO with SBIG ST 8300M camera. Version 3.0.0.3 does not slave the dome even though I can control it manually within SGP. In addition, I get an “SBIG Error while fetching customer options!: BAD_CAMERA_COMMAND” at the initiation of every frame even though the frame is captured and downloaded ok. I went back to version 2.0.6.23 and it all worked normally. The log is at:

Thanks for the support on your excellent product!!

Kent


#38

Check your user profile, I had this issue as I never setup a user profile with Coordinates.


#39

Yes, we will add this to the errors box… seems to be the most common issue.


#40

All the time? Do you have that sequence?


www.mainsequencesoftware.com