SGPro 3.0 and FocusLock


#21

Hi All,

After having spent time with Professor Google and with no luck, I thought I would ask the obvious here - I take it FocusLock is not designed to work with a Moonlite focuser?

Pete


#22

Hi
I have managed to get focus lock to connect to my moonlight ! , what is your error ?

harry


#23

I’mn about to connect up this evening to see the blue / blood moon. I just couldn’t see anywhere that it worked with a moonlight focuser. I take it you loaded the moonlite ascom driver and it just worked from there?


#24

Hi
yes , but do make sure you have the latest version as older 32 bit ver do not work with focus lock

Harry


#25

That’s great Harry and many thanks.


#26

Hi

bump on the focus lock issue

Harry


#27

Hi Gents

any chance of looking at this please :slight_smile:
got logs if that helps , but thought you might have a idea from the screen grab

harry


#28

Harry, have you gotten Focuslock to work with just the Optec software? My setup works pretty well with SGP 2.6x, but I have not gotten around to upgrading to 3.0.


#29

Hi
I have got everthing to connect ok , just not had any clear skies to experiment with :weary:

Harry


#30

Hey Harry, one thing I’m curious about is the cost of the focuslock software. The optec website says it is $100 “with 1yr maintenance”. Does this mean $100 per year for the software? I can also ask Optec…


#31

Hi
I am not 100% sure as I am still on the trial , but it suggests to me 100 bucks for the software and 1 year support
and hopefully it will then be ok to still use after that !

other wise $100 a year is a bit steep

perhaps I should have asked first :slight_smile:

Harry


#32

I have been using Focuslock for a couple of years and have always been able to get the latest versions of the software at no addition cost beyond the initial $100.


#33

Hi,
I’ve had FocusLock for the last month or so but have only managed to try it briefly three times with mixed results so far.

My first attempt worked well. Having manually focused both imaging and guide cameras to best focus, Focuslock calibrated and then ran without a problem for the whole session maintaining focus throughout. The second time I just ran the system from start-up (without calibrating) and it was great to watch it seek, lock and then maintain focus without any input from me. Then I ran into a problem…

As I didn’t want to set up individual offsets for the entire filter set at the time and I also plan to image exclusively in Ha for the foreseeable future, I re-calibrated FocusLock for use with an Ha imaging filter (the test runs above used a Lum filter). The system seemed to calibrate correctly. When the calibration run finished I confirmed that I wanted the calibration data saved and also that I wanted the focuser returned to the pre-calibration start (best focus) position. When I then selected Start, FocusLock immediately drove the focuser to the last calibration run position and subsequently tried to maintain this focus position. Clearly this resulted in an out of focus image (with an elongated guide star). I would have expected the system to try and maintain the lowest Absolute Roundness value for the guide star and thus the focuser position when I selected Start.

I’m not sure whether I’m doing something wrong (probably) or there is a problem somewhere. It looks a little like it may be using incorrect calibration data (e.g. the previous calibration from my early trials).
I sent an email to Optec Support for assistance a week ago but have not yet had a reply.

The integration of FocusLock with SGP (v3.0.0.7) works fine except for two minor issues:

  1. when I close the FocusLock application SGP becomes non-responsive or, more accurately, becomes very, very slow in responding to commands. This is not a big deal as I can disconect equipment from within FocusLock and minimise the application and carry on using SGP as normal.

  2. I cannot connect/control the focuser (SharpSky Pro) from within SGP and FocusLock simultaneously. I’ve tried connecting via the Optec ASCOM Server but this doesn’t appear to make any difference.

Any ideas?

Ian


#34

@harry Sorry for the delay… this is on my list of things to look at… just now reading through. I am unable to reproduce that behavior. Does it happen every time or just sometimes? Logs are not super useful for this condition… Can you think of any special circumstances or special state prior to clicking “Open”? Was FocusLock already open (opened manually)? Had it been open before? Right now, there is a bug in FocusLock where it does not properly report that it is closed and depending on what happens before this message, it might come into play.

@Ianto111

Thanks for this report. This is due to a bug in FocusLock where it does not properly report that it is no longer running. In the meantime, I have worked around it. A fix will be out in the next release / beta.

This depends on the model of your ASCOM driver. SOme are written to support multiple connections and some are not. In reality, cameras are the only ones that should use a model where the device can support only one connection. That said, if this is the case (not sure), there is nothing SGPro can do to help. BUT, as a workaround, you can use the built in ASCOM POTH Hub. This will create a situation where both SGPro and FocusLock can connect to the POTH Hub (Poth HUB driver supports this) and the POTH hub will be the one and only connection to your focuser.


#35

Just wondering if it would be possible to use fosculock solely for focus but keep guiding with a separate guidescope/camera if I don’t want to use OAG for guiding?


#36

Hi everyone,

OK I’m now using focus lock amd I calibrated tonight and am just started to take a sub and I see the focus steps changing.
Do I turn off auto focus now? So just have focus lock?

Thanks
Matt


#37

Yes turn off auto focus. Just have focus lock running.


#38

According to the original post for this thread there is no way to automate the start of the lock. You have to be there to manually click the button.

"Lock not available: FL gear is connected, but FL does not have a “lock” available to use. A lock is required before FL is able to maintain focus.
Lock available: FL has a lock available, but it is not being used. Click the “Start” button or start the lock in the FL application."

While SGP can load up and connect to PHD2 and start up Focuslock and it can determine the state of FocusLock, it does not start the lock/focus process. Unless I am misunderstanding. However there is a list of script commands in the help file that can tell it to do just that. Has anyone here got it 100% automated? I like to start my sequences before I take my daughter to swim practice so it starts imaging when it gets dark. But if I have to be at the computer to click “go” then it doesn’t really do what I need.

Here is the API for reference. public ScriptFocusLock()
This initializes the scripting object and starts the FocusLock UI.

public bool isLockAvailable()
This reports true when FocusLock is able to start focusing and engage the lock.

public bool isAtFocus()
This reports true when the guide image is in the Critical Focus Zone.

public bool isConnected()
This reports true if FocusLock is connected to the necessary devices.

public bool isLockRunning()
This reports true if FocusLock is maintaining the focus. This is called Lock mode.

public bool IsRunning()
This reports true if the scripted copy of FocusLock is running.

public void ConnectDevices()
This will instruct FocusLock to connect to the preselected devices. Any errors will be displayed in FocusLock. A pop up Windows Notification will appear if all are connected.

public void DisconnectDevices()
This will instruct FocusLock to disconnect from the preselected devices.

public void StartLock()
This will instruct FocusLock to begin focusing and to engage the lock.

public void StopLock()
This will instruct FocusLock to stop focusing and to disengage the lock.

public void CloseFocusLock()
This will tell the scripted copy of FocusLock to close.

Also there are script examples in a .zip file located in the FocusLock install folder. I have no idea how to use them but perhaps someone else does. I hope.


#39

It has been a month or so since I last did any imaging but I had it at about 99% automated. I uncover my scope , fire up sgp, connect all my equitment and then i connect focus lock. I wait a few moments then run my sequence which is cool down and wait until a specified time to start. Go inside for dinner and and check back in the morning.

One suggestion if you cant get it to work is use a remote desktop program such as splashtop. I use it to just check in to make sure everything is running ok. You can use that to press “go” while you are out and about.


#40

To use the Lacerta kit do we have to have a Lodestar camera or wiuld it work with an ASI174 Mini ?


www.mainsequencesoftware.com