SGPro 3 does not see PHD2 starting


#1

I never had a problem with this in SGPro 2, but recently paid the money for 3 and now when I start my sequence, SGPro starts PHD2. I can see PHD2 select a star and start guiding automatically, but SGPro continues to say “waiting for PHD2 to start”. But it has started. I almost wish I had not upgraded. The only way I got around it was to turn off PHD2 in SGPro and start it manually, but then I loose dithering. Really frustrating. Anyone else have a solution to this?


#2

Sometimes the port for PHD2 may not open or SGP may not be able to find it. You can give it a nudge by opening up the Settings on the Autoguide tab on the control panel and click the “connect” button. It’s pretty rare that you’d have to do this…

Thanks,
Jared


#3

Thanks, I will try that. But it is not rare in my case. Ever since I went to version 3, this happens everytime I am out


#4

Do you have the path to PHD setup in the PHD2 settings of SGP as well as your PHD2 profile?

image

Thanks,
Jared


#5

Hi there,
I am new with SGP, maybe I am doing something wrong.
I have bought SGP3 recently and I have very similar problem: SGP does not start PHD2 guiding.
SGP starts the PHD2 application but that is it.
The path is set correct, but the SGP does not “see” the PHD Equipment profile - that row is inactive.
I get the error “SGPro could not successfully query the guider’s version”.
PHD2 its self works just fine.


#6

I am sorry, my fault - the PHD2 server was off.


#7

All the settings are there and it shows it was connected. SGPro just never new that PHD2 had started. I will keep working with it, but I may have to go back to version 2 since it worked fine. Just hate i spent the money on version 3 if i have to go back


#8

Are you running PHD2 or SGP3 as admin? Were you running SGP2 as admin?

Thanks,
Jared


#9

They are both running under the same user. Do they have to be admin?


#10

This is happening to me as well. It never happened in v2 but now happens often in v3. The point here is that it sometimes works so it surely cannot be a ‘wrong’ setting? So far I have not used any extra facility in v3 that isn’t in v2 …

Lawrence Harris


#11

No, you should not run them as admin.

Thanks,
Jared


#12

I have just done an interesting daytime test which might shed light on this strange problem. As already reported, sometimes (for me at least) the autoguiding works normally and sometimes it tells me that no profile is selected. I have just had a look at the settings for autoguider. The correct path is shown. In front of my own eyes, the profile was correct - but then PHD2 was launched and then the profile in SGP reset to ‘no profile is selected’ - the very error message that SGP shows during failure.

At least now that I know where it is happening, I can fix it - but this should not be happening and did not happen in v2.

Lawrence Harris


#13

Lawrence, does the fix stick? - I had an issue where the sync setting was reset to ‘sync’ from ‘target offset’ in every equip profile, each time I updated a SGP version. Once I corrected it back to ‘target offset’ it stuck. This particular issue was fixed in a recent beta but I’m just wondering if you have found something similar…


#14

I don’t know yet. This was a daytime check and really surprised me
seeing it changed in front of my eyes!

Lawrence


www.mainsequencesoftware.com