SGPro does not launch anymore

Sorry for the late reply.
I have the .NET 4.8 installed.
ASCOM is the 6.4 version.

Thanks
Thomas

I had a similar problem, except that SGPro never started once after a brand new first-time install. I ended up getting it going by uninstalling the DOT NET frameworks 3.5 and 4.8, and the C++ runtimes back through 2013. Then I reinstalled DOT NET FW 3.5 and 4.7.8, and let the C++ runtimes install on their own with apps that needed them. And finally, SGPro started and has been working fine since (though that’s only a couple of days so far).

I am having exactly the same problem. Fresh install of7 Windows 10. SGP will not launch. I have removed C++ back to 2010 and .NET Framework 4.8 & 3.5. Reinstalled 4.8. Windows refuses to download 3.5. Reinstalled SGP but still fails to launch. Any ideas on adding .NET Framework 3.5 and is it needed.

3.5 should not be needed. Is a SGP log being generated at all?

Jared

Thank you in taking an interest. No. the program is aborting during start up. I never see any thing present it’s self. I have attempted to start with Task manager open. It doesn’t show anything either.

Rich

I upgraded to Ascom 6.4 SP1 tonight and now SGP won’t lauch. I’ve rebooted the computer and uninstalled SGP and then reinstalled it but all to no avail.
I’m basically dead in the water here.

I’ve tried the “nuclear option” described previously in the thread but to no avail. I’m running Windows 10 home on a Dell XPS 15 9560. I’ve got the following DOT.NET version installed:
4.8.3752.0
C:\Windows\Microsoft.NET\Framework\v4.0.30319>
I’ve also tried uninstalling version 3.1.0.479 and installing a previous version all to no avail.

SGP has worked flawlessly on my machine since I purchased it 3 years ago. I updated my ASCOM yesterday to version 6.4 SP1 following an update to version 3.1 of the driver for my Optec Focus Lynx focuser and since then when I can’t get SGP to open. Not even a splash screen.

Has anybody had a similar issue ?

thanks for your help.

Marc

Yes I also just installed ASCOM 6.4 after a Windows 10 reins

Can you check to see if logs are getting generated? Even if you never see anything that doesn’t necessarily mean that SGP didn’t write a log. You can find them here:

C:\Users\<YOUR_USER_NAME>\AppData\Local\SequenceGenerator

There have been quite a few cases where the ASCOM 6.4SP1 install has been corrupt and running the installer and using the “Repair” option has fixed it. Be sure to restart after installing ASCOM versions as well.

Thank you,
Jared

I repaired ASCOM. Uninstalled SGP and reinstalled v2.6.1.398. Then rebooted the computer. Opened task manager and hit the SGP icon. Got a rotating circle for 1.5 seconds. No activity in task manager and no sign of the program. Looked for log but folder \AppData doesn’t exist.

So, it looks like ASCOM 6.4SP1 was released 22 days ago. Do any of you with this problem have the previous version that you can go back to?

What version of windows are you running?

Thank you,
Jared

ASCOM 6.4SP1 has been around for a while, much longer than 22 days ago. Where did you get this information? Are you thinking of Beta version of 6.5?

Peter

I have just wiped this machine and downloaded from Microsoft three or four days ago. I am running Microsoft Windows 10 Home 10.0.18362 Build 18362.

Peter you are right. I was looking in the release notes but they referenced 6.5

FYI, the latest version of Windows 10 build is 18363.836, so it looks like you are missing some updates, and have you configured all the app permissions to access the hardware etc.

Julian

I reinstalled Windows 10 this afternoon. Ran Windows Update assistant which assured me that I was running the most up to date version. But I am still 10.0.18362. So 18363.363 maybe more current but I have no idea how to get there. Went to Apps & Features and attempted to examine allowed permissions but SGP shows no advanced options button. That is the only way I know to change permissions. I you are aware of another way to access permissions please let me know.

AppData is a hidden folder but it does exist on Windows 10. Please check there for logs. One may or may not be getting created but if there is one it should help narrow this down.

Jared

No. NoSequenceGenerator folder in Local

It is now fixed. I originally installed Windows 10 with a full wipe. SGP would not run. I did two additional re-installs but left programs and data intact. No luck. Did a reinstall and wipe and now SGP is running. I am guessing an error in the original install? Thank you all for your efforts.