SGPro not Syncing to mount


#1

Hi All

I have configured my plate solving successfully, however, during the “Blind Solve and Sync” the mount Position does not get synced with the results of the Blind Solve, I am using EQMOD and an EQ8 Mount, It used to work flawlessley, I recently upgraded ASCOM to the 6.2 release and SGPro to the latest release also. I have chedked all the settings in EQMOD and everything checks out, just EQMOD does not get updated with the Solve and Sync results

Anyone have any ideas?

Simon

Even after the latest SGPro update, it still fails to Sync, I have restarted everything

In the logs I see:

[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Plate solving scope frame successful, scope is synced, writing FITs header info…
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Telescope: Syncing to J2000 RA: 1.50076137802671 Dec: 87.9913447989921
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Attempting to write fits header info for C:\Users\Simon\AppData\Local\SequenceGenerator\Temp\plate_solve_image.fit
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Opening fits file…
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Successfully opened fits file…
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Writing fits headers…
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Closing fits file
[29/12/2015 18:49:38] [DEBUG] [Telescope Thread] Failed to sync the rotator to 255.2 degrees, not connected!
[29/12/2015 18:49:47] [DEBUG] [Telescope Thread] Scope solve complete…
[29/12/2015 18:49:47] [DEBUG] [Telescope Thread] SGM_TELESCOPE_SOLVE message complete…

Not sure why it is failing on the rotator when I do not have one configured!


#2

In addition to this, I have found that Solve and Sync only appears to work when the mount is in the “Home” position, it successfully applies the position to EQMOD, in my observatory, I have had to define two park positions, one in the normal “Home” position where the mount is neither East or West but pointing up at Polaris, and the other “Defined” park position is 6 Hours East (To allow for my roof to close)

If I try Solve and Sync at my Defined Park Position (Unparked and tracking), Solve and Sync does not apply the results to the mount, however if I park the mount to the “Home” position, and then immediately unpark it and enable sidereal rate, Solve and Sync applies the position

Not sure if Solve and Sync is supposed to work like this


#3

Most mount will not accept syncs while parked. I know that EQMOD is also very picky about when it will apply the sync. What would be most helpful is to look at the log for the EQMOD driver and find the corresponding syncs in that log. Then we can track down if it’s SGP not sending the sync or EQMOD rejecting it.

Thanks,
Jared


#4

Hi Jared

Can’t seem to locate the EQMOD logs, any ideas where they are located?

It seems I can only apply Sync data to the mount when the mount is in the “Home” position but tracking is running

Simon


#5

You will probably do better asking about EQMOD issues on an EQMOD forum.

You seem to be trying to synchronise very close to the pole, declination close to 90 deg and that could be causing problems because the hour angle becomes indeterminate at the pole.

A better way to operate may be to do some sort of approximate alignment, slew to somewhere away from the pole and then do a solve and sync. You may also find that a sync where the sync position is a long way from the position the mount thinks it is pointing will cause problems.

I doubt that there is some fundamental problem with sync and EQMOD because if there was lots of people would see it.

Chris


#6

All ASCOM mount drivers should reject syncs whilst parked and reject syncs to RA/DEC coordindates is not tracking. EQMOD will reject syncs if the difference between the current mount position and sync coordinates are exceptionally large (implying bad sync data) or if a sync is being attempted from a counterweights up postion (beyond EQMOD’s control limits). I would’t consider EQMOD’s behaviour as being very picky - it is simply protecting the user’s equipment against syncs that if actioned could result in subsequent abnormal slew behaviour.

[quote=“CarlightExpress, post:2, topic:2770”]
If I try Solve and Sync at my Defined Park Position (Unparked and tracking), Solve and Sync does not apply the results to the mount, however if I park the mount to the “Home” position, and then immediately unpark it and enable sidereal rate, Solve and Sync applies the position
[/quote].

Most likely your custom park position is slightly beyone the horizontal - just unpark slew to a ‘normal’ counterweights down observing position and try a sync there.


www.mainsequencesoftware.com