SGPro with AVX Mount - Error connecting to Celestron Telescope Driver


#1

I have tried everything possible to get SG Pro to connect to my Celestron AVX mount, to no avail. My PC is running Win 10 Pro, with the Nexstar HC connected to my PC via a USB 2 cable. I have installed ASCOM 6.4.1 with the Celestron Unified Ascom driver. I am using the latest version of SG Pro, although still in trial mode with valid days remaining. I have confirmed my USB connection is correctly recognized as COM10 by SG Pro, and Stellarium connected with no issues whatsoever (via COM10) and could slew my mount.

In SG Pro, I have tried using both the “Celestron Telescope Driver” option as well as the “Generic Hub” option with Celestron set in the ASCOM settings; neither work. No matter what I try, including enabling “Minimal Mode,” I get the same “Error connecting…” message. I ensured the mount is aligned properly before connecting the USB cable, in case the mount’s startup state had anything to do with it. I’m pretty sure the issue is somewhere with the ASCOM driver, since it fails when I test the connection with ASCOM Diagnostics as well.

I have included the 6 different log files which were generated on my last failed connection attempt via SG Pro:

Any help debugging this will be HUGELY appreciated, as I am at my wits end :frowning:

Regards
Ara


#2

So I decided to downgrade my Celestron Unified driver version to 5.0.30 (from the latest 6.0.6333) and SGPro is now able to connect to my telescope. So, that’s something, although would love to figure out who and where to report this accordingly.


#3

Ara,

I have the AVX mount as well and haven’t had any issues with the latest ASCOM driver. I wonder, what is the firmware version of your mount/HC? Maybe that is it? I can look when I get home and see what version I am running, but I know I updated the firmware before I started running SGPro and haven’t had any issues.


#4

Hey Stephen, thanks for the response! My HC version is 5.29.7137 and MC is 7.13.7075, the latest as of the beginning of this month, Nov. ‘18. The fact that falling back to the 5.0.30 version of Celestron’s ASCOM driver really makes me think it’s an issue with the combination of drivers: ASCOM platform version > Celestron ASCOM driver version > Telescope HC/MC firmware versions.

I’m really curious as to the versions for all 3 of yours, if you don’t mind!

Regards,
Ara


#5

No problem. I will look at everything when I get home (in about 3 hours) and post what I have. Back when I updated mine, around July, I was troubleshooting something else and ran across a post that said even though an update wasn’t posted on Celestron’s site, when you ran the update tool it did update to a newer version. This is why I ran the update. I only got an update on the HC or mount and I can’t remember which one it was. My brain is foggy as to where I was with versions when I was doing this so there is no guarantee something is out there, but seems like there would be some kind of difference since I’m not having the issue. I believe we should be able to track it down!

Update: Correction, it was Oct when I did the update, found the post where I mentioned it. So if you have a version that was released in November, I doubt I have that one and maybe that is the problem.

Be back soon!
Stephen


#6

Ara,

Back with the numbers.

Firmware:

  • MC: 7.13.7075
  • HC: GEM 5.29.7137

ASCOM:

  • ASCOM 6.4 Version 6.4.0.2618
  • Celestron ASCOM Driver: 6.0.6338.35136

So, it looks like there are some differences. Your version of ASCOM v6.4 is a little newer than mine (Didn’t realize a minor release was issued, hasn’t been that long since I installed my version) and your original Celestron driver looks to be a little older (or is that a typo? Log says 6338, post says 6333). Firmware seems to be the same provided your HC firmware was of the GEM type. I did browse over to Celestrons Nexstar listing of the firmware and there was another driver released in November for the MC (7.15.8270). Just an FYI. Does look to be some sort of ASCOM driver compatibility issue with versions.

AVX%20Firware


#7

Stephen, thanks again for tracking down your versions. I really appreciate it!

My Celestron driver version is indeed 6.0.6338.35136 (the 6333 was a typo on my part :frowning: )

Also, since you noted a new MC version was released by Celestron, I actually tried to update my mount to that new version, thinking it may resolve this compatibility issue, even though the release notes don’t say so. Everything seemed to update fine via CFM with the mount, but the version numbers stayed the same (same as you and I have for the HC/MC). I have contacted Celestron support for this separate issue now :confused:.

With the only difference between our setups being the ASCOM platform, I would be surprised if a minor SP1 release would be the cause of this issue. Little things like this bother me, as I find they are always indicators of a larger issue unless I know the cause. Alas, I guess I’ll open a support ticket with Celestron for this as well.

Once again, thanks for all your help thus far!

Regards,
Ara


#8

No problem Ara, hope you get it figured out. As a side note, I also decided to do the MC update to the 8270 version (goes against my if it ain’t broke don’t fix it rule) and my update seems to have worked. I haven’t tested it in the field yet, but the version info in the hand controller is reporting that the new MC firmware was updated to the 8270 release. Just in case by chance your CFM is different, the version I used was CFM v2.3.7111.

If you need me to look at anything else or try something, don’t hesitate to let me know.

-Stephen


#9

Well, I guess that is a good data point to know. I mean, it’s not like it’s my first time updating the firmware, so I can’t be doing too many things wrong. Everything seems to go smoothly with CFM reporting all is up-to-date at the end, but controller still shows the same versions.

Anyway, I have a few cloudy nights ahead of me this winter it seems, so hopefully I can iron these out…

Many thanks,
Ara


#10

Ara, saw this in another SGP post. Maybe this has something to do with it?

issue with ascom 6.4sp1

-S


#11

Hey Stephen, thanks for the link. I guess I will try to follow the same approach and reinstall everything, ugh. I didn’t even consider a possible issue with a Windows update.

AJ


#12

An update to this issue I had: I just recently had to rebuild the PC (OS and everything) running my AP setup, and when I finished reinstalling everything, the connection issue I had above with the latest Celestron Ascom driver worked just fine. So, it must have been a case of bad libs or installation order issue on my first attempt. Anyway, all is working as expected now. Case closed…


www.mainsequencesoftware.com