Should the roof have closed?


#1

OK, pretty much everything worked fine last night so I am mostly getting things working well. The only thing that I thought should have happened and did not is for the roof to close when the scope was parked for the last event (darks). The settings were as you see (the second being for the darks event):


The roof was opened “manually” from the control panel before the sequence was started. I then disconnected the equipment in SGP and went to MaxIm/FocusMax since I needed to set up the focus offsets in SGP and getting the offfset numbers was faster using FocusMax. Once I was done with that, I went back to SGP, loaded the sequence described above, connected the equipment, and ran the sequence.

I suspect that the fact I had shut down and then restarted SGP while the roof was open may have caused the roof not to close as expected but don’t know why this would be the case as it was connected (and did, in fact close from the control panel in SGP when I noted it had not done so by itself).

So what did I do wrong?


#2

Did you have the option to slave the observatory to the scope selected?

Essentially you need to setup when to do what (like you’ve done). But then you also have to select to slave the observatory to the scope. I’m guessing you missed that part. You can find this in the Observatory section of the “Other” tab on the Control Panel:

Thanks,
Jared


#3

Actually, I was just wondering that when I noted your reply. It may have been unchecked. I will try a test today. It appears that this checkbox setting does not save as part of the profile and needs to be checked each time. Is that correct? If so, that is probably why it happened as I assumed it would stay checked. I need to add that as a reminder in the sequence start popup.

BTW, while we are talking about “domes”, I noted that the bug (I think mentioned before) where the whole program locks
when you open the dome setup dialog from the grey icon as below. I needed to go to task manager to shut down SGP.


#4

You likely need to disconnect before accessing the settings. Some hardware can handle this, others can’t. Unfortunately ASCOM doesn’t provide us with a way to know which ones will handle it and which won’t.

Can you close the settings dialog and get back to SGP when this happens? Or is MaxDome settings dialog locked up too?

Thanks,
Jared


#5

Maxdome dialog is locked up as well. I was disconnected (and powered off) when I first accessed the setup. It just blinks the setup dialog when you try to close it. It does not seem to matter whether the dome and scope are connected or not, it still locks up the same way.

I am getting a funny feeling that this is a Doug George issue. If so, it may just be “don’t click here”. It is a seldom used
dialog that can be accessed in other ways anyway.


#6

The intent is that this is up to the driver author. If the driver can’t handle a setup dialog when connected it should show a message box saying so.


#7

It does not matter if it is connected or not. The lockup still occurs.


#8

My roof will close, even if I command it manually from the ASCOM driver software. However, just like you, I have to click ‘slaved to telescope’ and then the ‘open roof’ every time I use it.

It’s nice to have another ROR guy to bring up these issues.


#9

Thanks, It is another “no big deal” issue really, I just need to remember to check or uncheck the box and I added a popup
(which is a nice feature) to remind me.

Of course too many “no big deals” can, I suppose, eventually be a big deal.


#10

The “Open Roof First” issue has been fixed. It will come out with the next maintenance release of 2.3.

For the time being you can easily work around this by:
1 - Creating the profile
2 - Creating a sequence with the profile.
3 - Checking the “Open Roof First” option.
4 - Selecting “Save Sequence as Profile” from the File menu then save over your other profile.

Now when you use that profile the option to “Open Roof First” will be selected.

The slaving of the dome to the observatory isn’t a setting…it’s an action and it will need to be selected prior to the start of imaging. This is a safety measure to ensure that something unexpected doesn’t happen just because you connected some equipment.

Thanks,
Jared


www.mainsequencesoftware.com