SX Filter Wheel Error


#1

My SX Filter Wheel dropped in SGP tonight. This has happened several times over the past few imaging sessions and was hoping there was something in the Log to tell what is happening.

Log is attachedsg_logfile_20190318193511.txt (393.3 KB)


#2

Nothing I see in there other than SGP logging that it detected an external disconnect.

Vast majority of the time that’s a physical connection issue, bad USB cable, something along those lines.

You could spend hours of troubleshooting and testing and posting results and so on…or you could just replace the USB cable with a new one and see if that fixes it. heh


#3

Many Thanks. I’ll keep an eye on the cable.


#4

I also have the SX USB filter wheel and I had the same problem for a long time. It got completely solved when I connected the FW directly to the computer, without passing through a USB hub. This despite I tried two different hubs which both were powered. In case you use a HUB this might be worth considering.

Mikael


#5

Hi,

Thanks. With me (lately) it happens very early on and then once I reconnected things stay stable. Not sure why. I would like to avoid a long cable from the wheel to the desktop computer :slight_smile:


#6

Meanwhile, I’ve had my SX FW connected via a hub since the day I got it (2+ years ago) and haven’t had a lick of trouble with that configuration.

Which is kinda my point above…there’s 1000 different “solutions” and “troubleshooting steps” flying around, and you can drive yourself nuts trying to chase them all down…when the simplest, most likely, cheapest, and easiest solution is always :

Replace the USB cable and see what happens. :slight_smile:


#7

+1 on the usb cable being the best place to start, followed close 2nd by power cable and any other cables :=)

I run both my regular and Maxi SX FWs through a usb hub (good quality one) without issue … except for the PC reboot problem. On reboot of PC, the filter wheel shows up as not recognized in the Device Manager (ie. the dreaded exclamation mark). Only way to resolve is to unplug and replug the FW usb cable, after the Windows OS has fully finished its startup routine. Or, if running remote, can try “Disabling” and then “re-Enabling” the entry in Device Manager (this may take several tries).

DaveNL


www.mainsequencesoftware.com