SX USB filter wheel not connecting - all the time


#1

When I start SGP 3.x and attempt to connect my equipment the SX USB Filter wheel does not connect. The solution is for me to unplug the USB cable from the computer, then replug it into the same port AFTER all the other equipment has connected (mount, focuser, cameras). I have swapped out the USB cable and even purchased a new cable – same problem. This did not happen with SGP 2.6. Any suggestions on how I can overcome this problem?


#2

I am afraid I cannot help with this problem. But I have exactly the same experience with my SX filter wheel. Once my observatory is open I can connect and run it from my indoor PC. Except I have to go down and unplug the cable to the filter wheel and plug it in again whereupon it works perfectly. I have had the FW. For quite a few years and it has always been the same (with all versions of SGP right back to the early years). Could it be a driver problem?
If anyone has a solution I would be pleased to hear it.
Thanks Adrian


#3

Interesting! I think it is a SGP problem. Last night I uninstalled all the COM Ports and USB drivers on the computer, then restarted the computer – Windows will automatically reinstall the drivers, this “trick” is suppose to take care of flaky drivers. I then started SGP and still could not connect. Then I did a small experiment. I recently downloaded a 30 day trial of another all in one imaging software so I gave it a try. This software does find the filter wheel. So, I thought that the “problem” was somehow fixed. I shut down the alternate program and fired up SGP again. This time SGP could not find both my filter wheel and my camera. To finish my night, I once again quit SGP and tried one more time with the alternate program. It finds all the hardware I have attached. I even restarted the computer one more time and SGP is still broken. I did not think of it last night, but I need boot up the observatory computer to post a copy of the log file. Any thoughts?


#4

There is a “known issue” with SX filter wheels (I have both regular and Maxi versions) where the computer does not recognize the device, Usually on a fresh reboot/start-up of the PC. Unplugging and replugging the usb cable usually resolves the issue. Try opening up Device Manager and see if there is a usb entry with Exclamation mark.

As was pointed out above, this is problematic for remote control observatories. What I have found works most of the time is to “disable” the driver and then “enable” it (will need admin access in Device Manager). Sometimes have to try this multiple times before it works, For the odd time this doesn’t work, I am glad my “remote” obs is only a 2 minute walk away :smile:

DaveNL


#5

I too have this problem, but it is an SX driver issue I think.

There was an old version of the ascom driver, with the included fw program, would error out the driver and software. You could use this error to restart the device remotely. I had written an instruction set a long time ago, but I have no clue where it is now. I’ll have a look.


#6

If you find it please let me know. What is odd that makes me think it’s an SGP problem is that all the equipment connects with the alternative imaging software that I tried last night?? Why would the filter wheel connect with that software and not SGP? I remember reading just a few days ago about an issue where you need to make a backup copy of some type of SGP file in case Windows has a problem but I can’t remember the thread. Do you think that’s the issue —— a file has become corrupted? If anyone can tell me the topic of that fourum thread that would be wonderful.


#7

Have you updated the filterwheel firmware? Some of the later versions have a fix for this kind of an issue. You can find the update here: http://www.sxccd.com/downloads/Fwheelupdate-1040.zip


#8

You know, I don’t think that I have updated this version. I don’t ever remember reading about the version being able to automatic re-boot wheels at remote sites. I’m going to give a try and report back tomorrow

Thanks


#9

I had the same problem with both SX wheels a few years ago. This was using the ASCOM driver and…Maxim DL. The driver updates were only partially successful for me and in the end I gave up on SX camera/wheel and went QSI/ SGP.


#10

Yes it is definitely not a SGP issue, it is SX. I have 3 of them, of varying types and ages and they all do it. It has been there from day 1 and an attempt to add a reset USB function to the driver was made, but of course this was pointless as you aren’t connected!

If you run remote, use another filter wheel I’m afraid.


#11

I regret to say that I also experience the exact same problem but with an Atik EFW2 Filter Wheel. About 50% of the time when I turn the power on and connect everything I’ll get an “unable to connect” message. I simply unplug the power to the filter wheel, plug it back in and SGP will connect. Exact same behavior as the OP.

I have always assumed this was an Atik driver issue…now I’m not so sure.


#12

Hello All,
The only thing it can be is an SGP issue. The reason why – the filter wheel and all the other equipment connect just fine with the alternative software that I used. If it were strictly a filter wheel problem or filter wheel driver problem, then the other software would also have the problem. That’s my hypothesis and I’m sticking to it :smile:


#13

Here is the log from today after I have updated the drivers. Still no connection to the filter wheel

[04/07/18 20:39:51.992][DEBUG] [Main Thread] Licensing: Machine ID found…
[04/07/18 20:39:52.210][DEBUG] [Main Thread] Checking for valid internet connection…
[04/07/18 20:39:52.554][DEBUG] [Main Thread] Valid internet connection detected…
[04/07/18 20:39:54.289][DEBUG] [Main Thread] Licensing: Request for licenses successful, writing cookie…
[04/07/18 20:39:54.336][DEBUG] [Main Thread] Licensing: Applying licenses…
[04/07/18 20:39:54.336][DEBUG] [Main Thread] Licensing: Licenses applied…
[04/07/18 20:39:54.336][DEBUG] [Main Thread] SGPro retail license…
[04/07/18 20:39:56.398][DEBUG] [Main Thread] API successfully started on port 59590…
[04/07/18 20:39:58.373][DEBUG] [Main Thread] Error loading notification settings! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\notifications.sgd’.
[04/07/18 20:39:58.383][DEBUG] [Main Thread] Error loading GNS endpoint settings! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\gnsSettings.sgd’.
[04/07/18 20:39:58.387][DEBUG] [Main Thread] Error loading email endpoint addresses! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\1-emailEndpointAddresses.sgd’.
[04/07/18 20:39:58.387][DEBUG] [Main Thread] Error loading email endpoint addresses! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\2-emailEndpointAddresses.sgd’.
[04/07/18 20:39:58.388][DEBUG] [Main Thread] Error loading email endpoint addresses! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\3-emailEndpointAddresses.sgd’.
[04/07/18 20:39:58.390][DEBUG] [Main Thread] Error loading text file endpoint data! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\1-textFileEndpointSettings.sgd’.
[04/07/18 20:39:58.391][DEBUG] [Main Thread] Error loading text file endpoint data! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\2-textFileEndpointSettings.sgd’.
[04/07/18 20:39:58.391][DEBUG] [Main Thread] Error loading text file endpoint data! Could not find file ‘C:\Users\OEM\AppData\Local\SequenceGenerator\Sequence Generator Pro\3-textFileEndpointSettings.sgd’.
[04/07/18 20:39:58.849][DEBUG] [Main Thread] ===== S E Q U E N C E G E N E R A T O R (v3.0.1.0) =====
[04/07/18 20:39:59.150][DEBUG] [Main Thread] OS: Microsoft Windows 10 Home
[04/07/18 20:40:00.669][DEBUG] [Focuser Thread] Entering Fouser message dispatch loop…
[04/07/18 20:40:00.671][DEBUG] [Camera Thread] Entering camera message dispatch loop…
[04/07/18 20:40:00.671][DEBUG] [TEC Thread] Entering TEC message dispatch loop…
[04/07/18 20:40:00.672][DEBUG] [Filter Wheel Thread] Entering Filter Wheel message dispatch loop…
[04/07/18 20:40:00.674][DEBUG] [Rotator Thread] Entering Rotator message dispatch loop…
[04/07/18 20:40:00.677][DEBUG] [Auto Guider Thread] Entering Auto Guider message dispatch loop…
[04/07/18 20:40:00.679][DEBUG] [Auto Guider Error Thread] Entering Auto Guider message dispatch loop…
[04/07/18 20:40:00.680][DEBUG] [Dome Thread] Entering Dome message dispatch loop…
[04/07/18 20:40:00.680][DEBUG] [Safety Thread] Starting safety monitor…
[04/07/18 20:40:00.684][DEBUG] [Environment Device Thread] Starting environment device monitor…
[04/07/18 20:40:00.717][DEBUG] [Telescope Thread] Entering Telescope message dispatch loop…
[04/07/18 20:40:00.799][DEBUG] [Main Thread] Settings changed (or loaded)…
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingMdiAutoStretch = False
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingIgLastFileFolder =
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingFormScaleWarning = False
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingRecoveryDuration = 90
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingSBIGLpt2Address = 278
[04/07/18 20:40:00.800][DEBUG] [Main Thread] * SETTING: settingFliFlushLow = 0
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingSBIGLpt1Address = 378
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingShowBetas = False
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingMdiMouseAction = Stretch
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingLastAscomCamera =
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingTemperhumInterval = 300
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingASCOMWarningShown = False
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingPlateCamScale = 0
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingCanonMirrorSettle = 0
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingInterface =
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingLastAscomFilterWheel =
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingAstroArtDisplayInstructions = True
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingMdiPhdZoom = 40
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingCheckForUpdatesOnStart = True
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingMdiLastImageDir =
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingTemperHumUserTempComp = 0
[04/07/18 20:40:00.801][DEBUG] [Main Thread] * SETTING: settingCaptureCalFramesAlways = False
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingDelayFirst = 0
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingFliNormalSpeedMode = 0
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingFliHighSpeedMode = 0
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingMfPosition = {X=0,Y=0}
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingSoundAttention =
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingPinpointCatalog =
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingCameraOverhead =
[04/07/18 20:40:00.802][DEBUG] [Main Thread] * SETTING: settingPlateSolveOn = False
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingAstrometryNetEndpointList = System.Collections.Specialized.StringCollection
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingSBIGGuider = None
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingFocusLockDirectory =
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingQSIFanSpeed = 2
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingNaggerText =
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingMdiPhdDisplay = RA/Dec
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingMdiShowToolStrip = True
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingMdiShowCrosshairs = True
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: WindowGeometry =
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingIgRenameStringLocation = 2
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingIgSubFolders = False
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: WindowGeometrySearch =
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingOffset = -1
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingAutoStretchLevel = Low
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingTemperHumUnits = C
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingProfileDirectory =
[04/07/18 20:40:00.826][DEBUG] [Main Thread] * SETTING: settingBasename =
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingHfrColor = Color [RoyalBlue]
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingNikonAfBinning = 1
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingSBIGFanOffWithTec = False
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingLastAscomSafetyMonitor =
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingMdiSize = {Width=800, Height=600}
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingIgCopyAndRenameFiles = False
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingSimDownloadTimesAf = False
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingNagger = False
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingImportFromCfw = True
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingMdiShowStatusTrip = True
[04/07/18 20:40:00.827][DEBUG] [Main Thread] * SETTING: settingShowTooltipHelp = True
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingLastUpdateCheck = 1/1/2012 12:00:00 AM
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingEventSuffixes = null
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingCpPosition = {X=0,Y=0}
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingSBIGCfwPort =
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingMdiLocation = {X=0,Y=0}
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingIgLastCsvFolder =
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingPlateSolve3Catalogs =
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingSBIGFilterWheel = Auto Detect
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingSBIGConnection = USB
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingDSLRSoftwareBinForAf = False
[04/07/18 20:40:00.828][DEBUG] [Main Thread] * SETTING: settingAutoSave = True
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingFirstTime = True
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingAutoRecoveryActive = False
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingMdiState = maximized
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingUseSequenceOptions = False
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingSoundCompleted =
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingTrialExpiredShown = False
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingTemperHumColor = Grey
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingDataDirectory =
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingCanonFileFormat = Single Image (CFA FITS)
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingAlnitakComPort =
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingIgRenameFiles = False
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingPhd2InstallPath =
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingSubFolder = True
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingLastSGSaveFolder =
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingFindStars = Normal (recommended)
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingNikonDataFormat = FITS
[04/07/18 20:40:00.829][DEBUG] [Main Thread] * SETTING: settingPlaySounds = False
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingLastNikonType = Auto Connect
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingLastSequenceStart = 1/1/0001 12:00:00 AM
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingLastAscomTelescope =
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingMdiPhdScale = 100
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingIgRenameType = 0
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingHelpLanguage = English
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingTemperHumUserHumidityComp = 0
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingMdiPhdRaColor = Color [Blue]
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingLastImageSaveFolder =
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingIgOverwriteExisting = False
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingFinishFullEvent = True
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingMosaicOverlap = 20
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingQSIFanOffWithTec = False
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingRecentSequences =
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingDefaultDirectory =
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingMdiPhdDecColor = Color [Red]
[04/07/18 20:40:00.830][DEBUG] [Main Thread] * SETTING: settingAstrometryNetEndpoint = Astrometry.NET (Remote)
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingFliFlushHigh = 0
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingStarsColor = Color [OrangeRed]
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingDefaultMfwFov = 4.0
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingSBIGLpt3Address = 3BC
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingLastAscomFocuser =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingIgLastFolder =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: WindowGeometryOpen =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingNumEvents = 5
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingDelayBetween = 0
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingCanonAfBinning = 1
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingPlateCamBlank =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingLogApiCalls = False
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingNikonUseBulbModeAlways = False
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingTempFiles = C:\Temp
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingFliHighSpeedDesc =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingSBIGCfwUseRS232 = False
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingRecoveryInterval = 10
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingEnableImageHistory = False
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingSBIGEthernetIP = 0.0.0.0
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingFliNormalSpeedDesc =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingIgCopyLocation =
[04/07/18 20:40:00.831][DEBUG] [Main Thread] * SETTING: settingSBIGAutoDetectIp = True
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingAstroArtStartApp = True
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingSimDownloadTimesPlate = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingMicroTouchLocation =
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingEventAlwaysVisible = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingMdiNewWindow = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingTrialQuestionsAsked = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingFliRbiMitigation = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingGain = -1
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingLastAscomDome =
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingLookForTemperDevices = False
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingLastAscomRotator =
[04/07/18 20:40:00.832][DEBUG] [Main Thread] * SETTING: settingAfTestPackPath =
[04/07/18 20:40:01.276][DEBUG] [Main Thread] ASCOM Observing Conditions Hub (OCH)
[04/07/18 20:40:01.277][DEBUG] [Main Thread] ASCOM Observing Conditions Simulator
[04/07/18 20:40:01.277][DEBUG] [Main Thread] OpenWeatherMap ObservingConditions
[04/07/18 20:40:01.277][DEBUG] [Main Thread] TEMPerHUM
[04/07/18 20:40:01.283][DEBUG] [Main Thread] Performing initialization…
[04/07/18 20:40:01.284][DEBUG] [Main Thread] Creating new sequence with default profile: CEM60
[04/07/18 20:40:01.327][DEBUG] [Main Thread] Performing full form reset (with profile CEM60)…
[04/07/18 20:40:01.345][DEBUG] [Main Thread] Retreiving new equipment objects…
[04/07/18 20:40:01.345][DEBUG] [Main Thread] New camera object (ASI Camera (1)) dispatched…
[04/07/18 20:40:01.458][DEBUG] [Main Thread] New filter wheel object (Starlight Xpress Filter Wheels) dispatched…
[04/07/18 20:40:01.461][DEBUG] [Main Thread] New environment device object (OpenWeatherMap ObservingConditions) dispatched…
[04/07/18 20:40:01.467][DEBUG] [Main Thread] New focuser object (Optec TCF-S) dispatched…
[04/07/18 20:40:01.472][DEBUG] [Main Thread] New telescope object (iOptron ASCOM Driver for Mount) dispatched…
[04/07/18 20:40:01.476][DEBUG] [Main Thread] New rotator object (No Rotator) dispatched…
[04/07/18 20:40:01.478][DEBUG] [Main Thread] New dome object (No Observatory) dispatched…
[04/07/18 20:40:01.479][DEBUG] [Main Thread] New flat box object (No Flat Box) dispatched…
[04/07/18 20:40:01.481][DEBUG] [Main Thread] New safety monitor object (No Safety Monitor) dispatched…
[04/07/18 20:40:01.483][DEBUG] [Main Thread] New auto guider object (PHD2) dispatched…
[04/07/18 20:40:01.483][DEBUG] [Main Thread] New plate solver object (PlateSolve2) dispatched…
[04/07/18 20:40:01.616][DEBUG] [Main Thread] Populating the form controls…
[04/07/18 20:40:01.795][DEBUG] [Main Thread] Added row 0…
[04/07/18 20:40:01.940][DEBUG] [Main Thread] Added row 1…
[04/07/18 20:40:02.132][DEBUG] [Main Thread] Added row 2…
[04/07/18 20:40:02.389][DEBUG] [Main Thread] Added row 3…
[04/07/18 20:40:02.701][DEBUG] [Main Thread] Added row 4…
[04/07/18 20:40:02.749][DEBUG] [Main Thread] Loading custom filter names…
[04/07/18 20:40:02.778][DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[04/07/18 20:40:03.033][DEBUG] [Main Thread] Retreiving new equipment objects…
[04/07/18 20:40:03.033][DEBUG] [Main Thread] No change in camera object…
[04/07/18 20:40:03.033][DEBUG] [Main Thread] No change in filter wheel object…
[04/07/18 20:40:03.033][DEBUG] [Main Thread] No change in environment device object…
[04/07/18 20:40:03.034][DEBUG] [Main Thread] No change in focuser object…
[04/07/18 20:40:03.036][DEBUG] [Main Thread] MoveFocuserAbs: Error! The focuser is no longer connected!
[04/07/18 20:40:03.036][DEBUG] [Main Thread] No change in telescope object…
[04/07/18 20:40:03.036][DEBUG] [Main Thread] New rotator object (No Rotator) dispatched…
[04/07/18 20:40:03.036][DEBUG] [Sequence Thread] Entering sequence message dispatch loop…
[04/07/18 20:40:03.038][DEBUG] [Main Thread] New dome object (No Observatory) dispatched…
[04/07/18 20:40:03.039][DEBUG] [Main Thread] New flat box object (No Flat Box) dispatched…
[04/07/18 20:40:03.041][DEBUG] [Main Thread] New safety monitor object (No Safety Monitor) dispatched…
[04/07/18 20:40:03.042][DEBUG] [Main Thread] New auto guider object (PHD2) dispatched…
[04/07/18 20:40:03.043][DEBUG] [Main Thread] No change in plate solver object…
[04/07/18 20:40:03.051][DEBUG] [Main Thread] Checking if version check is required…
[04/07/18 20:40:03.129][DEBUG] [Main Thread] Checking for updated version…
[04/07/18 20:40:03.475][DEBUG] [Main Thread] Version Check: Could not find version info for beta track (Sequence+Generator+Pro+3+Beta. : Could not fetch Sequence+Generator+Pro+3+Beta
at rk.aa(Boolean A_0)
[04/07/18 20:40:03.903][DEBUG] [Cleaner Thread] Running cleanup…
[04/07/18 20:40:03.904][DEBUG] [Cleaner Thread] Cleaning 0 files in directory C:\Users\OEM\AppData\Local\SequenceGenerator\Temp…
[04/07/18 20:40:03.904][DEBUG] [Cleaner Thread] Cleaning multi camera registration file…
[04/07/18 20:40:03.905][DEBUG] [Cleaner Thread] Cleaning finished…
[04/07/18 20:40:03.905][DEBUG] [Main Thread] UI layout found, loading layout at C:\Users\OEM\AppData\Local\SequenceGenerator\sg_ui_config.xml
[04/07/18 20:40:24.328][DEBUG] [Main Thread] Connecting camera in main thread…
[04/07/18 20:40:24.340][DEBUG] [Main Thread] Connecting ASCOM camera: ASCOM.ASICamera2.Camera…
[04/07/18 20:40:26.551][DEBUG] [Main Thread] Camera implements ASCOM gain. Current gain is 139
[04/07/18 20:40:26.589][DEBUG] [Main Thread] Failed to fetch ASCOM camera gains list, checking min / max… : Property read Unknown is not implemented in this driver. (ASCOM.PropertyNotImplementedException: Property Unknown is not implemented in this driver.
at ASCOM.ASICamera2.Camera.get_Gains())
at ASCOM.DriverAccess.MemberFactory.GetTargetInvocationExceptionHandler(String memberName, Exception e) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 661
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in c:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 231
at ASCOM.DriverAccess.Camera.get_Gains() in c:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 864
at q7.bz()
[04/07/18 20:40:26.652][DEBUG] [Main Thread] Camera cooler detected…
[04/07/18 20:40:26.654][DEBUG] [Main Thread] Camera cooler is OFF…
[04/07/18 20:40:26.655][DEBUG] [Main Thread] Camera cooldown on connect is selected…
[04/07/18 20:40:26.655][DEBUG] [Main Thread] Camera cooldown is starting…
[04/07/18 20:40:26.663][DEBUG] [TEC Thread] SGM_CHANGE_COOLER_TEMP message received…
[04/07/18 20:40:26.667][DEBUG] [TEC Thread] TEC Change: Starting…
[04/07/18 20:40:26.668][DEBUG] [TEC Thread] TEC Change: After camera connect change, waiting ~5 seconds…
[04/07/18 20:40:31.676][DEBUG] [TEC Thread] TEC Change: Attempting to turn the camera cooler on…
[04/07/18 20:40:31.677][DEBUG] [TEC Thread] Turning camera cooler on…
[04/07/18 20:40:36.685][DEBUG] [TEC Thread] TEC Change: Changing temp from -17.60 to -20.00 in 600 seconds…
[04/07/18 20:40:59.480][DEBUG] [Main Thread] Turning camera cooler on…
[04/07/18 20:42:08.585][DEBUG] [TEC Thread] TEC Change: Aborted…
[04/07/18 20:42:08.585][DEBUG] [TEC Thread] SGM_CHANGE_COOLER_TEMP complete…
[04/07/18 20:42:10.386][DEBUG] [Main Thread] Turning camera cooler off…
[04/07/18 20:42:10.389][DEBUG] [Main Thread] Disconnecting ASCOM camera: ASI Camera (1)…
[04/07/18 20:42:10.693][DEBUG] [Main Thread] Turning camera cooler off…
[04/07/18 20:42:21.156][DEBUG] [TEC Thread] TEC Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.156][DEBUG] [Sequence Thread] Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.156][DEBUG] [Focuser Thread] Focuser Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.156][DEBUG] [Telescope Thread] Telescope Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.156][DEBUG] [Auto Guider Thread] Auto Guider Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.157][DEBUG] [Camera Thread] Camera Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.157][DEBUG] [Filter Wheel Thread] Filter Wheel Dispatch loop: Received SGM_TERMINATE…
[04/07/18 20:42:21.296][DEBUG] [Main Thread] Performing clean up…


#14

One more thing to add. I did an ASCOM diagnosis test, and ACSOM can connect to the filter wheel


#15

I have 2 EFW2’s and an EFW3 Joel and never had that issue with any of them, only the SX.


#16

Can you tell me what version of the Atik driver you are using?


#17

I am like @RayD - both EFW2 & EFW3 work without problem. Have updated the driver from time to time from the Atik site…so it is not a question of rolling back to an old driver. I think I last updated back in Jan/Feb this year (can’t check this at the moment).

My EFW3 is connected through Pegasus Ultimate Hub (https://pegasusastro.com/products/ultimate-powerbox/). This shows the power use on individual items and I can clearly see that the EFW3 (and the EFW2 before it) do not draw constant power. They appear to connect/disconnect on an ongoing basis. Since two different EFWs have done the same - I assume this is as per design.
But this may be the root of your problem.
When I got the Pegasus it highlighted something I did not previously realise - that my AC/DC converter, powering my mount accessories, was not up to the job. The more than12V went down below 11V when things got busy. I subsequently bought a higher spec converter and ALWAYS have more than 12V available now to any and all accessories…camera, filter wheel, dew heaters, focuser.
So, whether you run at home with AC/DC converter or in the field on battery…I think all should be aware that things go downhill rapidly if you don’t have enough ‘juice’ to run everything. It is often overlooked when trying to sort intermittent problems. (Just my opinion :pensive:)

Kinch.


#18

I’ve always used whatever the latest one released by Atik is, Joel. I last updated when the EFW3 came out, which was earlier this year, and have never had an issue.

The reason I’m sure this isn’t a SGP issue is that there are many posts dotted about talking about this issue outside SGP, from years ago, in other forums. I think the consensus generally is that it is a timing issue, in that more often than not, if you connect to the FW immediately it is fine, but if you power up and don’t connect straight away the problem manifests. I’ve tried it in all sorts of ways and never been able to recreate it consistently enough to be convinced this is the case, but it happens for me outside SGP also using the SX software.

From memory SX didn’t write the ASCOM driver, it was written by Bret McKeel for them, but was last updated many years ago. You would like to think they would perhaps have a fresh look now and update as necessary.

I think also that SX really intend (hope) for their devices to be used with their own software.


#19

This is not argumentative so please don’t read it that way. 1) Why are individuals asking me if I installed the latest Atik driver? I own a Starlight Express filter wheel. I don’t understand, please explain. 2) How can it not be an SGP problem when the Starlight Express filter wheel connects via ASCOM and it connects with the alternative software - I don’t want to name the software since this is an SGP forum. Please explain. Jared, I need your help!!! Please help me out. I copied my log a few posts ago.


#20

wglogoski,
I asked about the Atik driver. I wasn’t asking you directly, but rather
RayD who also participated in this thread. I offered another data point
that my Atik EFW2 was exhibiting the same behavior as your SX filter
wheel. Since RayD has never had this problem with his Atik filter wheels,
I was curious what driver he is using.

I don’t know the answer to your second question, but if this was just an
SGP issue then I might expect that all filter wheels might experience this
behavior, which isn’t the case.

I think RayD might be right about the USB timing issue. From now on I’m
going to try connecting the filter wheel right away first before anything
else and see if the problem happens again.


www.mainsequencesoftware.com