SX USB filter wheel not connecting - all the time


#21

No I get it! :smile: Thanks for clarifying this it is much appreciated!


#22

Oops that was suppose to be, Now I get it! Thanks again!


#23

The reason I don’t think it is necessarily a SGP issue is that I have exactly the same problem on all 3 of my SX wheels when using them directly via the SX software if I don’t connect to the FW immediately on power up. MaximDL and AA have SX wheel command sets built in, so I don’t think they use the ASCOM driver.

As Joel says, if it is a SGP issue, it would happen on every wheel, but it doesn’t. This has been brought to the attention of Terry at SX on many occasions, and it is most likely to be a SX ASCOM driver issue, but it hasn’t been updated for quite some time.

If you update to the latest firmware and connect via serial (this was strangely added as an option) then the problem goes, using the exact same ASCOM driver. I think that the powering of the motor happening at exactly the same point as the USB connection is problematic, and will only be resolved fully by using the serial connection is connecting to it using the ASCOM driver.


#24

Sounds like there could be two separate issues at play here.

The issue I referenced earlier relates to usb drivers (and which the latest FW firmware from a couple years ago did not fully resolve). If the usb driver is not recognized, then nothing can connect to the FW (inside or outside SGP).

However, if @wglogowski does not see this kind of entry in his Device Manager:

image

and still cannot connect to FW within SGP (but can from other apps), then that sounds like a separate issue.

FWIW, as long as Device Manager is recognizing my FW usb driver correctly, I have never had an issue with connecting to the FW from within SGP (both regular and MAXI wheel). I am currently on 2.6.0.25.

And I am starting to agree with comments above about SX FW’s and truly remote obsy’s (recommendations anyone?).

DaveNL


#25

Yes this is my experience with all of mine and has been known for a long time.

Atik EFW2 (or 3 if you need 2" filters) for remote for me. Never fails to connect and excellent build quality. Obviously you need the power supply also.


#26

Hello Dave

When I check my Device manager USBs all of them are working properly.

Walter


#27

Check the power management panel on your USB generic/root hubs. Make sure its
not set to turn off to save power.


#28

I have the SX Mini FW which I am using with SGP 2.6.0.25 and have the same issue. When I hit connect in SGP everything connects except the FW.

If I disconnect the FW USB cable and reconnect it usually sorts itself out but can take several attempts and sometimes when it reconnects the FW just rotates endlessly at which point I usually have to reboot and start again.
Very frustrating.


#29

So I was the person who originally posted the problem. What is really frustrating to me is that the only advice that I have gotten so far is to unplug and replug the cable, check the USB device manager, purchase a new filter wheel for $$$ or buy "powered USB hub for $600! Come on! And, I keep getting told that it’s not a SGP issue even-though I never had a problem with the 2.6 software version.


#30

Might be worth making Starlight Express aware of the thread, they are very helpful and would probably check out the driver.
Jon


#31

Just a thought - timing is…everything. Have you run the ASCOM conformance checker on the SX ASCOM driver? I have seen a few posts on various device connections recently that relate to the difference between synchronous and async commands. Suffice to say that not all ASCOM drivers are created equal in this regard and it provides opportunity for the host application to ‘go wrong’.


#32

There is a difference between a trigger and the root cause of an issue. When a device is not ‘robust’ to noise factors, it may only take a small change in its environment to cause an issue. This might just be a small difference in software command timings, power supply voltage during power up, etc.
The difficulty for any application provider that interface through ASCOM to devices is that while some models always work, others have issues, using the same ASCOM conforming software commands. Some drivers are clearly at fault and in addition, while there is an ASCOM conformance specification, in some cases I suspect there may be some chinks in it that allow through issues in some systems.

[edit] - my observatory has 4 high quality PWM Power supplies for NUC, Roof, Camera and Noisy consumers. I noticed I occasionally got connection anomalies if I simply turned on a master mains switch with all my 12 V DC switches in the on-position. I assumed the surge in demand on power up was creating the problem (voltage or RFI). The issues go away if I flip the mains switch and then turned on the two DC switches in short order, just a few seconds apart.


#33

I’m on mains supply and have tried dedicated USB port so I don’t think supply is the issue.

I don’t always get an error message when I have issues but just found these from the last time it happened in February.


#34

Well - that error message appears to becoming from ASCOM / hardware.
ASCOM commands are pretty basic and a filter wheel driver is probably the most basic of the lot. (http://www.ascom-tandards.org/Help/Developer/html/T_ASCOM_DriverAccess_FilterWheel.htm)
It is difficult to see how SGP can be doing something ‘wrong’ with so few driver commands, which would make a timing issue more likely to be the cause. For instance, it may be that SGP asks the filter wheel where it is while it is still moving and it falls over. In my own ASCOM roof controller, I keep a local status, so if I get a request for roof position while it is moving, it reports the prior known status, without interrogating the hardware.

In regard to power, the other consideration is the length and quality of the USB cables. There are some very inexpensive and ugly ones out there. I gone through a few in my time and they do sometimes wear out for no apparent reason. I have Lindy ones at present and they have been consistently reliable.


#35

I have the SX USB Filter Wheel (5 position) and SGP connects to it just fine. When it first comes on, it rotates through the positions (assuming to find the home position). However, where it connects to the hub the port indicator stays unlit! Seems a bit strange but regardless, it is indeed connected and works just fine with SGP and the SX native app. Running under Windows 10 Pro 64bit and latest versions of all software/drivers. The latest Windows update has fixed the ASCOM issues that came up before.

If your filter works with the native app but not SGP, I would do a clean install of everything and see if it works, or better yet install on another computer and test. There should be no reason for the filter wheel failing to connect to SGP. Otherwise, there may be some hardware or driver issue/incompatibility.

Ciao,
Mel

P.S. Not sure if it will help, but I turn off the Power Management on all USB devices. This is an option under Power Management tab in the respective device’s driver. The theory is if the computer/OS is doing something to change the state of devices, I don’t want that to happen during normal operation.


#36

Terry at SXccd has advised me to use USB2 rather than USB 3. Also to update the firmware which I have done. I spent a couple of hours testing yesterday and it is much improved although not completely fixed. I did an imaging session last night and it worked without issue, probably for the first time. SGP crashed on me which it does too regularly (Whilst stretching a light to check it out) but the FW just worked. I also found in testing that using the USB on the camera to power the FW was less reliable than connecting directly to laptop.

So using USB 3, at least in my case, causes issues.

Hope this helps
Jon


#37

I’m just about to upgrade my system hubs to USB3. I know there have been early implementation issues with USB3, including interference with WiFi and other issues. Some of the modern CMOS cameras use USB3 for fast downloads. I’m using the Startech industrial 2.0 hubs at present. They have been really good, even in freezing conditions. I’m going to try one of their 7-way USB3 hubs in the coming weeks. They are the best part of $100, but that’s progress…


#38

Hi

I’ve been having this problem with my SX filter wheel ever since I can remember.

Like others, I find that I can sometimes connect to all of kit except the SX filter wheel and this can be overcome by unplugging and replacing the USB lead - sometimes this takes two or three attempts. The FW is connected to a good quality USB 2 powered hub and when this happens, there are no warning symbols on the USB devices on Device Manager and the FW can be accessed using other software and the SX FW program. I’ve updated the firmware but this has made no difference.

Any advice / solution would be great please!

Cheers

Steve


#39

At one point I contacted Terry from SX about similar problems. Often I needed to unplug and replug the filterwheel several times before it started working, and sometimes the connection was lost during imaging.

I have a pretty old wheel, and Terry said they might have problems with 64-bit Windows, unless the bootloader firmware of the wheel is updated.

Updating the bootloader requires a PICkit programmer or similar, and my friend happened to have one so I was able to do the update without sending the wheel back to SX.

So far it has worked pretty well. Sometimes it might not work right after connecting the wheel to my computer’s USB port, but usually starts working about 30-60 seconds after connecting. I have a permanent setup in my observatory and I don’t think I’ve had to unplug the wheel even once during this winter.


www.mainsequencesoftware.com