Tested Beta last night


Here’s a quick update on Beta

For the first time since the meridian flip finally worked, went off without a hitch. the sequence ran the entire night unattended, Imaged 3 hours on the Fireworks Galaxy and 5 hours on the Bubble Nebula. Scope parked and did all of the Calibration frames, Flats, Bias and Darks.

I only found two issues from last nights run.

  1. After the Flats were done the Flat panel did not turn off as expected.
  2. I still have issues with convergence during platesolve centering. mount always seems to gets stuck, and is very repeatable, between 75 and 85 pixels no matter how many attempts are tried. Because of this I set the centering to 80 pixels. I’m using a CGE-Pro mount.

I used the new “Sync” setting. I’m not sure I understand what the new Offset or non-sync settings do. Plus Ken said these have not been tested so I didn’t want to be the first without knowing what they are suppose to do.

I think that’s all for now If the weather holds again tonight, I’m planning on another run at the same targets. If I have any problems I’ll post the logs.

BTW - Great software!



Update - I ran another sequence last night with and everything worked, The only issue I’m having besides the mount not wanting to converge during centering is the Flat panel turns on but does not turn off.

My imaging run finishes up at 4 AM and I have it set to park the mount and begin doing the calibrations with Flats being the first follow by Bias and finally Darks. The flats start at 4 AM and finish up at 4:15. I look through the log and found the flat box turns on at the expected time of 4 AM but is not told to turn off until 4:58. I’m not sure why or whats so special about 4:58 but I would think the flat box would be told to turn off after all the flats have been taken or until the allotted time has expired.

Anyway I attached the log file. If you look at 4 AM you see the lightbox being set to 5 and turning on. it is not told to turn off until 4:58 as per the log. But even then when i wake up in the morning I find the panel is still on.

Attached is the log file from last night. I had to remove some of the text to get the file under the 1024 limit.

mahaffm SGPro Log from 9-12-16.txt (635.0 KB)



I just wanted to bring this up again with the issue of the Alnitak light box not turning off after the sequence finishes. Maybe I don’t have something configured correctly but for whatever reason, after the sequence completes taking the required flats the Alnitak flat panel is not given the command to turn off. As per the attached log, at 4:00:01 AM the Alnitak Flat box is told to turn on, setting brightness 5, but is never told to turn off. When I wake up in the morning I need go into the sequence and set the brightness to 0, As per the log this occurred at 4:50:43 AM.

(461.7 KB)




I can see the bug… we just need to think about how to address it without breaking other flatboxes. Should be out in the next beta.



That would be great, thanks for checking into it.



Yes, I have seen the Alnitak not turning off as well. That issue has been around for a long time - at least since 2.4.X. Not a super big deal for me as I do flats during the day since my setup is inside a rolloff that is dark during the day. Would be nice to have it fixed, however. has been just super for me (other than the minor no-dither on first frame mentioned on the other thread). I installed it on a new W10 pro Skylake speed demon that I just built and it runs all night smooth as glass so far.

My only complaint is that GNS seems to be a bit overly sensitive and often comes up with alerts that are of no consequence. I get up from a GNS alert expecting a disaster only to find things running normally. But if it runs as smoothly as it has, GNS is not nearly as critical. Besides. I also set up this so I don’t have far to go :slight_smile:


That is one really cool setup! I remote in using my iPad and have it set up beside my bed, if clouds move in, the pinging of the lost star from PHD2 wakes me and I go out and close everything up. My setup isn’t automated, I built a small shed and I have a light panel mounted on the wall so when the mount is parked it can take the flats. I typically do my flats at the end while it’s still dark.I can close up the shed and do that during the day but haven’t had a need to. Here’s what it looks like when it’s open…

This was my summer project. Thanks to all the hard work Ken and Jared has put into SGPro, I felt it was time to have something more permanent.



Nice! Nothing like a permanent mount, that is for sure. Yes, the bed arm is nice. Unfortunately it was more of a necessity than a luxury since I have lumbar spine and knee problems which make it hard to sit at a desk for long enough to process images these days. The arm is great for those long sessions w/o much typing. Not really all that expensive either, under $300 for the arm. Needs to be mounted on a plate spanning two studs which takes some effort but my other hobby is woodworking so not a big deal.



Agree, that arm needs to be securely mounted given the length of the cantilever, hate to have it come crashing down while you’re sleeping :frowning:. BTW I work for a medical device orthopedic company and we have fixes for that back and knee of yours. I had a knee replacement last year and the knee has never felt better,



Yes, I plan to have that done but it is not quite ready for that yet.


I just finished what I believe to be a proper fix for this issue. It will be out in the next beta release.



That is great news, thank you for looking into it and doing the fix.



Hi Ken

Wanted to give you an update. I tested out the Alnitak Flat Box fix in Beta and it seems to work just fine now. When the Flats are done the Flat Box is turning off.

Thanks for doing the update/fix for this.

Kind Regards,


Good to hear. I will try that beta as soon as I am sure the SBIG guider issue reported here is working.