The new focusing algorithm doesn't work for me

Hi and thank you for reading this. My Celestron C-14 HD has an Optec Fast Focus secondary mirror. Ever since you’ve implemented the new algorithm (Quadratic?) I can’t get it to solve a focus point meaning that after a few tries it always says that the “fit” failed and it goes back to the initial focuser position. No matter what I do change the binning, steps, smart focus on or off…I’ve tried EVERYTHING to no avail. The old system worked ok. Is there a way to change the algorithm? modify it in some way.

I also use The sky X Pro with CCDAP 5 sometimes and their (SXP) focus system (focus 3) does an amazing job no matter how unfocused you are.
I know you guys won’t integrate, but is there a way to plagiarize their system? (LOL just kidding).

Finally if anybody has a C14 HD and the Optec FastFocus and it works for you can you share the settings with me?

Thank you in advance and Happy New Year

Pablo Lewin
The Maury Lewin Astronomical Observatory.

Ya… that’s a lot of focal length and may require that you override the minimum fit quality. First thing is that you perform a manual auto focus run when you are already in focus. You will have a red fit-line and a black box on the graph that shows calculated HFR, Position and fit quality. Assuming the calculated HFR and focuser position check out, you will want to grab the fit quality plus about 5-10% higher for your minimum value. Then, in the sequencer window, if you expand the “equipment section” (where the rotator flatbox, etc dropdowns are located). Go to the “custom variables” section at the bottom and type this:

quadratic_fit_min_quality=0.65;

Replace 0.65 (65%) with your derived value. Auto focus should start working within your new tolerance now. Note that you can also add the custom variable to your C14 equipment profile so that you don’t always need to remember to add it.

1 Like

Thank you Ken. I will give that a try tonight!

Take care!

Pablo

Pablo, and don’t hesitate to post logs of your AF tests. We can extract the curves from those logs, even failed curves where it fails, and maybe better understand your issue.

Mikael

1 Like

Thank you Mikael. Where do I get the focus logs?

In the Help menu, choose the “Open a Support Request” option and SGPro will bring up the log browser.

1 Like

Hi Ken and everybody interested. Here’s a link to the focus logfiles folder

Thank you!

Pablo Lewin

I meant the “normal” SGP log file, which has a format like: sg_logfile_20191205210806.txt. There should be one single file create each time you start SGP. It is likely a few 100s of kb large.

You can visualize the AF runs stored in that log file using the AF Logviewer, available for download here: https://sourceforge.net/projects/sgp-autofocus-logviewer/

However, that program will only show the succesful AF runs. But I can also output the failed/aborted ones for you if you publish the logfile here.

Mikael

1 Like

Thank you Mikael, I downloaded it but since none of my focusing events end successfully the viewer is showing nothing at all.
Thank you again!

Pablo

Hi Ken

I overrode the fit quality as you instructed me to no avail. It will not successfully complete a focus event…The Sky X Focus3 works great but ever since the new quadratic system was implemented on SGP no SGP focus for me…instead what I do now is to start the sky x, focus and then I start sgp…I also use ccdap 5 but your system is way superior and I’m so used to it…

Too bad…thanks for trying.

Pablo Lewin

I dont know what’s wrong, but I am almost certain it can be fixed with settings. If you can post the normal logs, we will take a look.

1 Like

Thank you Ken I uploaded and zipped all the logfiles for 2020 just in case.

Thanks again

Pablo

Pablo,

Your problem is the Step Size setting. For most of your log files it is either 1 or 3, which is MUCH TOO LOW. Basically SGP don’t move to focuser, which results in a flat AF curve and a failure. See exemple below.

 [01/06/20 17:38:01.110] Auto focus data
 [01/06/20 17:38:01.110]  - Data Points: 6
 [01/06/20 17:38:01.110]  - Step Size: 1
 [01/06/20 17:38:01.110]  - Current Position: 21118

You need to first understand your focuser by manually moving it using the Focus Control panel. Experiment with different Step sizes using either the “Fine” or “Course” setting. Likely it will be in the range of several 10s of steps, maybe more.

There is also some help in the SGP manual, look for the section “Understanding Auto Focus”.

Mikael

20200106173718_AFRun_ALL

Mikael

Thank you. I wish it were that simple. I’ve tried different bigger step sizes before my telescope uses the Optec Fast Focus which moves the secondary mirror. It’s extremely sensitive and requires miniscule step sizes here’s the specifications so that you can get an idea.

  • Mounting: Fits Celestron C-14 and EdgeHD C1400 OTA with Fastar capability
  • Step Size: 7.8-micro-inch (0.197 micron)
  • Total Steps: 44800 steps
  • Total Travel: 0.350-inches (8.9 mm) for secondary mirror
  • Net effective focal travel: approx. 8-inches at focal plane
  • Linear bearings: four 0.25-inch bore 3/4-inch closed circuit linear ball bearings
  • Lead screw: 1/4-20 tpi x 2-inch length

Pablo,

Ok, I see! I don’t have any experience with this optical system. But I did some back of the envelope calculations:

From you SGP logfile it looks like you have entered a focal length of 2737 mm, which means you use a reducer ? Anyway, with the 356 mm aperature that would mean a focal ratio of f/7.7. With the traditional CFZ calculation this gives a CFZ of 144 microns. Now, there are many posts on different forums discussing how two relate the “practical” focus zone to the theoretical CFZ calculation, many appear to say it is a bit smaller.

But if I get your specs correctly, the focuser has an effective focus travel of 8 inches for 44800 steps. This is 203.2 mm for 44800 steps, so 4.5 microns/step ! In the exemple above your total focus curve spans 6 steps, so 27 microns. To me that appears too small with respect to the CFZ.

Anyway, I guess the key is to make sure you can go in and out of focus manually before testing the AF routine. If the AF then fails it might be due to backlash, particularly for so small physical step sizes in terms of microns/step. I would say this is independent of the new quadratic routine, it should fail as the AF curves are completely flat.

Good luck!
Mikael

Thank you Mikael. In the past I have used 30 to 40 steps as high as 50 each to no avail.(it took forewver though) I will keep experimenting here what I’m going to do when it clears up is to focus with TSX focus 3 which always works and then translate the number of steps that program used to the SGP focus…that should do the trick.

take care and thanks again for your time!

Pablo

Pablo,

Im just guessing here, but I have Optec focus motors on my Feathertouch focusers as well. 0.2 microns per step means even 50 steps is only moving 10 microns. I think you have to increase your step size CONSIDERABLY more. Try 300-500 steps. You’ve got to move the focuser enough to in and out of the CFZ to estimate and achieve focus. Go bigger.

David

Pablo - this sentence suggests you are talking about the number of focus points (hence it takes longer to do more). The others are talking about the step SIZE. My focuser has 4 microns per step and I take either 9 or 11 readings, 30 motor steps apart. If you are not seeing some form of U or V shape on the graph, it is never going to focus.

Gentlemen, well it finally cleared up tonight and I was able to experiment with different focus datapoints and steps and I’m happy to report that 10 focus datapoints and 50 steps did the trick.

to complicate matters and specific to my system which is a celestron C-14 edge HD and the secondary Fastfocus focuser is that when I slew even a 1 mm flop of the main mirror translates into donuts when I slew past the meridian BUT with the new settings it went from donuts to sharp stars in 2 tries…

Not bad, at all!

Thanks again gentlemen!

Pablo Lewin