Two nights of failures with 3.1.405 & now 415

12-16 with .405

Sequence started up alright got one light frame - then noted AutoFocus hadn’t run for some reason so I re-enabled auto focus and set to run after the light frame.

  1. It ran but hanged. It never took a light frame.
  2. Could bring up control panel no matter what I tried. Not once after sequence started.
  3. So I aborted the seq so I could try to run auto-focus again. But after abort, the auto-focus control had “Waiting…” on the button that normally says “Run” and I couldn’t manually fire it.
  4. I figured I just restart the sequence and maybe that would auto-run AF, but the “Run Sequence” button was grayed out and I couldn’t restart the sequence - even after executing a reset sequence from Sequence menu.

So I gave up and restarted SGP. It recenterd ok, and then ran AF just fine and am capturing frames again. Now I am also able to bring up CP.

12-18 with .415
First target in sequence completed, SGP moved onto new target NGC1499 . Shortly thereafter I think it tried to do a meridian flip. It failed for some reason and SGP just ended the session and disconnected and parked the scope. I thought it was suppose to retry according to failure recovery settings? (every 15 min for 60mins is my setting).

So I retstarted the seq and it centered fine and then paused PHD2 and then tried to AF, but it just hanged on “Chaging filter to LUM…” and it never took one frame for AF. Cancelling AF worked but SGP could never recover and I couldn’t restart AF or the seq. So I gave up for the night.

So in general, it would seem SGP works ok until failure for me; and after it doesn’t recover and becomes unusable. AF works great when it works.

I dont see any log that shows that scenario… just one with a valid sequence run and one that shows SGPro start and end at ~9:00

Your camera is continually failing to download images. SGPro does not attempt recovery when there is a fatal camera error.

I strongly recommend that you use the ASCOM driver for ZWO. I think these camera issues you are seeing will disappear if you do so.

Why did the ZWO native drivers work so well in 3.0.165 and prev then? I use the native drivers for Offset access.

I had a stable setup with 3.0.165; I had the occasional crash/hang but it was rare. The only thing that changed was me upgrading to 3.1.

So you’re saying I’ve been lucky with 3.0 and using native ZWO drivers?

Oddly last night I had the odd black/blank image with my ZWO ASI1600-Pro (using the ZWO drivers). I felt like the cause wasn’t SGP related and more to do with connections and perhaps power related issues (so hard to say what), although I haven’t had this problem for a while. It’s nice to know it’s not specifically SGP related however and will go back to the ASCOM driver. Will the offset specified in ‘event settings’ override any other camera settings (as shown in the connection tab for instance)?

Got another hang; apparently trying to AF. Aborted sequence to try to keep going and then Resume and SGP will not run as it says “cannot resume due to AF running…”

Got to restart SGP again - getting tired of this!

Ascom doesn’t support the Offset setting.

1 Like

The ASI Camera driver does seem to support offset if you click on the advanced tab under manual preset. image

image Or is that the Zoo driver? There is another driver named ZWO Camera which sets default gain and offset?

Like I said, ASCOM doesn’t support the setting of Offset via ASCOM. The noted UI is the driver level support for ZWO does and sets the offset universally for that cam.

Using the non-ASCOM driver for ZWO you can set Offset per target. Using ASCOM you can set Offset per cam.

I’m sorry, but we will not be providing support for native ZWO drivers. You should be ok not using dynamic offset. If you still view this as problematic, I suggest you petition the ASCOM team. As of now, the current sentiment is that exposing offset to applications like SGPro is not necessary and that the camera manufacturer should be responsible for changing this value to accommodate every exposure. That said, there are plenty of beautiful pictures being made with the ZWO ASCOM driver.

My apologies nightfly I see what you mean now.

I’ll just move back to 3.0.165 where everything worked fine. Since I am loosing functionality/stability using 3.1 that seems like the only viable option until the Mosaic breaks for good in that version.