Two Rotators for Dual Imaging Platform

I have been running some tests trying to get a dual imaging platform running. I have gathered a lot of information on the forums about this so I know it works. I can get two instances of SGP running. I can configure both scopes and cameras to work (when I disconnect all of the equipment from the second instance of SGP). I know I have both configurations properly set (cameras, SkyX, manual focus, manual rotator, autoguider etc… all work). I simply want the second scope to connect to the camera and the manual rotator. My tests seem to show that in order for the manual rotator to work i have to be connected to The Sky X. Are there any “tricks” to connect two instances of SGP to TSX. I am assuming it needs the pointing parameters from TSX in order to plate solve and determine the correct FOV angle. Does anybody know if you can use the manual rotate feature on a second instance? Any help you can provide would be greatly appreciated.

OH!!! I did get the two camera angles set properly by plate solving one, then disconnecting then connecting to the other. I am hoping for an easier way. LMK what you got.

Thank you.

I am not a Sky X expert, but I am unsure of why this would be true. The rotator device does not have a dependency on the telescope.

I was hoping that was the case but it seems to run through a plate solve before it rotates and with TSX off
it seems to hang. My notes indicate the on 3/22 at approximately 01:19:00 I successfully completed a plate solve with everything on. I did nothing to SGP except turned ASCOM to TSX Off. The program hangs and I had to abort. Just some background, I have two FSQ106ED’s, one has a QHY367C and the other has a Nikon D810A. The QHY367C is the master while the D810A is the slave. Everything works great with the Master. If I turn everything off and do the same for the slave I can get everything to work. When I turn everything off except the camera and focuser it attempts to do a plate solve and fails. I am almost positive in “Target Setting” I turned off “dew not slew”. Here is the link to the log . I will try to repeat the problem next clear night. Thank you for your help.


Ken, I was able to conduct some test last night and resolved the problem. The main telescope is all set up and running smoothly (no problems there). The “SLAVE” telescope needs to be connected to the camera, rotator and TSX. The mount part is where I was making my mistake. I guess I was thinking only one of the two instances of SGP could be connected to TSX. I connected both instances to TSX and on the “SLAVE”, Target Settings I turned “SLEW TO” off but left “ROTATE” on. Everything is working great. Thank you.