Unable to abort sequence while waiting for conditions to be safe

In beta 289, and I think a few before, I’ve noticed that, in the following routine, I’m unable to abort the sequence:

  1. Setup sequence with a safety monitor active (and unsafe - eg before it’s fully dark), and with a sequence start time after darkness. I’d expect it to wait here until both of the safe conditions and the start time arrive.
  2. Click “Run sequence” - all the kit connects, and the safety monitor is unsafe.
  3. This prompts the mount to park, roof to close, etc.
  4. If I now hit “Pause Sequence” (I want to abort to change something) then it gives me the do you want to abort message - choosing yes momentarily appears to abort the sequence, but then it goes back to waiting for safe conditions (all the equipment connect buttons go back to being connected but inactivated, and the “pause sequence” button is reactivated).

The only way of getting out of the sequence here is to quit SGP and start over.

Separately, at point 3 - the cooler gets switched off and SGP goes into a loop of waiting for warm up - why should the cooler get turned off here? If the conditions become safe, surely you want the camera to be cool and ready?


It will indeed do this, but the definition of “wait” should be clarified. The sequence will start when it is SAFE and then after the start time has passed. While it is waiting though, UNSAFE dictates that your rig should wait in a shutdown state (mount, dome parked, etc). The only exception here is that the gear will not disconnect and camera warmup will not start.

Correct, see above

This is a bug and has been corrected. User abort should never restart “wait until safe”.

This should not happen. Testing here, I see the mount park, but the camera stays at temp. Maybe it was broken in 291? Not sure, but with the fix in place, I do not see this happen