Unable to platesolve with ANSVR or PlateSolve2


#1

I’d love to get away from Elbrus and astometry.net, but no luck so far. I followed Andy’s instructions on ANSVR, and installed catalogs 4202 to 4207. My FOV is 22x28 arcmin. I tried to solve several of my images following Andy’s steps. It reported it was uploading to ansvr.net, but then simply came back and said “failed to platesolve image.” Any ideas? Elapsed time was 0s, if that helps. As I mentioned the other day, PlateSolve2 runs perfectly from its own .exe, but when I try to switch it on in SGP I get “Component comdlg32.ocx or one of its dependencies not correctly registered: a file is missing or invalid.”

My test images all solve in Elbrus and on astrometry.net, but Elbrus doesn’t always work in an actual imaging session, and a few times lately a.net has been down. If anyone has any ideas, please let me know!

Kevin


#2

Hi Kevin,

That’s too bad. I have not had issues with both plate solvers. My focal length or image scale is smaller than your so that may have helped me.

Make sure the image scales of the image matches to image scale you fed in SGP. Maybe both image scales may have to match.

Peter


#3

Hi Kevin,

If you post a link to an image that does not solve, I will try it on my machine. That will give us a clue about whether it is a settings issue or something else.

Andy


#4

Kevin,
Also, it might help if you could post a link to your ansvr log.
Andy


#5

Thanks guys. An image is here:

https://dl.dropboxusercontent.com/u/58468743/2015_10_10_222351_120sec_R_frame9.fit

The log is here (a jpg of the Watch ANSVR window - is the log saved somewhere as a file?)

https://dl.dropboxusercontent.com/u/58468743/ANSVRLog.jpg

Kevin


#6

Does your URI to ANSVR read “127.0.0.1:8080/ap” instead of “127.0.0.1:8080/api”


#7

Dang, I can’t even cut and paste without messing up! Solved in 55 seconds. Thanks Ken! Any hope for PS2?

Kevin


#8

Oddly, you seem to be the only one having / reporting this issue so I cannot be sure. I can’t see how it would help since you can get PlateSolve2 to run by itself (which has the same dependency), but you can try this:

  • Open a command prompt as Admin
  • cd “c:\Program Files (x86)\SequenceGenerator” (or wherever you installed SGPro to)
  • run this: regsvr32 comdlg32.ocx

#9

Scratch that… do this instead:

  • Open SGPro, go to the Help menu -> Open Log Folder.
  • Find PlateSolve2.exe and double click it. What happens?
  • Look in this same folder for comdlg32.ocx. Is it there?
  • If it’s not, copy it in there and double click PlateSolve2 again

#10

Thanks Ken. I’ll check that out in the morning. Right now it’s imaging, and I don’t want to risk messing anything up. Finishing (hopefully) OIII on Melotte 15 tonight.

Kevin


#11

Actually, just install the latest beta (released tonight). It does this for you…


#12

Done. Same problem though. When I click on settings I get the same error message. Great session last night, though. 4 of 5 targets with no user intervention (because the user was asleep most of that time), and only lost the 5th because of clouds.

Kevin


#13

Can you validate that, when you go to Help->Open Log Folder (not the install folder like I asked that you check in a post above), you see files named “PlateSolve2.exe” and “comdlg32.ocx”.

You were using 2.4.3.10 right?


#14

Yes, I just checked and they’re both there. For the last couple sessions I’ve been using 2.4.3.9. I’ll move to 2.4.3.10 for the next session.


#15

Well that’s a huge bummer. For now, I am officially out of ideas (and we can’t find anyone else with the issue to help establish any type of patterns).


#16

Not to worry. With Elbrus now getting backed up by a local ANSVR, I’m fine. My much bigger problem is that I still get ASCOM disconnects from my mount. Chris can’t figure that one out either, so you’re in good company. :slight_smile: I’ll probably move to a new laptop soon, so maybe all these problems will go away.


#17

Hi Ken,

I’m also having a problem with comdlg32.ocx on a new (old) machine I’m setting up. PS2 runs fine from Platesolve2.exe however I get an error when I click on the setting button in SGP.


#18

Ya… that’s a bummer. Never was able to figure this one out (very few people have reported it).


#19

Could it be related to an XP install? 64 bit versus 32 bit? They mention older computers?


#20

Not for me, Chris. My machine is 64-bit Win 8.1. I’ll be moving to a new laptop soon, so hopefully the problem won’t follow me.


www.mainsequencesoftware.com