Unable to setup PlateSolve2 in SGP


#1

I’m trying to get PlateSolve2 going. I installed the two catalogs from Planewave, When I go into SGP>Platesolve>Settings, I get an error box that says “Component comdlg32.ocx or one of its dependencies not correctly registered: a file is missing or invalid.” Any ideas? My system is Win 8 64 bit, and this appears to be a 32 bit file. Googling has shown some discussion of this issue up until three years ago, then nothing. The solutions posted back then seem not to be available any longer.

Kevin


Unable to platesolve with ANSVR or PlateSolve2
#2

That’s a new one. Not really sure. We do distribute that file because PS2 depends on it. If it’s not in your install directory, maybe reinstall it. You can also try to double click the PlateSolve2.exe file directly (in the SGPro install folder) and see what happens.


#3

Running PS2 from its own exe does not trigger the error. I did also move from SGP 2.4.2.9 to 2.4.3.8 at the same time, so maybe I changed too many things at once. I had to move back to 2.4.2.9 for tonight anyway (I’ll make a separate thread on that), so I’ll try to run PS2 again in a few minutes.


#4

Nope, same error message with 2.4.2.9.

Ken, where should I look for that file? It does not show up with a search of the C drive.

Edit: In fact it IS in the SGP install directory, despite the fact that WinExplorer search failed to find it. So I think the problem is that it’s not registered correctly. Does anybody know how to do that?


#5

Keep in mind that double clicking the exe file and SGPro both use the same ocx file. Not sure it’s a registration problem.


#6

Are you running SGPro as an admin or anything like that?


#7

I haven’t been running SGP as an admin.

Edit: PS2 is running fine from the .exe. I had to point it to the UCAC and APM folders, but when I did it works. It had no trouble platesolving a couple images. But I’m still getting the same error in SGP. It is kind of surprising that it runs fine from the .exe but not within SGP. But then we’ve long known that no matter how well anything works for other folks, I can break it. :slight_smile:

Kevin


#8

From the window’s prompt screen type:

regsvr32 /u comdlg32.ocx.

then press the Enter key; then press Ok on the message icon that you get.
Get back to the prompt screen and type:

regsvr32 /i comdlg32.ocx.

then press the enter key; Press Ok on the message icon you get (it tells you about a DLL error… do not care about it, press OK…).

start SGP again and go to to the SGP control Panel --> Plate Solve
Choose Plate solve 2 from the menu and click on the “setting” button of plate solve 2.
Plate solve 2 will now open and you can go on associating the plate solve APM and UCAC3 catalog directories.

SOLVED! at last.
F.


www.mainsequencesoftware.com