Unable to start new beta 2.5.2.3


#1

I’m quite perplexed :confounded:

I installed the new beta this afternoon and clear skies forecast tonight. Installation all seemed fine. I opened the new beta once - all ok. Sent pc to sleep.

This evening I awoke the PC using TeamViewer from my home to my garden obs pc as normal. The screen showed the beta opening as normal. TeamViewer then lost connection (never had that before). I walked across the garden to the obs, and there was no sign of SGP open on the screen. I shut everything down and re-booted the pc.

When restarted, SGP would not open. I have an ethernet controlled power switch for my ccd, usb hubs, and dew strap and this is programmed to switch on when SGP opens and is very reliable. When I tried to open SGP, the power switch would click the relays on and then a second later click the relays off, ie SGP was opening and then immediately closing. There is no log created.

I reverted to 2.5.2.1 and then re-installed 2.5.2.3, I re-installed which triggered the ‘repair’ process in W10’s settings; I repaired and tried opening 2.5.2.3 but no luck. The power relays clicked on and then off as SGP opened and the immediately closed again. I rebooted my PC once again - reverted to an earlier beta and then reinstalled 2.5.2.3 but I could not open the new beta. I then reverted to 2.3.5.1 which was able to open successfully.

I seem to recall that this sort of windows behaviour has happened before and reported in the forum . . . I’ll have a search around.

Anyone recall the fix?

Thanks.

Barry


#2

Update: I found the advice given in previous thread to open the Command Line and navigate to the directory Sequence Generator and type in “Sequence Generator”/recover. This I did and it did not make a difference, SGP 2.5.2.3 was unable to open, starting and them immediately closing without even showing the start-up screen. I have reverted to 2.5.2.1 again.

I had a W10 update on 1st October (but used 2.5.3.2 on the 3rd October) if that makes a differenence.

Barry


#3

Could be my Avast anti-virus software although no ‘threat’ pop up happens when I open the latest beta. I’ll try adding SGP to the exclusion list within Avast and see of that makes a difference, doesn’t explain why 2.5.2.1 works though. I’ll do this tomorrow when I’ve finished imaging tonight.

I can always try completely uninstalling SGP after backing up my profiles if all else fails . . . Ken/Jared I may post for help if I have to carry this out and it screws up my registration.

Barry


#4

Barry just trying 2.5.2.3 myself. I am using W10 64 bit but don’t bother with virus stuff, since it is not connected to the web. I am controlling with MRD and it is working - and it did the PMX sync with offset :slight_smile:


#5

Thanks Buzz, at least I know there is nothing untoward with W10 and the latest beta. Has your W10 updated recently?

I’ll deactivate Avast too when I experiment tomorrow.

Good luck with your BabyQ – no clear skies for you for a while yet :grin:

Cheers,

Barry


#6

@BarryWilson

Can you check in the log folder to see if SGPro is creating a log?

C:\Users\<user name>\AppData\Local\SequenceGenerator

Also, can you check if you have this directory?

C:\Users\<user name>\AppData\Local\Main_Sequence_Software\

If you do, find a directory like this:

\Sequence_Generator.vshost_Url_coslir50mqfqfesfq1k5qqvx3hi3kkxm\

Then find the correct version:

\2.5.2.3\

Then delete this file and retry (this is what “/recover” is supposed to do for you)

user.config


SGP 2.6.0.23 suddenly won't start
#7

I just installed 2.5.2.3 on my obs pc running W10 64bit and it runs without issue. I also have SuperAntiSpyware running.


#8

Thanks Ken this has worked. New beta 2.5.2.3 now able to start correctly.

The repeated attempts to install has sure screwed up things - up at 4.00am to check how my sequence went and my mount failed to flip, and sequence was aborted at about 11:30pm shortly after I went to bed :tired_face:


#9

This the link to the log from last night when my 10U mount failed to flip.

https://dl.dropboxusercontent.com/u/32050952/sg_logfile_20161009200542.txt

Not sure whether the failure to open the new beta caused a problem with auto-meridian flipping or if this is something new. See about 11:20pm:

[09/10/2016 23:16:23] [DEBUG] [Sequence Thread] Meridian Flip needed, Hour Angle >= Degrees Past To Flip: -1.24379166666664 >= -1.25
[09/10/2016 23:16:23] [DEBUG] [Sequence Thread] Running blocking meridian flip…
[09/10/2016 23:16:23] [DEBUG] [Pier Flip Thread] Meridian Flip: Starting Meridian Flip Procedure
[09/10/2016 23:16:23] [DEBUG] [Pier Flip Thread] Meridian Flip: Skipping Solve and Sync
[09/10/2016 23:16:23] [DEBUG] [Pier Flip Thread] Meridian Flip: Stopping the Auto Guider
[09/10/2016 23:16:23] [DEBUG] [Pier Flip Thread] Meridian Flip: Sending Telescope command to execute meridian flip
[09/10/2016 23:16:23] [DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[09/10/2016 23:16:23] [DEBUG] [Telescope Thread] ASCOM Telescope: attempting pier flip using sideOfPier
[09/10/2016 23:16:24] [DEBUG] [Telescope Thread] Setting Pier East
[09/10/2016 23:16:33] [DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[09/10/2016 23:16:33] [DEBUG] [Telescope Thread] ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!
[09/10/2016 23:16:34] [DEBUG] [Pier Flip Thread] Meridian Flip: Telescope command to meridian flip has completed
[09/10/2016 23:16:34] [DEBUG] [Pier Flip Thread] Meridian Flip: Telescope failed to perform meridian flip
[09/10/2016 23:16:53] [DEBUG] [Pier Flip Thread] Meridian Flip: Procedure complete
[09/10/2016 23:17:54] [DEBUG] [Sequence Thread] Blocking Pier Flip: Failed to meridian flip, aborting sequence (True)
[09/10/2016 23:17:54] [DEBUG] [Sequence Thread] Adding sequence level notification: Failed to meridian flip, aborting sequence.

For 10U mounts you need to flip before the meridian (previous threads on this) and I have not changed my settings. Hence at a meridian flip, won’t the telescope always be moving from west side to west side, ie same side to same side?

Was this a result of the corruption of the ‘user.config’ file as a result of the faulty upgrade? Or something else? Or no way of knowing?

Thanks,

Barry


#10

This has nothing to do with the failed update. We asked the mount to pier flip, but, as you can see from the logs, the mount reported it was done flipping in 1 second.


#11

Thanks Ken.

I tested auto-meridian flipping when I got home from work with the current betas 2.5.2.3 and 2.14.6 (10U).

I simply connected the mount in my sequence, connected my mount to Cartes du Ciel and slewed to a point just east of the meridian and east of my flip limit. I nudged the mount west to within my limit (-5mins of meridian) and clicked Run on the telescope tab. The auto-meridian flip worked and countdown to meridian was reporting correctly.

Despite the forecast I am waiitng for the clouds to clear to test when running a sequence. I have the 10U log running as well as collecting logs from Per’s ascom driver.

If I have a problem flipping I will downgrade the 10U beta firmware to 2.14.4.

Barry


#12

An update:- the auto-meridian flip all worked fine in my sequence. the mount waited to track to my limit and then flipped fine.

So not sure what happened last night after the strange ‘user.config’ event with the new beta, but all seems well now. Only thing to check is the End of Sequence park, roof close and ccd warm-up which I’ll see in the morning (or if I wake in the night - funny how this can happen when you’re anxious :wink:).


#13

Final update and for completion of this thread, at the end of my sequence all End of Sequence options worked as expected - hurray!


#14

Thanks for the report @BarryWilson. I need to find out why the “recover” switch is not working. Did you find the settings file pretty much where I described?


#15

Yes, the location of the ‘user.config’ file was exactly where you described in the directory, within a sub-folder named for each beta. This was very easy to delete by navigating through File Explorer.

If using the Command Line and typing in the directory path between each ‘cd’, should I have typed the sub-folder for the 2.5.2.3 beta before the final ‘/recover’?


#16

I have placed a bit of trace code at the top of the logs to see if the method we are using to find (and delete) your corrupted config file is valid. It looks like this:

"Your settings file is located at "

This will be in the 2.5.2.5 beta.

@BarryWilson When it is released, I’m hoping you might be kind enough to let us know what it reads.

Thanks.


#17

Will do.

Barry


#18

Hi Ken

I managed to get out last Friday, sorry it has taken so long but a combination of autumnal weather and I stupidly slipped in my garden (sober I have to emphasise :innocent:) and fractured my wrist a week ago. Ouch!

I have attached a link to the log - doesn’t look like the path is shown unless I’m looking in the wrong place (just thought on, that I had forgot to use the 2.5.2.5 beta, the log below is 2.5.2.4; I have updated the beta now and will check next time out). Sorry, not been a good week.

https://dl.dropboxusercontent.com/u/32050952/sg_logfile_20161021195827.txt

A further lesson to all regarding W10’s update disruption is that a day before I eventually manged to image on Friday, I opened TV on my home iMac, woke up the obs pc, powered up the kit and started SGP. A few seconds later, TV lost connection (as before) and I went out to the obs to see what the issue was. The pc was re-booting itself after installing an update, of course the re-boot began part-way through the SGP start-up screen. Thus when the re-boot was complete I couldn’t again start SGP and had to manually delete the ‘user.config’ file to enable SGP to sart-up fully.

I have now amended settings to a ‘metred’ connection and hope this prevents auto updating and rebooting.

Barry


#19

Barry hope your wrist heals fast! Go to the services in the control panel and stop and disable the Windows Update service. That’s the only way to really protect from unwanted updates.


#20

Ken

Just completed a few subs between clouds and I can confirm that the first line of the log correctly records the location of the ‘user.config’ file in beta 2.5.2.5.

@entilza - thank you for the tip, I have switched off the Windows auto update service having followed a handy short You Tube video.

CS!

Barry


www.mainsequencesoftware.com