Unexplained and unexpected but repeatable - Jared and Ken, this one is complex

Logs for SGP and PHD to be found here https://www.dropbox.com/s/ubz1hvdp89lbvro/Logs.zip?dl=0

Hi Everyone,

For the past couple of nights I’ve been fighting with a very bizzare issue that I can’t seem to solve and as nobody has been able to help me on Cloudy Nights, I am posting it here as an SGP issue.

I’ve had several clear nights this week. The first night of imaging, everything was working fine until the middle of the night when PHD guiding went nuts for no seemingly obvious reason. Although I was able to restart the guiding relatively quickly, SGP wouldn’t move the mount to centre after plate solving and I lost the rest of the night. Someone on Cloudy Nights suggested the guider had switched to a hot pixel, reasonable assumption. However, the issue has repeated at almost the same time of night for a further two imaging sessions. My logs contain details on SGP and PHD for the last two nights. Everything works fine early evening and there are no issues with PHD or plate solving. In an attempt to trouble shoot last night, I got up and tried a number of things. Firstly, the mount is polar aligned, clutches are tight, balance is good. I’m using an Avalon Linear mount and have never had an issue with it. I discovered that plate solving was solving the image but wasn’t centring accurately by a few hundred pixels. This is what I believe is causing the sequence to abort or get stuck on a plate solving loop. I installed Astap to see if it was the plate solve program but no difference seen. I then slewed to M81 and tried to plate solve - same issue presented. I tried Vega - same issue presented. I tried Arcturus in the south and it solved and centred to within a couple of pixels. I’m completely perplexed by the issue. Worth noting that I installed windows 10 on my Eagle as SGP had stopped supporting Enterprise and I was unable to update - could there be some code somewhere that needs resetting (sorry, I’m not very technically minded). Please would you be able to look into this issue as it’s clear again tonight and I’m expecting the same issue. The Cloudy Night thread where I originally posted is here https://www.cloudynights.com/topic/699297-unexplained-and-unexpected-but-repeatable/
Hope everyone is ok over there - lock down here in the UK is strange but is giving us imagers more time to do what we love!

As you are not using EQMod and I don’t know how the Avalon works, but does it have a system where it stores alignment points as parts of the sky are synced and then force the mount to go where it thinks it should ??

In the EQMod world, to ensure correct Plate Solving, Guiding etc, Alignment\Sync must be disabled to ensure correct operation…

It does have a 24 point modelling system in the stargo software but I’ve never used it. Don’t think this is a mount issue as it’s never once given me issues…not impossible I suppose.

OK - it does not look like a hot pixel - or PHD2 would be reporting a flat-line. Once you are imaging, I do not think SGP sends any guide or slew commands (apart for dither). The odds are this is between PHD2 and your mount. This can be confirmed from the logs. The screen grab is from the 23rd but the logs are several days later. It would be helpful to have the log files from PHD2, ASCOM and SGP during the image acquisition.
I had an Avalon linear with Synscan but I avoided EQMOD and used Chris Rowland’s skywatcher ASCOM driver. I’m wondering if we are staring at PE and that the guider is not making any difference - but I don’t know the imaging scale here.
I think you have to pare back. Do unguided 10 minute exposures to begin with, physically removing any guider cables. Then try guiding without involving SGP at all. At some point the problem will return…

I looked at the PHD2 logs using PHD2 Logviewer. AS you noted, what is intriguing is that the wild excursions started at about 0230 on both sessions and the shape of the excursion is almost identical.

Your runs were over the course of MANY worm cycles, so I doubt that is the issue.

The fact that they occurred at the same time suggests an external trigger. Do you image remotely or can you observe what is happening outside your setup? (Maybe Phil’s spider migrated…)

You might post your logs on the PHD2 forum. Both Guide and Debug should be included. If you did this already, then I apologize for missing them.

https://groups.google.com/forum/#!forum/open-phd-guiding

Bryan

Think I might have a software corruption problem. I have an eagle pro 2 but it has the old Microsoft enterprise lstb 2015. Windows gave no conversion path to windows 10 for this so I spent hours understanding how to make the registry edits to force the conversion and bought a license. All seemed to go well. Tonight, I was setting up ready to finish my 30 hr elephant nebula project and boom…SGP won’t even boot up and the Avalon won’t connect either. I got the following screenshot from a diagnostic


I have an awful feeling this is going to end in a windows reinstall and possibly another trip back to Italy for my Eagle. No imaging for me for the foreseeable.

Email PrimaLuce, they have directions for an upgrade path for you.

Jared

I have this mount and experienced a similar issue where the mount did not respond as expected.
Do you have the hand controller plugged in? If not, you need to go into Avalon Star Go and on the RA DEC tab set the Disable Keypad check box. This solved my problem which drove me batty for a couple of nights. Hope this helps.

Alternatively, Avalon says if you have an SBIG camera connected and you are not guiding you should set the ST4 Enabled check box on the same tab.

I did, their recommendation was what I followed.

So, going out on a long limb here - cause I had a similar issue after I moved from a laptop to a NUC. I kept hitting the same time each night (~4 min difference) where I would lose a GuideStar and PHD2 would start acting crazy and terminate the sequence.

Turns out it was my meridian limits in EQMOD- they somehow hadn’t copied over when I transferred the settings files from the old computer. EQMOD would stop the mount, PHD2 would keep trying to make adjustments to follow GuideStar and I would get those similar trails like you’ve shown. I pulled my hair out, changed every cable and the USB hub before I sat out one night and watched it happen real-time.

But the confusing thing was everything pointed to a GuideStar lost event.

Only reason I mention it is your event happens same time, same target each night, right around the time of a meridian flip - your telescope is reporting EAST before the incident, and WEST after the incident.
See photos :

1 Like

that would do it - the trace goes off the wall and the mount does not respond to the guider

Except I’m not using EQMOD, only ASCOM. I had an older Enterprise 2015 back up so I went back to that, reinstalled windows 10 pro and this time took a new back up. Everything is connecting fine now and SGP is booting up so that seems to have sorted the driver issues. I now need a clear night to run the system and see if it’s fixed the plate solve issue. Not going to happen so with no clear nights on the horizon and a bright moon coming. Will post back when I know.