Unofficial release of SGPro beta 2.5.0.6


#1

Nothing exciting here… just a build to try and help narrow the cause of two potential SGPro hang conditions (well it may be exciting if you like helping find problems). Unfortunately, I cannot distribute a formal releaser until this weekend, but if you want to give me data for long plane trip tomorrow, you can download this file and replace your existing “sequence generator.exe” file in your install directory.

Interesting logs include sessions where:

  • The sequence appears to hang on FITS file download / save to disk
  • The sequence appears to hang and UI becomes unresponsive at the end of a sequence (mount will possibly park and then you’re done)

#2

Ken,
Looks like im the first one to add to the hopeful demise of this annoying problem (Freeze at the end of a sequence using 2.5.0.6) but what will be contained in this post is a 2 fold issue if you don’t mind, it will save the confusion of 2 separate threads when they could be related. It’s taken me 2 days of endless trying to get a freeze at the end so I hope all the effort is worth while.

:wink:

In short:
Ran a simple sequence with PHD2 (simulated guiding), slew to object, take some frames with Cam Simulator and my NEQ6-Pro hooked up in the living room - END - As simple as that !

At the end of the sequence the scope parked successfully and SGP completed the sequence as expected with no problems.

Then, I decided to Reset the sequence and run it again (for some strange reason) and 2 things happened on the second run as follows:

  1. I experienced the end of sequence freeze at the end of the second sequence run (primarily relevant to this thread)

  2. The second sequence run did not run and Recovery Mode was fired up which aborted the sequence due to Guiding not being able to resume.

I’ll explain both 1 and 2 together as they are related:

At the end of the first successful sequence run, scope parked and PHD2 guiding was stopped and all PHD2 equipment disconnected as expected as I have checkbox ‘Disconnect equipment on sequence complete’ in the Profile for the PHD2 settings. I then did the ‘Sequence->Reset Sequence Progress’ command and decided to run the same sequence again. Bare in mind at this point, PHD2 is still up & running but all the equipment is disconnected. I hit run sequence, SGP unparked the scope, slewed to the target and put up message that guiding was resuming (forcing re-calibration). This did not work and recovery mode kicked in and went all the way to the end of it’s time without being able to restart guiding (because the equipment is still not connected). Once recovery ended it aborted the sequence as expected, parked the mount and the interface completely froze with ‘Parking Mount’ in the status bar. It required a forced shutdown of SGP.

NOTE: if recovery fires up as a result of the above and you manually connect PHD2’s gear then the next recovery attempt WILL be successful !

Point 1 -
When I reset the sequence and ran it again, why does SGP not check and request equipment connection in PHD2 as all the kit was disconnected at the end of the first run, SGP did not recognise this after the sequence reset. SGP gets PHD2 to connect it’s selected profile equipment on a fresh sequence run, SGP should query the connection status and connect if this should prove False and attempt to re-calibrate or resume guiding from there.

Point 2 - The abort freeze itself
One thing important to know ref the abort freeze is the final line in the log which it froze on which is as follows:

[29/01/2016 16:30:41] [DEBUG] [PHD2 Listener Thread] PHD2 GetPhdStatus - Post-Wait: Stopped

All entries after this in the log are as a result of a forced ‘Task Manager’ end task where SGP put up a message informing me Kit was still connected, SGP closes normally choosing YES to this info box after informing me that the sequence had changed and do I wish to save. hopefully the following Log will be worth its weight in GOLD.

Here’s the Log File which includes both sequence runs:

sg_logfile_20160129152723.txt (525.6 KB)

Caught exception in CanPierFlipNow : Object reference not set to an instance of an object. at fi.g0()

The above entry looks rather interesting :wink:

Probably no use at all but ill add the PHD2 Guiding Log and Debug Log in case it’s helpful:

PHD2_GuideLog_2016-01-29_163003.txt (26.3 KB)

PHD2_DebugLog_2016-01-29_163003.txt (848.3 KB)

Ken, I truly hope this info makes your rather long plane flight shorter and lucrative ! ! !

Good Luck
Paul


#3

Thx for this write up. One step at a time. With this log… maybe not gold, but becoming more valuable, I am able to show the problem existing in about 40 lines of code. Upon inspection of that code there is still nothing that looks suspect, but the pieces are starting to fall into place. One good thing we now know is that the mount park issue is a wild goose chase. It was just the last thing reported, but had nothing to do with the problem. I am in the process of instrumenting those lines far more closely so I can see what is going on when somebody is able to reproduce it.


#4

:cold_sweat:

The suspense is killing me but its intriguing !

LMAO


#5

SGPro 2.5.0.7 beta is released.

The issue where PHD2 gear would not reconnect should be fixed here too.

I am still unable to produce any hang situation so I am still reliant on folks running SGPro to this failure and sharing the logs. Thx for all the help.


#6

Confirm PHD2 gear now re-connects in 2.5.0.7 once a sequence has completed and you try to re-run the same sequence again…Great !

Still not re-connecting in recovery mode though. While a sequence is running and guiding, I manually stopped guiding and hit ‘Disconnect All’ in PHD. Recovery mode fired up but cant restart guiding as the gear in PHD is disconnected and still stays disconnected.

Will get to work trying to reproduce the freeze

Thanks Ken

Paul


#7

Recovery is not designed to do this. It only covers so many conditions (this is not one of them)


#8

Not going to hassle you on this, I’d rather you spend time getting AF working with central obstructions better.

LOLOL

Paul


#9

@pscammp, I’m responding to your earlier reasoning (that has since been removed). I don’t disagree with you. I was just, unsuccessfully, trying to make 2 points.

  • It is not a case that is covered (not implying that it should not be). This would be something that has be written.
  • It is not covered, and therefore is not a bug. So if, you’d like this level of of coverage, we should make sure it ends up in feature requests before it is lost in the shuffle.

Any luck creating end of sequence hangs with 2.5.0.7?


#10

Sorry Ken,
I removed my original statement too late as is obvious, on reflection after the fact, I felt it could be somewhat offending to yourself and certainly not very productive at this point, my apologies, hopefully you were not. Had I realised the feature doesn’t exist in the first place then of course it would be more appropriate to submit it as a feature request instead of screaming Bug. As I’m relatively new to SGP I obviously am not 100% sure exactly what Recovery mode performs and what it doesn’t. In light of your thread ref the coming 2.5.0.8 release and the lengthy statement you make ref the Recovery feature I will leave it at that if you don’t mind, the situation is directly controllable by me so that is fine.

Ref freezes and the primary purpose for this thread, I have been very short on time in the last few days due to a rather full weekend, my apologies for this, I’ve had a shot amount of time but have not been able to produce a usable situation yet ( its hiding from us Ken ). In the morning I should have several hours where I will be able to give it a dedicated bash, my previous file which I loaded up on another thread (which you could not duplicate if you recall) did not freeze with 2.5.0.7, a bit ironic I think and rather annoying ! If someone else doesn’t get there first then this illusive creature will rear it’s head to say hello once again and we have a nice big net to catch it with…Stand By.

I will do my best over the coming days to give you a usable result I hope.

Best Regards
Paul


#11

Ya… good old digital communication. Missing two of the three primary components of face to face conversation leaves you wondering what somebody is really saying sometimes. I certainly have been offending by some posts, but I don’t recall ever being offended by one that contained a bug report, oversight or feature request.

My problem is that the brevity of my responses is often mistaken for annoyance or being short. I know it, but I do it anyhow… I try to make sure everyone gets an answer despite being in the middle of something else. A lot of this perception is my own fault.

Anyhow… I appreciate any help you can give… I hate to pester and if I could find a way to duplicate any of this stuff on my own, I promise I wouldn’t…


www.mainsequencesoftware.com