Using SGP but PHD2 not recieving 'Side of pier'!


#1

Hello again all,
I have a question which I really cant figure out an answer to which I hope all you super experienced guy’s & Gal’s might be able to help me out with ?

I use SGP 2.5.0.2, ASCOM 6.2, PHD2 2.6.0, latest EQMOD EQASCOM and a NEQ6 Pro mount using ST4 option for guiding
(haven’t tried pulse guiding yet, too scared LOLOL) up to now I use ‘On-Camera’ for the mount in PHD2’s profiles but ‘On-Camera’ does not report Side of Pier to PHD2.

I tried using the EQMOD ASCOM EQ5/EQ6 option for the auxiliary mount in PHD2 so it would report the side of pier to PHD, but when firing up SGP, connecting to the mount and running a sequence, a second EQASCOM fires up saying it doesn’t support pulse guiding ???

I want to, for the moment, stick with ST4 guiding option, run SGP and connect to my NEQ6-Pro in the normal way, have PHD2 fire up in ‘On-Camera’ mode but have the ability to have PHD2 know the side of pier. I know it says in the Auxiliary mount option that anything ASCOM will do but for me it didn’t.

There are quite a few options in PHD2’s auxiliary mount options which have ASCOM against their name so which option should I choose so PHD2 will be able to read the Side of Pier directly from ASCOM but not try to open up a second EQASCOM and state a pulse guiding error ???

Many Thanks for any help

Regards
Paul


#2

You might want to see this:

Peter


#3

Paul, you are on the right track selecting EQMOD ASCOM as the Aux mount in PHD2.

I do not understand the part about the error message about not support pulse guiding. PHD2 does issue an error like that if your Mount selection is an ASCOM mount that does not support pulse guiding. Since you are using “On-camera” as the mount, I do not think that message is coming from PHD2. We could confirm this by looking at your PHD2 debug log.

AFAIK the issue with multiple EQMOD instances popping up is due to one of your imaging programs being run as Administrator. That causes ASCOM to launch a separate driver instance. As long as nothing is run as Administrator you should get a singe shared instance of EQMOD ASCOM.

Andy


#4

topboxman,

Thanks for the link, already seen that thread.

Andy,

When I connect to the Mount in SGP obviously EQASCOM fires up, when I run the sequence in SG and it fires up PHD2 and connects, a second EQASCOM opens up. In the second instance of EQASCOM at the top in the box marked ‘Mount Position’ where usually you see the mount coordinates and if the mount is ‘PARKED’ or not, this is empty and the Error message about not supporting pulse guiding is in there.

I have checked the .EXE’s for SGP, PHD2, Plate solve 2 and none have 'Run as Administrator checked.

What files can I check to see if any part of ASCOM or EQASCOM is being fired up as administrator ??

Many Thanks
Paul


#5

Here’s one way (The Google told me): http://www.sevenforums.com/tutorials/319748-process-see-if-running-administrator-elevated.html

Andy


#6

Paul,

Set all the apps PHD2, SGP and EQMOD to run as adminstrator.

Chris.


#7

This is a really bad idea. No well written application should need to be run as administrator.

I don’t think that any of the applications mentioned (EQMOD, PHD2, SGP) needs to be run as administrator. I’ve never needed to do so.

SideOfPier issues may depend on how EQMOD is configured, you need to choose the right version and pier side setting to get it to report SideOfPier correctly.

Chris


#8

Through my support of EQMOD I’ve come across this same issue many times - running the client apps as administrator usually fixes things.

My advice still stands and Paul should give it a go. If it does fix his problem then Paul will be in a position to decide whether he prefers to have a broken setup or a working one based upon a bad idea. Whether software is considered “well written” really matters not a jot - folks are stuck with what they’ve got and generally they just want to get things working.

Chris.


#9

Hello all,

With ref to what was running as administrator previously, I fired up SGP, connected to the EQMOD ASCOM Simulator, connected to the V2 Camera Simulator, fired up PHD2, went into Task manager and done what the link said posted by Andy - The results were as follows:

UAC Virtualization setting for SGP and PHD2 were ‘Disabled’ - Settings for all ASCOM stuff I could see was ‘Enabled’ and if anything is running as Administrator it would have had ‘Not Allowed’ so nothing was as administrator from what I could see.

SO I have tried setting SGP, eqmod.exe *32 and PHD2 to ‘Run as Administrator’ in each .EXE’s properties and I can confirm now that set up this way I am not getting a second EQASCOM opening up with the error. Tried it with ‘On-Camera’ set and tested both the EQMOD ASCOM Simulator and my EQMOD ASCOM NEQ5/6 mount mount as the aux mount in PHD and on inspection of the PHD2 log file the side of pier is in there on both accounts so all is well as far as that’s concerned.

Chris_Shillito - It worked, many thanks to you

Chris ASCOM Developer - Im curious why this is so bad, I was under the impression that running a file as administrator just enabled more privileges for the program, obviously im wrong about that, could you enlighten me here ?, im using EQMOD version 1.28m with ASCOM 6.2 installed. What EQMOD settings might make a difference here where I could NOT run as administrator and still have my current result ??

Many Thanks All
Paul


#10

Running as administrator is bad because it allows much more privileges for those programs run as administrator. It’s a bit like leaving your front door open. Better provide limited access to people wishing to deliver things, a letterbox or mail box, than do that.

If running as administrator stops a second instance of EQMOD from loading then this is an indication that something is starting EQMOD as administrator, even though it’s not obvious. The thing to do is find out which and once you know stop it. It doesn’t seem to be SGP or PHD2, is there something else that is starting EQMOD?

I have a very simple way to deal with programs that insist on running as administrator - I uninstall them.

Chris


#11

Great. Thankfully you were brave enough to ignor the warnings and follow my advice - at least now you’ve made some progress.

Given Microsoft provide the ability to run as adminstrator off a simple right click this is clearly an action they anticipate folks may require. You’re not wrong about admin rights - ideally you only want applications to have the rights they need to get their particular job done. When it comes to admin rights its certianly worth keeping an eye on who has them but they are a fundamental part of windows operation so they’re not evil as such!

Yes, ageed, but do we know for sure that the culprit isn’t SGP or PHD2? The thing to do would be to only set one as admin and see what happens - so if SGP is set to run as admin and PHD is returned to its default setting then if only a single instance of EQMOD pops up the finger would point at PHD.

Chris.


#12

Hi Guy’s,
So I had a trawl though everything ASCOM and EQMOD and here’s a story your gonna love !

I did find an .exe file which was set to run as administrator (which I disabled as such) and now everything is not running as admin and a second EQASCOM is not firing up when I set EQMOD ASCOM EQ5/6 as my aux mount in PHD2. All is great now.

Here’s the story you’ll love…Cant remember what file it was or where it was :angry: The Mrs called me to help her in with the shopping and we chatted for a bit, just as I’d disabled ‘Run as Administrator’, when I got back to the computer I couldn’t remember for the life of me what file it was as I’d closed Win explorer already.

If I think of it, ill post it here !

Anyway, all running smoothly now and nothing is running as administrator and no second EQASCOM firing up, thanks so much for all your help guy’s

Best Regards
Paul


#13

Great! Glad you found the real problem. Much better than band aid “fixes”.

Chris


www.mainsequencesoftware.com