Using SGP with Starizona Microtouch and Feathertoucch

Can anyone help me out with initial settings for my focuser? I’m not quite sure where to start and am getting some pretty weird results.


Of particular concern is the 171% complete part–it seems fairly lost.
Thanks in advance for any advice.

I don’t have a Starizona Microtouch/feathertouch system and not knowing your image scale but first at first glance I would say you need to increase your step size. I believe a step size of 10 is to small. I would think something in the 75 to 100 range. But again not knowing your image scale and size of your stepping motor steps this is only a guess. For example for my setup using the nStep focusing system on my SCTs, focusing via the primary mirror, I found I needed to use a step size of 250.

Hope this helps,
Mark

Thanks for your reply. I’m using it on an SCT as well-a Celestron C9.25. Should I be using a backlash setting as well? How about fine and course settings? So many settings!!!
Alan

@alanrock

There are some basics to getting the AF routine configured. First, is that SGP assumes the camera is close to focus when the AF routine starts. The purpose of the AF routine is to maintain a good focus but not to get that initial good focus – especially when the camera is seriously out of focus to begin with. So, either by using a Bahtinov mask or just your eye ball and the HFR reading from the frame and focus routine, get the camera close to a good focus.

At this point you know what the approximate HFR reading is for your scope / camera when close to focus. Make note of this HFR and remember the HFR reading is in pixels, not arc seconds. The AF routine should move the focuser enough on the initial frame (data point) that the first HFR reading is about 3x the “good focus” HFR reading. So adjust the number of steps between data points to achieve that. Also, setup the number of data points to be 9.

You will probably need to bin 2x2 (at least) so that you can use short ( ie, 10 sec) exposures. While doing this initial setup, point your scope somewhere near the zenith at a star field that is free of nebulosity so the AF routine has a clean star field to work on.

Also, the AF option, “minimum star diameter…”, should be something around 3 -> 5.

You will probably not want to use the “smart focus” option, so disable it; at least for the initial setup process. If you are imaging with a system with a central obstruction, you definitely want to disable it.

All the above parameters can be tweaked to improve the consistency of the AF routine.

I am not familiar with the focusers you mentioned but backlash needs to be eliminated. In most ASCOM focuser drivers, you can enter a backlash amount. Probably better to do backlash in the ASCOM driver than in SGP.

If your focuser has temperature compensation, I recommend using it. If the ASCOM driver supports TC directly, better to enable it in the ASCOM driver than in SGP so that the TC adjustments are continuous.

Charlie

I have my backlash setting set to 500 steps. some folks use 1,000 or even 1,500. again it depends on your setup. are you using the primary mirror for your focusing? if so yes I would start with 1,000 steps for your backlash and go from there. I’m not sure, can’t remember, seeing a setting for fine or course, is this a setting in SGP or is it specific to the ASCOM driver? I’m not in front on my observatory computer so I can’t check.

Agree SGPro is a very powerful, excellent, program but it does take time to learn all of the features/functions. But once you do you’ll be asking yourself how your ever got by without it.

Mark

During focusing I bin my camera at 4x4 and use 5 seconds exposures with 9 data points. I never used the Focuser ASCOM backlash I’ve also used the one in SGPro. whatever you do, don’t have them both active. Agree with @chasmiller46 manually get good focus and note the HFR value. Than loop your camera and step out until you see where the HFR is 3 to 5 time greater then the good focus HFR. divide the number by 4 and that should get you a good starting point for how many steps per point you should be using. I’m sure there are other ways but that’s how I did it.

I have smart focus enabled and never had any issues, but I never had the focus fail where the smart focus needed to kick in. maybe just lucky but disabling it, I think, is a good idea for SCTs as well.

If you have a temperature probe I would use it and set it to refocus maybe every .8 or 1 degree C. I never found a way to accurately set the temperature compensation so I don’t use it. others do use it but I just can’t seem to figure out the correct steps per temperature so I gave up on that one.

Mark

So under Control Panel–>Focus I have the Fine and Course steps, and then under the “other” button is where I would set backlash, yes?
image1image2

Or should I be making these changes in the equipment profile?

I would work on getting your testing and your parameters setup in the current generic sequence. just don’t add in any targets. Once you have things setup you can then save the generic sequence as a profile. From there you can apply the profile you just saved to any sequence you wish to start. I have several profiles for my different scopes and cameras I use. If you want to update a profile you can always apply the profile you want to work on to a blank/generic sequence do your testing/update then save the sequence as a profile back onto the profile. This will overwrite the old profile. Just don’t add in any target information as every time you call in that profile the targets will always be there. Think of a profile as your starting template that contains all of your equipment information and settings you need to use for every sequence you want to start. You apply the profile to sequence update the sequence with your specific target information then save the sequence. if you edit the sequence only the sequence is updated and saved but the profile that was used to get you started is not changed.

For the focuser compensation, yes that is what I use. I check the “Focuser backlash compensation” and keep the “iN” and set the “Compensation step size” to 500.

Now I see what you’re referring to about the Fine and Coarse. these are the number of steps you want your stepping motor to take when you press the Fine or Coarse buttons. For your example if you select the In: “Fine” button your stepper motor will move 50 steps if you press the In: “Coarse” button the stepper motor will move 150 steps. I very rarely ever use them. However that’s what you want to use to get your focuser to move when you start working on determining your step size to use for your autofocus setup.

Hope this helps and is not to confusing.
Mark

Thanks for the help, I really appreciate it. I’ll probably put some more time into it tonight, moon time is learning time!
Although I did actually achieve a decent focus using the default settings, the focusing took forever and it seemed a bit lost, I think I killed it when it said 250% complete or something like that. Also, I was expecting more of a V curve, and I got no such thing.
Thanks again!
Alan

10 steps seems way too low. As mentioned those settings don’t do anything for auto focus. They allow you to manually jog the focuser and that’s is. To setup auto focus you need to click the “Set” button next to “use auto focus”:

I would also recommend this from our help docs about getting auto focus setup:

http://mainsequencesoftware.com/Content/SGPHelp/UnderstandingAutoFocus.html

Thanks,
Jared

Thanks again everyone, I’ll spend some more time with the support docs. I increased my step size to 100 and turned on the backlash compensation with a value of 500. I did 9 data points and binned 2x2 with an exposure time of 2 seconds. (I’m using a Hyperstar, so I’m at f2.3). It worked like a champ!!

Although now that I have read the tutorial. perhaps I should run through that process to see if it will make my U curve into more of a V curve. Do you think that’s necessary?

The shape of the graph greatly depends on your seeing conditions. when seeing isn’t very good I get more of a “U” shape curve. As seeing improves my “U” shape starts to look more like a “V”. From your plot you posted I’d say you’re almost there with the 100 step size. from in focus, approx 1.7 HFR, to out of focus, approx 3.8 HFR, you are slightly better then a ratio of 2. I would try increasing your step size to maybe 125 or 150 to see if you can improve that ratio to maybe 3. the higher ratio might help with getting the “V” curve. as I mentioned, the shape of the curve will depend on your seeing. Also, since you are using a SCT, be careful not to increase the steps to high, Donuts could become an issue if you get to far out of focus.

Mark

www.mainsequencesoftware.com