Waiting for SAFE to resume, but thinks it isn’t running a sequence

Useful Info

OS: Windows 10
Ver: 3.1.0.399

Description

I was happily imaging until an UNSAFE condition triggered a shut down. The system was waiting for SAFE to resume, but the sequence window showed a ‘Run Sequence’ button, not the ‘Pause Sequence’ button. It all appeared to think that it was not running a sequence, but it was still in a sequence. All a bit confused. Anyway, I tried clicking ‘Run Sequence’ and it immediately started running sequence and wanted to shut down due to unsafe (I think anyway, can’t really remember the exact results of that, but it was all wrong!). I manually aborted the sequence.

Steps to Reproduce this Issue

*I haven’t tried to reproduce this. *

Logs
https://www.dropbox.com/s/9s54511hzoxl7ta/sg_logfile_20191203164329.log?dl=0

To get logs: In SGPro click the Help->Open Log or if you are looking for logs from a previous session, Help->Open Log Folder and search by date.

Please download the final 3.1 release.

Ok, will do. Is that a known issue resolved in 3.1.0.402?

Related to this issue: SGPro 3.1.0.399: Pause Choices have changed

Yup, thank you. I’ve just installed .402, did a shutdown on UNSAFE and am happy to confirm that it all works as it should now and the Pause Sequence button appears.

Having said that, I did notice some slight weirdness… I clicked Pause Sequence while it was waiting to resume on SAFE and I aborted the sequence. I then did a Reset Sequence, Preserve Progress. Conditions were SAFE again and I clicked Run Sequence. It started running, but came up with the 300 second timer waiting for SAFE to persist before restarting the sequence. Is that the way it should work? Essentially I was starting a whole new sequence run, so it shouldn’t worry about 300 seconds of safe… or should it?!

No, we need to reset that old state for UNSAFE during reset… I’ll tidy that up.

Good stuff. Definitely not a show stopper!
Congrats on all the successful development recently. I feel like SGP has taken a big step forwards and is really quite stable now. (Famous last words!!). Loving all the new or upgraded features.

3 Likes