Why is SGPro and PHD2 so difficult to get working?


#1

I am trying to get SGPro working with PHD and frankly is seen excessively complicated or unclear. This is the process I am following:

(1) I run SGPro and connect up the camera, mount etc.
(2) I run PHD2
(3) In SGPro I start a sequence.

I am using an SBIG STX camera with remote Guide Head. When connecting equipment I have the SGI Guider (ASCOM) selected in PHD along with the AP1600GTO mount.

What is not at all clear is whether I select the guide star and start tracking in PHD (which I am quite familiar with) before I start a sequence, or I Start a sequence first.

Worse. I can only generate one frame before I keep getting a message in PHD: “Camera timeout during capture. The camera has been disconnected. Please resolve the problem and re-connect the camera”. The whole rest of the sequence aborts also. It seems to do this while the camera is downloading.

How can I just setup a sequence and forget about it? Getting very frustrated as PHD is easy to setup but in synch with SGPro I find it difficult to find a simple dummy explanation in one place. (At least in a way that is visible to me)


#2

Unfortunately your setup is necessarily complicated because only one application can use your camera, yet 2 require it. Your process should be to set up the proper guide camera in SGPro’s camera settings, then connect to the camera in SGPro. You cannot connect to the camera in PHD2 until this is done.


#3

Yes I do all that. I have read the documentation. I have looked through various posts on this forum. I am fairly certain that I am setup correctly unless there is some value not set correctly and indeed I can image one frame successfully. Can you explain why I get a message in PHD: “Camera timeout during capture. The camera has been disconnected. Please resolve the problem and re-connect the camera” after only one frame?


#4

You can send me an email and we can try to work through it via Team Viewer. Can you post your logs as well? Upload them to drop box and post the link here.


#5

I don’t mean to be flippant, but are you sure all your USB cables/hubs are working properly? This sounds like a random disconnect to me, and USB cables are the first thing I check with things like this.


#6

Feel free to be flippant… I can certainly make dumb mistakes!

I think the cables and USB connections are fine though. As mentioned I can successfully guide and image one frame, it is only when saving the image file to disk, that PHD gives me the time out message. I can also successfully image with another application like CCDops. Also if I run PHD on its own it tracks and guides perfectly well.

I have noticed in the PHD “brain” controls under the Camera tab, there is a field to enter a “time before a non-responsive camera is disconnected”. It defaults to 5 seconds. Perhaps that needs increasing to 60 seconds or something?

Chris


#7

Can you post your PHD2 and SGP logs? We can’t help you without seeing what is going on.


#8

Here is the Dropbox link to the log file that towards the end shows the timeout errors. Is this as simple as me needing to increase the “time before a non-responsive camera is disconnected” field in PHD to a very high number? (I won’t be able to try that out until it gets dark of course)

Thanks for taking a look!

Chris


#9

And here is a PHD log file from last night during the same session:

Chris


#10

Yes, you do need to increase the timeout time. 60 seconds is what I use.


#11

Thanks. I made some progress tonight and managed to guide and image multiple images in sequence. I found out:

(1) Extending the “Non-Responsive Camera” field in PHD to 100 seconds eliminated the time out error. (The default 5 seconds is far too small)

(2) In the autofocus tab, setting the “Settle” time to 0.2 rather than the default 0.1 pixel sped things up a bit.

Getting there.

Chris


#12

This is great advice. I’ve seen people their gear with 5 cables they got for $7 and have problems. You don’t need Monster cables but good quality cables make a difference especially when you might have power cables and data cables close together. One thing you can do is route power cables like dew heaters, away from the data cables. Keep in mind that all USB cables are also power cables and that’s why good shielding internally in the cable makes such a difference.


#13

That is for sure. This article is about HDMI, but the same logic applies to USB…

Monster Overpriced

I have had good luck with all but the cheapest USB cables and have found that securing the cable just short of the connectors to prevent flex is way more important than cable brand.


#14

I just replace cables whenever I have trouble with a device. Last set lasted nearly 3 years :slight_smile:


www.mainsequencesoftware.com