Windows 10 updates - you might want to go pro


#1

Having just built a new PC with windows 10 pro, I ran across something that I was not aware of that could cause problems for imaging done with automation like SGP.

They have eliminated the option to “download and notify” before installing updates. There are some time limitation options where you can limit when restarts happens but you can’t have it ask before doing so as was the case with previous versions. If things are unattended, it is quite possible, depending on how you have things set and when you are imaging, for it to do a restart that ruins a session.

However, it is still possible to get it to behave like the older versions and download updates but only install after asking. The catch is that you need to set this in the group policy editor - it is not in the main update settings area as before. Also, this option is only available in pro versions, not in home.

If there is a workaround or this information is not correct, please let me (and others) know.

I will say that generally I have found 10 to be OK and SGP and PhD2 have run very well so far.


#2

According to reports I’ve read, the group policy setting no longer works in
the Anniversary Update. The option is still there in the Group Policy
Editor, but apparently it doesn’t work. This would be very useful as I
have never been comfortable with Windows forcing updates and restarts. I
have changed the GP setting on one of my computers so I’ll see if it works
or not.


#3

Interesting. I have also changed the setting and we shall see. Microsoft is getting more and more like Apple and the “we know better than you do” attitude these days. Maybe time for a Linux version of SGP if this crap continues.


#4

What I do to avoid windows updates is to flag my internet connection as “metered” and that disable automatic updates.

Cheers,

Jose


#5

Yes, that is another option. I hate to do that since I would rather they download in the background but not install until I am ready but will use that option if indeed the group policy fix does not work


#6

I have Windows 10, not the pro edition. This what I do to disable updates.
In the cortina window, TYPE ‘services.msc’ (without the quotations), press enter.
In the services window scroll down to Windows Update. In that window you can change the option to disabled in the startup type, click apply, then okay.
This will disable all updates, if you wish to install any updates, go back into services, and select automatic. Not the most eloquent solution but it works.
I do not know if this is the same for Windows 10 pro.
Ed Stuckey


#7

Just to update this thread, it appears that the group policy setting indeed no longer works after the anniversary update. I changed the group policy setting and yesterday an update was downloaded and windows informed me the update would install outside of active hours. I had no choice in the matter.


#8

Damn arrogant Microsoft. I have to wonder if they are not going to get sued when some mission critical PC shuts down during a critical operation. Very bad idea. I may have to meter my connection. Idiots.


#9

doing as @estuckey describes above does work. i tried the metering thing and it did not help; i got an update the very next day. so i’ve disabled the update service.


www.mainsequencesoftware.com