Wrong directory saving flats for 2.5.10


I used 2.5.10 last night and overall it worked ok.

But at the start I loaded a previous sequence file to create flats and changed the displayed directory to a new one. I confirmed it was showing correctly. But when the flats were created - they were saved to the original directory.

I have not downloaded a beta for a while, so I don’t think I would have created a sequence file with one of the short-lived betas that somehow messed up the files.

Attached is a log. Test38 is the old directory that I did not want to save to. The displayed directory that I had selected for the sequence - and that was displayed on the screen - was Test40.

FrankBadDirLog2510.zip (138.7 KB)



Point of clarification since directories can be defined in 2 places. When you say this do you mean you changed the base imaging path (red arrow) or the file naming pattern (blue arrow) or both?


Hi Ken,

I also got hit by this.

There are two places to setup the default value for the File naming pattern:

  • The first one is under the SG Options, together with the base directory.
  • The second one is under the Equipment Profile (only the Filename).

It is not clear which one takes precedence.

From the way I am using SGP, the file naming pattern and the basis directory are global settings, i.e. they should stay under Options and should not change with the profile.

And they should be settings and not defaults as the possibility of having them changed at the sequence level would just make the directory structure on my HD even worse than it already is.



There is no precedence for use during the sequence. Anything other than the actual field in the sequencer is just a template or default value so you don’t have to keep typing your file name pattern out. The only one that matters is the one the blue arrow points to.

In terms of precedence of template values (the question asking: does the pattern in options dialog or the pattern in the profile get selected), the profile will always win. If it is blank, it will use the pattern in the options dialog. If that is blank, then SGPro will plug in a default value for you.

OK. That’s fine, just leave the ones in your profiles blank. We designed it this way so you can use it like you say above or have “by profile” control of file naming.

I don’t know what this means.

Also, I don’t think this is what @freestar8n was talking about. To make sure we don’t hijack his thread, you should start a new one (use the “Reply as linked topic” button to the right of this post) if you want to discuss this more.



I used browse to set the directory as displayed by the red arrow. It was displayed to what I set it to - Test40. The flats ended up in the correct subdirectory of Test38 - the original directory used for the sequence. That is not what I wanted.

I never changed the blue part. It seemed to work fine - but ended up in the wrong parent directory.

The log makes no reference to the directory string indicated by the red arrow that was displayed (Test40).



I cannot reproduce. Will leave open in case somebody else can…