ZWO ASI1600MM-Cool Image Download Hanging


#1

I have had some good sessions with the ASI1600MM-Cool and the latest SGP v2.5.1.14 release with ASCOM driver version v1.0.2.5 from ZWO. Yesterday, however, as I was trying to take a sequence of dark and bias frames at a new temperature for my dark library I encountered an issue where the sequence would work correctly for a few frames (sometimes as many as ~30, but usually just a couple) and then would hang while attempting to download a frame. If I waited long enough the sequence would abort. I am using Windows 8.1 Pro, the camera is directly connected to the computer with a USB 3.0 cable (provided with the camera), and I have tried restarting SGP, disconnecting everything from the camera to reset it, etc. but the problem persists. I was previously able to get through 5-6 hours of exposures using this same setup without issues.

I have attached sample logs of the problem occurring below. I can also provide the sequence file if it will be helpful, but this forum doesn’t allow it to be attached due to file name extension restrictions.

sg_logfile_20160531200100.txt (367.4 KB)
sg_logfile_20160531210327.txt (185.4 KB)

Thanks,

Kyle


#2

Kyle,
We have been working very closely with ZWO to resolve some issues but your issue actually seems different than what we’re seeing with the ASI1600. How is the device connected? Are you going through a hub?

Thanks,
Jared


#3

Maybe linked to this.
I am definitely interested in how the ASI1600 is working with SGP :slight_smile:
Olivier


#4

Similar, but a little different. the ASI1600 works “mostly ok” but it seems a few users are still experiencing random issues. Those that have issues are generally reporting Memory problems. This is the first occurrence of a timeout I have seen.

With SGP 2.5.1.4 and the ZWO ASCOM 1.0.2.5 drivers I haven’t seen either problem though. I’ve gone through thousands of frames on all types of hardware with that combination (even my very anemic windows 10 tablet!) and that combo seems pretty stable for the most part. So I’m wondering if this issue is something else entirely.

Thanks,
Jared


#5

Jared, thanks. Yes I’ve been talking to Sam about it and I have tried two previous ASCOM driver versions which did have memory issues as mentioned. This is definitely different. There is no hub involved. The camera is connected directly to the USB 3.0 port on my laptop with the USB 3.0 cable provided with the camera. When I did previous runs I could do thousands of images over many hours with no problems as you say. This just started happening yesterday afternoon. It is possible that my previous testing was with a different cable. I have several lying around and might have used a different one previously since the one from the camera is pretty short. I can try with a different cable tonight if you think it might be related to that. I can also test connected to a powered hub rather than directly to the laptop, but my previous testing was direct to the laptop as well.

I’m still waiting for some filter wheel adapters to do the final mounting of my imaging train on my scope and connect it to my normal hub setup, so that’s really the configuration I should be testing. I may attach it through that setup to test also even without the correct mechanical adapters to mount the camera.


#6

Since this started happening yesterday afternoon I haven’t had any successful sequence runs whereas previously all my sequence runs were successful with latest SGP and latest ZWO ASCOM driver. I tried 4-5 sessions yesterday afternoon and evening all with this same result.


#7

Interesting. I would try to go back to the state where everything was working and see if that solves things. Maybe the hub was down clocking to USB 2.0? I believe I’ve primarily been testing with a USB 2.0 port as I’m too lazy to get to the back of my desktop where the 3.0 ports reside. I can try that this evening though. We might be on to something as I believe my tablet only exposes a 2.0 or maybe even 1.1 port (downloads were very slow…but that could also have been the star analysis on the SGP side)

Thanks,
Jared


#8

The working configuration was also direct to the laptop, but I will try both with other USB 3.0 cables, a USB 3.0 powered hub, and via USB 2.0 and see what the results are in each case.


#9

KGoodwin,

While you’re talking with Sam, please express/stress the importance of naming the drivers properly in the UI.

Right now…they appear as ‘ASI Cameras ASCOM driver’ and ‘ASI Cameras ASCOM driver 2’

http://zwoug.org/viewtopic.php?f=21&t=6378

They should appear more clearly as ASI Camera (1) and ASI Camera (2). No need to put ASCOM in the name, but more important to note that they support two cameras at the same time.

Using mine (ASI1600MC-Cool) last night was good in SGP (2.5.1.14) for 2.5 hours of testing.


#10

I think the post on the ZWO forum got the message through; I don’t think I need to worry about that in my communication with him or in this thread also. I don’t personally care about the naming anyhow if everything works well.


#11

If you’re a developer…you should care about such things as it reduces support requests due to confusion.


#12

I am a developer. I’m not the developer of the ZWO ASCOM driver, though, or SGP.

I was trying top be nice, but I’ll just be direct.

You’re derailing my thread which I created to try to work through an issue I’m having with my camera with SGP. I’m not here to be everyone’s conduit of communication to ZWO and I’m not here as a developer of some other software. I’m here to get support for my hobby for software I own. Please stop.


#13

I am testing right now and so far no problems. I have hooked the camera up to my normal imaging setup which involved 2 USB 3.0 powered hubs and an active USB 3.0 extension cable which is effectively another hub. I’ve made it through 42 images so far without a problem. I have another 19 hours left on this sequence of dark exposures, so I will report back again when it completes if there are still no issues, but it may well have been the cable. Sorry to bother you if that’s the case!


#14

My test was successful, no issues. I believe the USB 3.0 cable I was using was the problem.


#15

Great it’s working. I just saw a thread on cloudy nights regarding USB 2 vs USB 3 and this camera, perhaps it may shed some light: http://www.cloudynights.com/topic/539123-i-finally-got-it-asi1600-apt-bias-question/


#16

I believe the memory issues have been resolved. Please see this thread if you’re interested in that. For the most part these were generally handled with the ZWO 1.0.2.5 ASCOM driver but still happened very rarely.

Thanks,
Jared


#17

Hi guys,

I received my ASI1600MM-cool yesterday and have been trying to capture some bias frames this morning and am having issues very similar to those reported in this thread.

Using frame & focus I seem to be able to capture an unlimited number of frames without a problem with ‘0 second’ subs. As soon as I try to use the sequencer I run into issues.

I’m using ZWO ASCOM driver v1.0.2.7 and SGP 2.5.1.15. Camera is connected directly to the computer via USB 3, with the supplied cable (no hub). I’ve tried changing the USB limit to 45 and 90, with no effect.

When using 1 second exposures, I can consistently capture the first exposure in the sequence before it fails to download subsequent subs. Using anything less than 1 second has failed to deliver any subs. I get no error messages, nor does the application crash, it just sits there saying “Downloading” in the status bar until I give up.

After failing to download an image using the sequencer, frame & focus is no longer able to download subs. Disconnecting and reconnecting the camera via SGP has no impact. After restarting SGP and connecting the camera I will again be able to use frame & focus.

I’ve also tried putting a 20 second delay in between the capture of 1 second subs, but it still failed to deliver more than the first sub.

I’ve tried once to capture 2x60s exposures with the same result: sequencer delivers 1 sub, fails to download the second.

Due to the fact that fame and focus seems to work flawlessly, but the sequencer does not, I doubt it’s a USB cabling issue like the OP believed was causative of his issues; this definitely seems to be caused by software.

If there’s anything else I can provide to make debugging this easier please let me know.

Cheers,
Lee


#18

According to ZWO web site, the latest driver is 1.3.5.20 for this camera.

http://astronomy-imaging-camera.com/software/

EDIT: Never mind. That’s for non-ASCOM driver. Sorry about that. But you may need 1.3.5.20 to work with ASCOM driver?

Peter


#19

That’s correct, Peter, but I’m referring to their ASCOM driver version, which is 1.0.2.7. I also have the 1.3.5.20 “Camera driver” installed.

EDIT: heh. You snuck in your edit whilst I was writing my response. Yes, I also have 1.3.5.20 installed.


#20

Update: I’ve now been able to (once) capture a zero second sub using the sequencer, so I’m not sure if the exposure length is related.

I’ve also found that if I leave it long enough, I will eventually (after about 8mins) get a message informing me of the camera timeout.

I found the logs, and have attached one, which will hopefully aid in debugging the issue.

sg_logfile_20160611094738.txt (70.7 KB)


www.mainsequencesoftware.com